Connectrix SANnav:備份失敗,並顯示錯誤「無法將備份檔案複製到指定路徑」
Summary: Windows NFS 伺服器不允許 root 存取,這會使 SANnav 無法變更備份檔案的擁有者和群組。
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
備份路徑是 Windows 伺服器的 NFS 共用。
排定和手動備份皆失敗,並出現「無法將備份檔案複製到指定路徑」錯誤。但備份檔案已成功產生。
這是在 SANnav 2.3.x 上觀察到的SANnav 2.2 不會使用相同的 NFS 共用報告此錯誤。
Cause
mw-consolidated-2.log顯示 chown 命令。
mw-consolidated-2 - [INFO ] 2024-09-24 09:21:26.022 [pool-90-thread-1] com.brocade.dcm.backuprestore.core.BackupGenerator - Response received from backup script : Picked up JAVA_TOOL_OPTIONS: -Djava.net.preferIPv4Stack=true
Picked up JAVA_TOOL_OPTIONS: -Djava.net.preferIPv4Stack=true
Picked up JAVA_TOOL_OPTIONS: -Djava.net.preferIPv4Stack=true
Picked up JAVA_TOOL_OPTIONS: -Djava.net.preferIPv4Stack=true
Picked up JAVA_TOOL_OPTIONS: -Djava.net.preferIPv4Stack=true
chown: /<NFS mount point>/<backup filename>.tar.gz: Permission denied
當 Linux 使用者在 Windows 伺服器上沒有對應關係時,NFS 路徑中的新檔案會屬於「匿名」使用者和群組。
[root@<sannav hostname>]# ll total 128535364 -rw-r--r--+ 1 4294967294 4294967294 3947527003 Aug 1 02:11 dcm-New_backup_<name>-08-01-2024-02-00-00.tar.gz -rw-r--r--+ 1 4294967294 4294967294 3956913210 Aug 2 02:11 dcm-New_backup_<name>-08-02-2024-02-00-02.tar.gz -rw-r--r--+ 1 4294967294 4294967294 3965818644 Aug 3 02:11 dcm-New_backup_<name>-08-03-2024-02-00-01.tar.gz <truncated> (By default, the Windows OS uses UID/GID "-2" for anonymous, "-2" --> 32bit Binary --> Decimal = 4294967294)
SANnav 2.3.0 引入了使用者/群組「sannavmgr」和 2.3.x 備份指令檔要求,以將備份檔案的擁有者和群組變更為「sannavmgr」。
Windows 伺服器會拒絕匿名使用者的 chown 要求,因此備份指令檔會在記錄檔中記錄「權限遭拒」錯誤,並在 SANnav UI 中顯示「無法將備份檔案複製到指定路徑」訊息。
SANnav 2.2.x 無法執行 chown 因此,在備份期間不會遇到此問題。
Resolution
在 Windows NFS 伺服器上啟用「Allow root access」 然後在 Linux 主機上為 SANnav 重新掛接 NFS 共用
Products
Connectrix, Connectrix SANnavArticle Properties
Article Number: 000234211
Article Type: Solution
Last Modified: 15 Oct 2024
Version: 1
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.