NVP vProxy : La sauvegarde de la machine virtuelle ne parvient pas à télécharger le fichier .vmx de la machine virtuelle Erreur serveur interne HTTP 500

Summary: NetWorker VMware Protection (NVP) est configuré. Lors des sauvegardes de machine virtuelle (VM), une sauvegarde de machine virtuelle échoue, signalant qu’elle ne parvient pas à télécharger le fichier .vmx de la machine virtuelle. Code d’état HTTP : Le message 500 (erreur de serveur interne) est renvoyé. ...

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Symptoms

Lors d’une sauvegarde de machine virtuelle NetWorker VMware Protection (NVP), la sauvegarde échoue et l’erreur suivante est consignée dans le journal de la session de sauvegarde de la machine virtuelle :

  • NetWorker Server :

Linux : /nsr/logs/policy/POLICY_NAME/WORKFLOW_NAME/JOBID_VM-NAME_TIMESTAMP.log
Windows (par défaut) : C:\Program Files\EMC NetWorker\nsr\logs\policy\POLICY_NAME\WORKFLOW_NAME\JOBID_VM-NAME_TIMESTAMP.log
 

Remarque : Les logs de politique de NetWorker Server respectent le jobsdb retention (72 heures par défaut), les logs antérieurs à la fenêtre de rétention sont automatiquement supprimés. Les logs de la session de sauvegarde se trouvent également sur l’appliance vProxy et ne sont pas affectés par le jobsdb retention.

 

  • Appliance vProxy :

/opt/emc/vproxy/runtime/logs/recycle/vbackupd/DATE/BackupVmSessions-SESSION_ID.log

YYYY-MM-DDTHH:mm:SS ERROR:  [NETWORKER-BUILD] UUID-VCENTER-NAME:VM-MOREF: HTTP Get request failed to download config file '[DATASTORE-NAME] VM-NAME/VM-NAME.vmx' using URL 'https://VCENTER-NAME/folder/VM-NAME/VM-NAME.vmx?dcPath=DATACENTER-NAME&dsName=DATASTORE-NAME'. HTTP Status code: 500.
YYYY-MM-DDTHH:mm:SS ERROR:  [NETWORKER-BUILD] Failed to download VM config file "[DATASTORE-NAME] VM-NAME/VM-NAME.vmx" into saveset file "VM-MOREF-config-file-0.cfg".

La commande /var/log/hostd.log sur les machines virtuelles (ESXi), l’hôte signale les éléments suivants :

YYYY-MM-DDTHH:mm:SS Wa(164) Hostd[79374775]: [Originator@6876 sub=Vmsvc.vm:/vmfs/volumes/UUID/VM-NAME/VM-NAME.vmx] File - failed to get objectId, '/vmfs/volumes/UUID/VM-NAME/VM-NAME.vmx': Operation not supported (11)

Cette erreur coïncide avec le moment où HTTP 500 Une erreur a été observée lors de la sauvegarde des machines virtuelles. 

Cause

La commande HTTP 500 (Erreur de serveur interne) dans le journal de la session de sauvegarde de la machine virtuelle est renvoyé à partir de l’environnement VMware. Le workflow de sauvegarde vProxy envoie un HTTP GET demande d’obtention des fichiers de configuration de la VM ; Toutefois, le vCenter répond avec HTTP 500 (Erreur de serveur interne)

Le hostd Message d’erreur "Operation not supported (11)» indique généralement un problème d’accès ou de manipulation du fichier de machine virtuelle spécifié dans VMware.

Il y a plusieurs causes qui pourraient entrer en ligne de compte dans cette erreur ; Toutefois, la plupart sont au niveau ESXi :

  • File permissions : l’hôte ESXi ne dispose pas des autorisations nécessaires pour accéder au fichier.
  • Accessibilité du datastore : problèmes de connectivité entre l’hôte ESXi et le datastore.
  • Agents de gestion : l’hôte ESXi hostd et vpxa Les agents rencontrent des problèmes.
  • Problèmes d’espace disque sur l’hôte ESXi
  • Problèmes liés au fichier de configuration de la machine virtuelle
  • L’hôte ESXi nécessite des mises à jour

Resolution

Remarque : Ce problème se produisant au niveau de VMware, il est vivement recommandé de contacter le support VMware. Les étapes suivantes peuvent être utilisées pour faciliter le diagnostic du problème. L’administrateur VMware doit effectuer toute action dans l’environnement VMware.


Vérification des autorisations NetWorker VMware Protection (NVP) : 

La commande ProxyHC utility Peut être utilisé pour valider les autorisations d’accès aux sauvegardes. La commande ProxyHC utility n’est pas fourni sur l’appliance vProxy par défaut.

Voir NVP-vProxy : Utilisation de l’outil de bilan de santé ProxyHC sur l’appliance vProxy
./ProxyHC perm
Corrigez les problèmes d’autorisations manquantes identifiés par ProxyHC.
 
Remarque : ProxyHC ne vérifie pas que l’hôte ESXi dispose des autorisations nécessaires pour accéder aux fichiers de la machine virtuelle. ProxyHC Vérifie que le compte d’utilisateur utilisé pour exécuter NetWorker VMware Protection dispose des autorisations appropriées. Les autorisations sont documentées dans le Guide d’intégration de NetWorker VMware, disponible via https://www.dell.com/support/home/product-support/product/networker/docs
 
Ce problème peut se produire lorsque le chiffrement VMware est activé, mais que le compte d’utilisateur vCenter pour NetWorker ne dispose pas des autorisations cryptographiques : NetWorker NVP-vProxy : Backup error: Échec du téléchargement du fichier de configuration de la machine virtuelle. Code d’état HTTP : 500

Lorsque le chiffrement VMware est activé, le compte d’utilisateur doit disposer des autorisations suivantes :
  • Opérations > cryptographiques Ajouter un disque
  • Cryptographic operations > Direct access
  • Autorisations cryptographiques Enregistrer la > machine virtuelle
L’administrateur VMware doit vérifier l’autorisation des fichiers sur l’hôte ESXi.

Accessibilité du datastore :

Dans VMware vSphere Client, vérifiez si l’onglet Datastore contient des erreurs d’accessibilité. En cas de problème de connectivité intermittente, vérifiez que la console des événements vSphere ne présente pas d’erreurs ou de défaillances concernant l’accès au datastore.

Agents de gestion :

Vérifiez les paramètres de hostd et vpxa agent pour détecter toute erreur.
Composant Rapport Description
Journal de l’agent hôte ESXi /var/log/hostd.log Contient des informations sur l’agent qui gère et configure l’hôte ESXi et ses machines virtuelles
Log de l’agent vCenter Server /var/log/vpxa.log Contient des informations sur l’agent qui communique avec vCenter Server (si vCenter Server gère l’hôte)
Dans certains cas, le redémarrage des agents peut résoudre le problème :
/etc/init.d/hostd restart
/etc/init.d/vpxa restart

Problèmes d’espace disque ESXi :

Assurez-vous que l’espace disque disponible sur l’hôte ESXi est suffisant. Utilisez la commande vdf -h pour vérifier l’espace disque.

Corruption du fichier de configuration de la machine virtuelle :

Vérifiez l’accès au .VMX en dehors du workflow de sauvegarde. En utilisant la page .vmx URL de fichier dans le journal de session de la machine virtuelle, utilisez une ou plusieurs des options suivantes pour valider l’intégrité du fichier VMX :
  • Enregistrez à nouveau la machine virtuelle.
    • Cliquez avec le bouton droit de la souris sur la machine virtuelle, puis cliquez sur Supprimer de l’inventaire (NE PAS SUPPRIMER DU DISQUE !)
    • Parcourez le datastore, localisez le fichier .vmx de la machine virtuelle et ajoutez-le à nouveau à l’inventaire.
  • Sur l’appliance vProxy, ouvrez une session SSH, puis exécutez la commande curl suivante. Remplacez le nom d’utilisateur vCenter par le compte d’utilisateur utilisé pour effectuer les sauvegardes de machines virtuelles. Remplacez l’URL par l’URL identifiée dans le journal de session de la machine virtuelle :
curl -v -k --user VCENTER_USER_ACCOUNT "VMX_URL"
Exemple :
admin@nsr-vproxy02:~> curl -v -k --user administrator@vsphere.local "https://vcsa.amer.lan/folder/05b58d65-4eef-c1d2-5070-00505606604d/rhel-client03.amer.lan.vmx?dcPath=vSAN%2520Datacenter&dsName=vsanDatastore"
Enter host password for user 'administrator@vsphere.local':
*   Trying 192.168.9.111:443...
* Connected to vcsa.amer.lan (192.168.9.111) port 443 (#0)
...
< HTTP/2 200
...
CONTENTS OF .VMX File
* Connection #0 to host vcsa.amer.lan left intact
 
Remarque : HTTP 200 Indique une réussite GET Demande du fichier VMX. La sortie contient également le contenu du fichier vmx de la machine virtuelle. Vérifiez que le contenu du fichier est correct et qu’il n’y a aucun signe de corruption. Si la commande curl renvoie un autre état HTTP (404, 500, etc.), le support VMware doit être contacté.
 
  • À partir d’un navigateur Web ayant accès à l’adresse vCenter. Saisissez/collez l’URL à partir du log de la session de machine virtuelle. Saisissez les informations d’identification du compte d’utilisateur vCenter utilisé pour les sauvegardes :
téléchargement d’un fichier VMX à partir d’un navigateur
 

Remarque : Si le test réussit, le fichier vmx est téléchargé. Vérifiez que le contenu du fichier est correct et qu’il n’y a aucun signe de corruption. Si le navigateur renvoie d’autres erreurs HTTP (404, 500, etc.), le support VMware doit être contacté.


Gestion des versions de VMware vCenter et ESXi :

Consultez la matrice de compatibilité NetWorker correspondant à votre version de NetWorker. 

https://elabnavigator.dell.com/eln/modernHomeAutomatedTiles?page=NetWorkerDans le Guide de tous les composants NetWorker, reportez-vous à la Matrice de compatibilité NetWorker NVP (proxy).
Utilisez la dernière version majeure de vProxy prise en charge par votre version de NetWorker et compatible avec votre version d’ESXi.
Idéalement, vCenter Server et les hôtes ESXi doivent avoir la même version et la même version de mise à jour.

Solution de contournement :

L’une ou l’autre des solutions de contournement suivantes peut être testée : Toutefois, chaque option peut n’être qu’une solution temporaire :

  • Effectuez un VMware vSphere vMotion hôte et stockage de toutes les machines virtuelles signalant ces défaillances. Après avoir exécuté vMotion sur la machine virtuelle, effectuez une sauvegarde à partir de NetWorker.
  • Redémarrez les hôtes ESXi contenant les machines virtuelles signalant ces problèmes lors des sauvegardes. Une fois l’hôte ESXi de nouveau en ligne, vérifiez si les sauvegardes de machines virtuelles ont réussi pour les machines virtuelles résidant sur cet hôte.

Dans les deux cas, le support VMware est recommandé pour trouver la cause première de ce problème. 

Affected Products

NetWorker

Products

NetWorker Family
Article Properties
Article Number: 000240662
Article Type: Solution
Last Modified: 07 Nov 2025
Version:  5
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