NVP vProxy: Il backup della macchina virtuale non riesce a scaricare il file .vmx della macchina virtuale Errore interno del server HTTP 500
Summary: NetWorker VMware Protection (NVP) è configurato. Durante i backup di macchine virtuali (VM), un backup di VM ha esito negativo e segnala che non riesce a scaricare il file .vmx della VM. Codice di stato HTTP: Viene restituito 500 (errore interno del server). ...
Symptoms
Durante il backup di una VM NetWorker VMware Protection (NVP), il backup non riesce e nel log della sessione di backup della VM viene registrato il seguente errore:
- Server NetWorker:
Linux: /nsr/logs/policy/POLICY_NAME/WORKFLOW_NAME/JOBID_VM-NAME_TIMESTAMP.log
Windows (impostazione predefinita): C:\Program Files\EMC NetWorker\nsr\logs\policy\POLICY_NAME\WORKFLOW_NAME\JOBID_VM-NAME_TIMESTAMP.log
jobsdb retention (impostazione predefinita: 72 ore), i registri precedenti alla finestra di retention vengono rimossi automaticamente. I registri della sessione di backup sono disponibili anche sull'appliance vProxy e non sono interessati da jobsdb retention.
- Appliance vProxy:
/opt/emc/vproxy/runtime/logs/recycle/vbackupd/DATE/BackupVmSessions-SESSION_ID.log
YYYY-MM-DDTHH:mm:SS ERROR: [NETWORKER-BUILD] UUID-VCENTER-NAME:VM-MOREF: HTTP Get request failed to download config file '[DATASTORE-NAME] VM-NAME/VM-NAME.vmx' using URL 'https://VCENTER-NAME/folder/VM-NAME/VM-NAME.vmx?dcPath=DATACENTER-NAME&dsName=DATASTORE-NAME'. HTTP Status code: 500. YYYY-MM-DDTHH:mm:SS ERROR: [NETWORKER-BUILD] Failed to download VM config file "[DATASTORE-NAME] VM-NAME/VM-NAME.vmx" into saveset file "VM-MOREF-config-file-0.cfg".
La colonna /var/log/hostd.log sull host VMs (ESXi) segnala quanto segue:
YYYY-MM-DDTHH:mm:SS Wa(164) Hostd[79374775]: [Originator@6876 sub=Vmsvc.vm:/vmfs/volumes/UUID/VM-NAME/VM-NAME.vmx] File - failed to get objectId, '/vmfs/volumes/UUID/VM-NAME/VM-NAME.vmx': Operation not supported (11)
Questo errore coincide con il momento in cui l'opzione HTTP 500 errore durante il backup delle macchine virtuali.
Cause
La colonna HTTP 500 (Errore interno del server) nella sessione di backup della macchina virtuale il registro viene restituito dall'ambiente VMware. Il flusso di lavoro di backup di vProxy invia un HTTP GET richiedere di ottenere i file di configurazione della VM; tuttavia, vCenter risponde con HTTP 500 (Errore interno del server)
Le hostd Messaggio di errore "Operation not supported (11)" indica in genere un problema di accesso o manipolazione del file della macchina virtuale specificato in VMware.
Ci sono diverse cause che potrebbero influire su questo errore; tuttavia, la maggior parte sono a livello ESXi:
- File permissions: l'host ESXi non dispone delle autorizzazioni necessarie per accedere al file.
- Accessibilità del datastore: problemi di connettività tra l'host ESXi e il datastore.
- Agent di gestione: gli host ESXi
hostdevpxaGli agenti stanno riscontrando problemi. - Problemi di spazio su disco sull host ESXi
- Problemi relativi al file di configurazione della macchina virtuale
- L'host ESXi richiede aggiornamenti
Resolution
Verifica delle autorizzazioni di NetWorker VMware Protection (NVP):
La colonna ProxyHC utility Può essere utilizzato per convalidare le autorizzazioni di accesso al backup. La colonna ProxyHC utility non è fornito sull'appliance vProxy per impostazione predefinita.
Vedere NVP-vProxy: Come utilizzare lo strumento di controllo integrità ProxyHC sull'appliance vProxy
./ProxyHC permCorreggere eventuali problemi relativi alle autorizzazioni mancanti identificati da
ProxyHC.
ProxyHC non verifica che l'host ESXi disponga delle autorizzazioni per accedere ai file della VM. ProxyHC Verifica che l'account utente utilizzato per eseguire NetWorker VMware Protection disponga delle autorizzazioni appropriate. Le autorizzazioni sono documentate nella NetWorker VMware Integration Guide, disponibile tramite https://www.dell.com/support/home/product-support/product/networker/docs.
Quando la crittografia VMware è abilitata, l'account utente deve disporre delle seguenti autorizzazioni:
- Operazioni > crittografiche Aggiunta di un disco
- Operazioni > crittografiche Accesso diretto
- Autorizzazioni > crittografiche Registra VM
Accessibilità del datastore:
Dal VMware vSphere Client, controllare la scheda Datastore per verificare la presenza di eventuali errori di accessibilità. Nel caso in cui si verifichi un problema in cui la connettività è intermittente, controllare la vSphere Event Console per eventuali errori o guasti riguardanti l'accesso al datastore.Agent di gestione:
Controllare il valore dell host ESXihostd e vpxa file dell'agent per eventuali errori.
| Componente | Registro | Descrizione |
| Registro dell'host agent ESXi | /var/log/hostd.log |
Contiene informazioni sull'agent che gestisce e configura l'host ESXi e le relative macchine virtuali |
| Registro di vCenter Server Agent | /var/log/vpxa.log |
Contiene informazioni sull'agent che comunica con vCenter Server (se vCenter Server gestisce l'host) |
/etc/init.d/hostd restart /etc/init.d/vpxa restart
Problemi di spazio su disco ESXi:
Assicurarsi che sia disponibile spazio su disco sufficiente sull'host ESXi. Utilizzare il comandovdf -h per controllare lo spazio su disco.
Danneggiamento del file di configurazione della macchina virtuale:
Verifica dell'accesso a.VMX al di fuori del flusso di lavoro di backup. Utilizzando il comando .vmx URL del file dal registro della sessione VM, utilizzare una o più delle seguenti opzioni per convalidare l'integrità del file VMX:
- Registrare nuovamente la VM.
- Cliccare con il pulsante destro del mouse sulla VM e scegliere Remove from Inventory (DO NOT DELETE FROM DISK!)
- Sfogliare il datastore, individuare il file .vmx della VM e aggiungerlo nuovamente all'inventario.
- Nell'appliance vProxy, aprire una sessione SSH, eseguire il seguente comando curl. Sostituire il nome utente vCenter con l'account utente utilizzato per eseguire i backup delle VM. Sostituire l'URL con l'URL identificato nel registro della sessione della VM:
curl -v -k --user VCENTER_USER_ACCOUNT "VMX_URL"
admin@nsr-vproxy02:~> curl -v -k --user administrator@vsphere.local "https://vcsa.amer.lan/folder/05b58d65-4eef-c1d2-5070-00505606604d/rhel-client03.amer.lan.vmx?dcPath=vSAN%2520Datacenter&dsName=vsanDatastore"
Enter host password for user 'administrator@vsphere.local':
* Trying 192.168.9.111:443...
* Connected to vcsa.amer.lan (192.168.9.111) port 443 (#0)
...
< HTTP/2 200
...
CONTENTS OF .VMX File
* Connection #0 to host vcsa.amer.lan left intact
HTTP 200 indica che un GET Richiesta del file VMX. L'output contiene anche il contenuto del file vmx della VM. Verificare che il contenuto del file sia valido e che non vi siano segni di danneggiamento. Se il comando curl restituisce qualsiasi altro stato HTTP (404, 500 e così via), è necessario contattare il supporto VMware.
- Da un web browser che ha accesso all'indirizzo vCenter. Inserire/incollare l'URL dal registro della sessione VM. Immettere le credenziali dell'account utente vCenter utilizzato per i backup:
NOTA: Se l'operazione ha esito positivo, viene scaricato il file vmx. Verificare che il contenuto del file sia valido e che non vi siano segni di danneggiamento. Se il browser restituisce altri errori HTTP (404, 500 e così via), è necessario contattare il supporto VMware.
Versioning di VMware vCenter ed ESXi:
Consultare la matrice di compatibilità di NetWorker per la versione di NetWorker in uso.
https://elabnavigator.dell.com/eln/modernHomeAutomatedTiles?page=NetWorkerNella guida a tutti i componenti di NetWorker, vedere Matrice di compatibilità NVP (proxy) NetWorker.
Utilizzare la versione principale di vProxy più recente supportata dalla versione di NetWorker in uso e compatibile con la versione ESXi in uso.
Idealmente, vCenter Server e gli host ESXi dovrebbero avere la stessa versione e la stessa release di aggiornamento.
Soluzione alternativa:
È possibile testare una delle seguenti soluzioni alternative; Tuttavia, ogni opzione può fungere solo da soluzione temporanea:
- Eseguire un VMware vSphere vMotion host e storage di qualsiasi macchina virtuale segnalando questi errori. Dopo aver eseguito vMotion della VM, eseguire un backup da NetWorker.
- Riavviare gli host ESXi che contengono le VM che segnalano questi problemi durante i backup. Dopo che l'host ESXi è tornato online, verificare se i backup delle VM hanno esito positivo per le VM che risiedono su questo host.
In entrambi i casi, si consiglia al supporto VMware di individuare la root cause di questo problema.