NVP vProxy:VMバックアップがVMの.vmxファイルのダウンロードに失敗する HTTP 500内部サーバー エラー
Summary: NetWorker VMware Protection (NVP)が構成されている。仮想マシン(VM)のバックアップ中に、VMのバックアップが失敗し、VMの.vmxファイルのダウンロードに失敗したことが報告されます。HTTP状態コード: 500 (内部サーバー エラー) が返されます。
Symptoms
NetWorker VMware Protection (NVP) VMバックアップ中にバックアップが失敗し、VMバックアップ セッション ログに次のエラーが記録されます。
- NetWorkerサーバー:
Linuxの場合 /nsr/logs/policy/POLICY_NAME/WORKFLOW_NAME/JOBID_VM-NAME_TIMESTAMP.log
Windows(デフォルト): C:\Program Files\EMC NetWorker\nsr\logs\policy\POLICY_NAME\WORKFLOW_NAME\JOBID_VM-NAME_TIMESTAMP.log
jobsdb retention (デフォルトは72時間)、保存期間よりも古いログは自動的に削除されます。バックアップ セッションのログはvProxyアプライアンスでも確認でき、 jobsdb retentionの詳細を確認してください。
- vProxyアプライアンス:
/opt/emc/vproxy/runtime/logs/recycle/vbackupd/DATE/BackupVmSessions-SESSION_ID.log
YYYY-MM-DDTHH:mm:SS ERROR: [NETWORKER-BUILD] UUID-VCENTER-NAME:VM-MOREF: HTTP Get request failed to download config file '[DATASTORE-NAME] VM-NAME/VM-NAME.vmx' using URL 'https://VCENTER-NAME/folder/VM-NAME/VM-NAME.vmx?dcPath=DATACENTER-NAME&dsName=DATASTORE-NAME'. HTTP Status code: 500. YYYY-MM-DDTHH:mm:SS ERROR: [NETWORKER-BUILD] Failed to download VM config file "[DATASTORE-NAME] VM-NAME/VM-NAME.vmx" into saveset file "VM-MOREF-config-file-0.cfg".
「 /var/log/hostd.log VM(ESXi)ホストでは、次の情報が報告されます。
YYYY-MM-DDTHH:mm:SS Wa(164) Hostd[79374775]: [Originator@6876 sub=Vmsvc.vm:/vmfs/volumes/UUID/VM-NAME/VM-NAME.vmx] File - failed to get objectId, '/vmfs/volumes/UUID/VM-NAME/VM-NAME.vmx': Operation not supported (11)
このエラーは、 HTTP 500 VMのバックアップ中にエラーが発生しました。
Cause
「 HTTP 500 VMバックアップ セッション ログの(Internal Server Error)がVMware環境から返されます。vProxyバックアップ ワークフローは、 HTTP GET VMの構成ファイルを取得するためのリクエスト。ただし、vCenterは次のように応答しています HTTP 500 (内部サーバー エラー)
ザ hostd エラー メッセージ "Operation not supported (11)」は通常、VMware内の指定された仮想マシン ファイルへのアクセスまたは操作に関する問題を示します。
このエラーの原因はいくつかあります。ただし、ほとんどはESXiレベルです。
- ファイルの権限:ESXiホストに、ファイルへのアクセスに必要な権限がありません。
- データストアのアクセス性 - ESXiホストとデータストア間の接続の問題。
- 管理エージェント:ESXiホストの
hostdとvpxa担当者が問題に直面しています。 - ESXiホスト上のディスク領域の問題
- VM構成ファイルの問題
- ESXiホストのアップデートが必要
Resolution
NetWorker VMware Protection (NVP)権限の検証:
「 ProxyHC utility バックアップ アクセス権限の検証に使用できます。「 ProxyHC utility は、デフォルトではvProxyアプライアンスで提供されていません。
「NVP-vProxy: vProxyアプライアンスでヘルス チェック ツールProxyHCを使用する方法
./ProxyHC permによって特定された権限の欠落の問題を修正します
ProxyHCの詳細を確認してください。
ProxyHC ESXiホストがVMファイルにアクセスする権限を持っているかどうかは確認しません。 ProxyHC NetWorker VMware保護の実行に使用されるユーザー アカウントに適切な権限があることを確認します。権限については、https://www.dell.com/support/home/product-support/product/networker/docs から入手できるNetWorker VMware統合ガイドに記載されています。
VMware暗号化が有効になっている場合、ユーザー アカウントには次の権限が必要です。
- ディスクの追加 > 暗号化操作
- 直接アクセス > 暗号化操作
- VMを登録する > 暗号化権限
データストアへのアクセス性:
VMware vSphere Clientで、[ データストア ]タブにアクセシビリティ エラーがないか確認します。接続が断続的になる問題がある場合は、vSphereイベント コンソール でデータストア アクセスに関するエラーまたは障害がないか確認します。管理エージェント:
ESXiホストのhostd と vpxa エージェント ファイルでエラーがないか確認します。
| コンポーネント | 丸太 | 説明 |
| ESXiホスト エージェント ログ | /var/log/hostd.log |
ESXiホストとその仮想マシンを管理および構成するエージェントに関する情報が含まれる |
| vCenter Serverエージェント ログ | /var/log/vpxa.log |
vCenter Serverと通信するエージェントに関する情報が含まれます(vCenter Serverがホストを管理している場合) |
/etc/init.d/hostd restart /etc/init.d/vpxa restart
ESXiディスク領域の問題:
ESXiホストに十分なディスク領域があることを確認します。コマンドvdf -h ディスク領域をチェックするコマンド。
VM構成ファイルの破損:
へのアクセスの確認.VMX バックアップ ワークフロー外のファイル。コマンド .vmx VMセッション ログのファイルURL 次のオプションを1つ以上使用して、VMXファイルの整合性を検証します。
- VMを再登録します。
- VMを右クリックし、[Remove from Inventory]をクリックします(ディスクから削除しないでください)。
- データストアを参照し、VMの.vmxファイルを見つけて、インベントリーに追加し直します。
- vProxyアプライアンスでSSHセッションを開き、次のcurlコマンドを実行します。vCenterユーザー名を、VMバックアップの実行に使用するユーザー アカウントに置き換えます。URLをVMセッション ログで特定されたURLに置き換えます。
curl -v -k --user VCENTER_USER_ACCOUNT "VMX_URL"
admin@nsr-vproxy02:~> curl -v -k --user administrator@vsphere.local "https://vcsa.amer.lan/folder/05b58d65-4eef-c1d2-5070-00505606604d/rhel-client03.amer.lan.vmx?dcPath=vSAN%2520Datacenter&dsName=vsanDatastore"
Enter host password for user 'administrator@vsphere.local':
* Trying 192.168.9.111:443...
* Connected to vcsa.amer.lan (192.168.9.111) port 443 (#0)
...
< HTTP/2 200
...
CONTENTS OF .VMX File
* Connection #0 to host vcsa.amer.lan left intact
HTTP 200 成功したことを示します GET VMXファイルのリクエスト。出力には、VMのvmxファイルの内容も含まれます。ファイルの内容が良好であり、破損の兆候がないことを確認します。curlコマンドがその他のHTTPステータス(404、500など)を返す場合は、VMwareサポートと連携する必要があります。
- vCenterアドレスにアクセスできるWebブラウザーから。VMセッション ログのURLを入力するか貼り付けます。バックアップに使用するvCenterユーザー アカウントの認証情報を入力します。
メモ: 成功すると、vmxファイルがダウンロードされます。ファイルの内容が良好であり、破損の兆候がないことを確認します。ブラウザーがその他のHTTPエラー(404、500など)を返す場合は、VMwareサポートに問い合わせる必要があります。
VMware vCenterおよびESXiのバージョン管理:
ご使用のNetWorkerバージョンのNetWorker互換性マトリックスを参照してください。https://elabnavigator.dell.com/eln/modernHomeAutomatedTiles?page=NetWorker
NetWorkerのすべてのコンポーネント ガイドで、NetWorker NVP(プロキシ)互換性マトリックスを参照してください。
NetWorkerバージョンでサポートされ、ESXiバージョンと互換性のある最新のvProxyメジャー リリースを使用します
vCenter ServerとESXiホストは、同じバージョンおよびアップデート リリースであることが理想的です。
対処方法:
次のいずれかの回避策をテストできます。ただし、各オプションは一時的な解決策としてのみ役立つ場合があります。
- これらの障害を報告しているすべてのVMのホストおよびストレージVMware vSphere vMotionを実行します。VMをvMotionした後、NetWorkerからバックアップを実行します。
- バックアップ中に、これらの問題をレポートしているVMを含むESXiホストを再起動します。ESXiホストがオンラインに戻った後、このホスト上に存在するVMのVMバックアップが成功したかどうかを確認します。
いずれの場合も、この問題の根本原因を突き止めるためにVMwareサポートが推奨されます。