Les routes Dell Networking OS10 ne sont pas installées
Summary: Le problème est lié à l’absence d’installation de nouvelles routes dans le matériel Broadcom sur les commutateurs Dell S5248F. OS10 peut apprendre de nouvelles routes, mais il n’est pas en mesure de les installer dans les tables matérielles Broadcom. Ce problème affecte toutes les plates-formes et toutes les versions d’OS10, mais peut être atténué à l’aide de la configuration du commutateur ou de différentes plates-formes où les tables sont supérieures à S5200. ...
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
- Collecte d’informations :
- Utilisez la commande sosreport pour collecter les journaux système et les informations des tables matérielles.
- Collecter les cartes de topologie et les détails de configuration.
hshell -c "l3 info" command indique si l’espace de la table est épuisé.
- Identification du problème :
- Vérifiez si les routes ne fonctionnent pas et si les appareils ne parviennent pas à communiquer.
- À l’aide des commandes show OS10, vous pouvez voir les routes dans la table de routage.
- À partir du noyau OS10, la commande ping fonctionne entre la source et la destination.
- En utilisant la commande hshell, la route n’est pas visible dans la table de définis.
- Pour IPv4,
hshell -c "´l3 defip show"peut être utilisé pour vérifier l’entrée d’itinéraire. - Pour IPv6,
hshell -c "l3 ip6route show"peut être utilisé pour vérifier l’entrée d’itinéraire. - Vérifiez l’utilisation actuelle de la table avec
hshell -c "l3 info".
- Pour IPv4,
- Vous pouvez également extraire la sortie journalctl en recherchant les entrées ci-dessous.
//========
[ROUTE:HAL-RT-DR], Error: hal_fib_route_add vrf_id: 8, prefix: 201.54.14.249, prefix_len: 32, hal_err: -1 (Failure)base_nas[err]: [ev_log_t_SAI_ROUTE:Switch Id: 0], Failed to add route in Unit 0. Err: Table full.base_nas[err]: [ev_log_t_SAI_ROUTE:Switch Id: 0], Route Add failed
//========
- Le calcul de l’utilisation de la table est le suivant :
Example: ip6 routes – 12 (show ipv6 route summary including all VRF) ipv4 routes - 12 (show ip route summary including all VRF) total routes = 36 = ip6-routes*2 + ip4-routes <------ Note: IPv6 takes two entries. l3 info shows the number of used/total-entries hosts/route entries. //======= OS10#system "sudo hshell -c 'l3 info'" hosts : 12 / 147456 routes : 31 / 32768 nexthops : 9 / 65536 ecmp_groups : 0 / 4096 overlay_ecmp_defrag : 0 underlay_ecmp_defrag : 0 //=======
Cause
- Cause première :
- Ce problème peut se produire sur n’importe quelle version d’OS10.
- Le problème est dû au fait que la table matérielle Broadcom est pleine, ce qui empêche l’ajout de nouvelles routes.
- Justificatives:
- Consultez le dernier Guide de l’utilisateur de Dell SmartFabric OS10 pour obtenir des détails sur l’utilisation des commandes et les limitations matérielles.
- Limites matérielles de la plate-forme S5200 :

Resolution
- Il n’est pas prévu de corriger ce problème dans le code OS10, car il s’agit d’une limitation matérielle. Utilisez certaines des options ci-dessous pour contourner cette limitation
-
- Vérifiez le profil matériel actuel avec la commande ci-dessous et adaptez les routes et les hôtes dans les limites.
Note: The command was taken from s5248f. OS10# show hardware forwarding-table mode all Mode default scaled-l2 scaled-l3-routes scaled-l3-hosts L2 MAC Entries 163840 294912 32768 98304 L3 Host Entries 147456 16384 16384 212992 L3 Route Entries 32768 32768 131072 98304
-
- Surveiller l’espace table à l’aide de commandes
"l3 info"dans le menu HSHELL.
- Surveiller l’espace table à l’aide de commandes
-
- Utilisez différentes configurations pour supprimer les routes inutiles ou les entrées d’hôte installées dans le commutateur.
Affected Products
PowerSwitch, SmartFabric OS10 SoftwareArticle Properties
Article Number: 000322394
Article Type: Solution
Last Modified: 22 May 2025
Version: 1
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.