Výstraha PowerStore: Byly zjištěny zastaralé softwarové balíčky
Summary: Tento článek popisuje kontrolní výstrahu pro zastaralé softwarové balíčky PowerStore
Symptoms
V určitých scénářích může funkce automatického stahování zařízení PowerStore ponechat v zařízení softwarové balíčky, které časem zastarávají a zbytečně zabírají místo v interních systémových adresářích používaných pro provoz zařízení.
Pokud k tomu dojde, zařízení PowerStore zvýší alert 0x03700103 "Stale Software Package Check"

- Výstraha identifikuje uzly se zastaralými balíčky a také identifikuje uzel, ze kterého byla kontrola zahájena.
- Tyto informace jsou uvedeny v části "Components" výstražné zprávy:
Stale software packages detected. KB# 000370624. Components: (node_b: node_a )
Ve výše uvedeném příkladu byla kontrola zahájena z uzlu B a uzel A obsahuje zastaralé balíčky Pokud uzel A i uzel B obsahují zastaralé balíčky a výstražná zpráva se zobrazí takto:
Stale software packages detected. KB# 000370624. Components: (node_b: node_b node_a) Toto je zástupný text.
Cause
Když zařízení PowerStore stáhne softwarové balíčky pomocí funkce automatického stahování, soubory se dočasně uloží do interních systémových adresářů. Za normálních okolností jsou tyto soubory po úspěšném stažení zpracovány a odstraněny. Problémy, jako je přerušení sítě, však mohou vést k částečnému stahování, takže v těchto adresářích zůstanou neúplné soubory.
Resolution
Toto upozornění zahrnuje funkce automatické opravy, které lze povolit nebo zakázat v nástroji PowerStore Manager (GUI) –> Nastavení –> Podpora –> Automatická oprava
Pokud je funkce Automatická oprava již povolena:
- Zařízení PowerStore automaticky problém opraví a vymaže výstrahu, pokud je náprava úspěšná.
Pokud je automatická oprava zakázána:
- Ruční spuštění procesu automatické opravy pro tuto výstrahu z nástroje PowerStore Manager –> Monitorování –> Kontroly stavu –> Kontrola zastaralých softwarových balíčků –> Oprava

Pokud ruční oprava selže nebo výstraha přetrvává i s povolenou automatickou opravou, obraťte se na technickou podporu , aby zjistila příčinu a určila nejlepší postup. Uveďte ID tohoto článku znalostní databáze, aby se urychlilo zpracování.