PowerFlex: OpenStack kan ikke slette diskenheden efter ændring af legitimationsoplysninger

Summary: PowerFlex-diskenheden, der er knyttet til en OpenStack Instance (VM), der er slettet efter en ændring af PowerFlex-legitimationsoplysninger, slettes ikke fra PowerFlex.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

PowerFlex-legitimationsoplysninger, der bruges til OpenStack-integration, er ændret i PowerFlex-backend (MDM).

PowerFlex-legitimationsoplysningerne er korrekte i OpenStack Cinder-konfigurationsfilen, cinder.conf.

Cinder Volume-, API- og Scheduler-tjenesterne genstartes efter konfigurationsændringen.

Eksisterende OpenStack-forekomst med PowerFlex-diskenheder vedhæftet, oprettet før legitimationsændringen.

Symptomer

Diskenheder, der er tilknyttet slettede forekomster, forbliver klargjort i PowerFlex.

Diskenheder, der er knyttet til slettede forekomster, markeres som error_deleting i produktionen af openstack volume list, svarende til følgende:

+--------------------------------------+--------------+----------------+------+-------------+
| ID                                   | Display Name | Status         | Size | Attached to |
+--------------------------------------+--------------+----------------+------+-------------+
| 6b7ce738-5a28-40ff-8ffa-2c98f6a051ad | vol-1        | error_deleting |   24 |             |
+--------------------------------------+--------------+----------------+------+-------------+

 


Påvirkning

Diskenheder forbliver klargjort efter sletning af forekomsten.

Diskenheder forbliver opført i Cinder, efter at deres tilknyttede forekomst er blevet fjernet.

Cause

Ved volumenvedhæftning til en forekomst gemmer OpenStack Nova Cinder-relaterede oplysninger i sin database, herunder de ScaleIO-legitimationsoplysninger, der blev brugt på tidspunktet for vedhæftet fil.

Nova opdaterer eller opdaterer ikke disse oplysninger ved ændringer i Cinder-konfigurationen.

Når legitimationsoplysningerne er ændret i ScaleIO-backend, forsøger Nova at interagere med ScaleIO ved hjælp af de gemte, gamle legitimationsoplysninger, som afvises.

Forekomster, der er oprettet efter Cinder-konfigurationsændringen, påvirkes ikke, da Nova for disse gemmer de opdaterede legitimationsoplysninger i sin database.

Resolution

For diskenheder, der er knyttet til slettede forekomster, skal du manuelt fjerne tilknytningen og slette fra ScaleIO ved hjælp af ScaleIO CLI, UI eller andre metoder.
Hvis du vil slette Cinder-poster, der er knyttet til sådanne diskenheder, skal du kontakte OpenStack-leverandøren.

For eksisterende forekomster, der er oprettet før ændringen af legitimationsoplysninger, skal du lægge forekomsterne på hylden og fjerne dem fra hylden.
Dette får Nova til at opdatere sine lagrede Cinder-data.

 

Påvirkede versioner

OpenStack Newton og derover

OpenStack-distributioner baseret på OpenStack Newton og derover

Affected Products

PowerFlex rack, ScaleIO
Article Properties
Article Number: 000375313
Article Type: Solution
Last Modified: 29 Sept 2025
Version:  1
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.