PowerFlex: OpenStack kann Volume nach Änderung der Zugangsdaten nicht löschen
Summary: PowerFlex-Volumes, die einer OpenStack-Instanz (VM) zugeordnet sind und nach einer Änderung der PowerFlex-Zugangsdaten gelöscht wurden, werden nicht aus PowerFlex gelöscht.
Symptoms
Die für die OpenStack-Integration verwendeten PowerFlex-Zugangsdaten wurden im PowerFlex-Backend (MDM) geändert.
Die PowerFlex-Zugangsdaten sind in der OpenStack Cinder-Konfigurationsdatei korrekt. cinder.conf.
Die Cinder Volume-, API- und Scheduler-Services wurden nach der Konfigurationsänderung neu gestartet.
Vorhandene OpenStack-Instanz mit verbundenen PowerFlex-Volumes, die vor der Änderung der Zugangsdaten erstellt wurde
Problem
Volumes, die gelöschten Instanzen zugeordnet sind, bleiben in PowerFlex bereitgestellt.
Volumes, die gelöschten Instanzen zugeordnet sind, sind gekennzeichnet als error_deleting in der Ausgabe von openstack volume list, die dem Folgenden ähnelt:
+--------------------------------------+--------------+----------------+------+-------------+
| ID | Display Name | Status | Size | Attached to |
+--------------------------------------+--------------+----------------+------+-------------+
| 6b7ce738-5a28-40ff-8ffa-2c98f6a051ad | vol-1 | error_deleting | 24 | |
+--------------------------------------+--------------+----------------+------+-------------+
Auswirkungen
Volumes bleiben nach dem Löschen der Instanz bereitgestellt.
Volumes bleiben in Cinder aufgeführt, nachdem ihre zugeordnete Instanz entfernt wurde.
Cause
Nach dem Anhängen des Volumes an eine Instanz speichert OpenStack Nova in seiner Datenbank Cinder-bezogene Informationen, einschließlich der ScaleIO-Zugangsdaten, die zum Zeitpunkt des Anfügens verwendet werden.
Nova aktualisiert diese Informationen nicht bei Änderungen der Cinder-Konfiguration.
Nachdem die Zugangsdaten im ScaleIO-Back-end geändert wurden, versucht Nova, mit ScaleIO über die gespeicherten, alten Zugangsdaten zu interagieren, die abgelehnt werden.
Instanzen, die nach der Änderung der Cinder-Konfiguration erstellt wurden, sind nicht betroffen, da Nova für diese die aktualisierten Anmeldeinformationen in seiner Datenbank speichert.
Resolution
Für Volumes, die gelöschten Instanzen zugeordnet sind, können Sie die Zuordnung manuell aufheben und aus ScaleIO löschen, indem Sie die ScaleIO-CLI, die Benutzeroberfläche oder andere Mittel verwenden.
Um Cinder-Einträge zu löschen, die solchen Volumes zugeordnet sind, wenden Sie sich an den OpenStack-Anbieter.
Bei vorhandenen Instanzen, die vor der Änderung der Zugangsdaten erstellt wurden, verschieben Sie die Instanzen auf "Shelving" und heben Sie sie zurück.
Dies führt dazu, dass Nova seine gespeicherten Cinder-Daten aktualisiert.
Betroffene Versionen
OpenStack Newton und höher
OpenStack-Distributionen basierend auf OpenStack Newton und höher