PowerFlex: OpenStack kan ikke slette volumet etter endring av legitimasjon

Summary: PowerFlex-volum, tilknyttet en OpenStack-forekomst (VM) som er slettet etter en endring av PowerFlex-legitimasjonen, slettes ikke fra PowerFlex.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

PowerFlex-legitimasjonen som brukes til OpenStack-integrering, er endret i PowerFlex-backend (MDM).

PowerFlex-legitimasjonen er riktig i OpenStack Cinder-konfigurasjonsfilen, cinder.conf.

Cinder Volume-, API- og Scheduler-tjenestene startet på nytt etter konfigurasjonsendringen.

Eksisterende OpenStack-forekomst med PowerFlex-volumer tilkoblet, opprettet før legitimasjonsendringen.

Symptomer

Volumer som er knyttet til slettede forekomster, forblir klargjort i PowerFlex.

Volumer som er knyttet til slettede forekomster, merkes som error_deleting i utdataene fra openstack volume list, som ligner på følgende:

+--------------------------------------+--------------+----------------+------+-------------+
| ID                                   | Display Name | Status         | Size | Attached to |
+--------------------------------------+--------------+----------------+------+-------------+
| 6b7ce738-5a28-40ff-8ffa-2c98f6a051ad | vol-1        | error_deleting |   24 |             |
+--------------------------------------+--------------+----------------+------+-------------+

 


Innvirkning

Volumer forblir klargjort etter sletting av forekomst.

Volumene forblir oppført i Cinder etter at den tilknyttede forekomsten er fjernet.

Cause

Ved volumvedlegg til en forekomst lagrer OpenStack Nova i sin database Cinder-relatert informasjon, inkludert ScaleIO-legitimasjonen som ble brukt på tidspunktet for vedlegget.

Nova oppdaterer eller oppdaterer ikke denne informasjonen ved endringer i Cinder-konfigurasjonen.

Etter at legitimasjonen er endret i ScaleIO-backend, forsøker Nova å samhandle med ScaleIO ved hjelp av de lagrede, gamle legitimasjonene, som avvises.

Forekomster som opprettes etter endringen av Cangior-konfigurasjonen, påvirkes ikke, da Nova lagrer den oppdaterte legitimasjonen i databasen.

Resolution

For volumer tilknyttet slettede forekomster, må du manuelt oppheve tilordningen og slette fra ScaleIO, ved hjelp av ScaleIO CLI, UI eller på annen måte.
Hvis du vil slette Cinder-oppføringer som er knyttet til slike volumer, kontakter du OpenStack-leverandøren.

For eksisterende forekomster som ble opprettet før legitimasjonsendringen, skrinlegger og fjerner du forekomstene.
Dette får Nova til å oppdatere sine lagrede Cinder-data.

 

Berørte versjoner

OpenStack Newton og nyere

OpenStack-distribusjoner basert på OpenStack Newton og høyere

Affected Products

PowerFlex rack, ScaleIO
Article Properties
Article Number: 000375313
Article Type: Solution
Last Modified: 29 Sept 2025
Version:  1
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.