NetWorker: nsrexecd kan niet worden gestart na wijziging van hostnaam van client

Summary: De nsrexecd-service kan niet worden gestart na het hernoemen van een NetWorker-clientsysteem. Dit gebeurt omdat de hostnaam die is opgeslagen in de NSRLA-database niet langer overeenkomt met de huidige hostnaam van het systeem. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

  • Poging om de NetWorker Remote Exec (nsrexecd) resulteert in de volgende fout:

    "The NetWorker Remote Exec Service service on Local Computer started and then stopped. Some services stop automatically if they are not in use by other services or programs."

Foutmelding zoals te zien in de gebruikersinterface

  • De daemon.raw logboek (te vinden op C:\Program Files\EMC NetWorker\nsr\logs\ op Windows of /nsr/logs/ op Linux) bevat een vermelding die lijkt op
RAP critical Attributes 'name' or 'my hostname' of the nsrla resource do not resolve to the machine's hostname 'clientname.domain.com'. To correct the error, it may be necessary to delete the NSRLA database.

Cause

De naam van het clientsysteem is gewijzigd, maar de NSRLA-database bevat nog steeds de vorige hostnaam. Door deze mismatch wordt de nsrexecd service niet correct wordt geïnitialiseerd. 

Resolution

  1. Stop alle NetWorker-services op de client.
  2. Naam van de NSRLA-databasedirectory wijzigen:
    • Windows:
      Herdopen C:\Program Files\EMC NetWorker\nsr\res\nsrladb Aan nsrladb_old
    • Linux:
      Herdopen /nsr/res/nsrladb Aan nsrladb_old
  3. Start de NetWorker-services opnieuw.
    Er wordt een nieuwe NSRLA-database gegenereerd met de juiste hostnaam.

Affected Products

NetWorker
Article Properties
Article Number: 000376266
Article Type: Solution
Last Modified: 05 Dec 2025
Version:  2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.