NetWorker: nsrexecd nie uruchamia się po zmianie nazwy hosta klienta

Summary: Nie można uruchomić usługi nsrexecd po zmianie nazwy systemu klienckiego NetWorker. Dzieje się tak, ponieważ nazwa hosta przechowywana w bazie danych NSRLA nie jest już zgodna z bieżącą nazwą hosta systemu. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

  • Próba uruchomienia NetWorker Remote Exec (nsrexecd) powoduje następujący błąd:

    "The NetWorker Remote Exec Service service on Local Computer started and then stopped. Some services stop automatically if they are not in use by other services or programs."

Komunikat o błędzie widoczny w interfejsie użytkownika

  • Polecenie daemon.raw dziennik (znajdujący się pod adresem C:\Program Files\EMC NetWorker\nsr\logs\ w systemie Windows lub /nsr/logs/ w systemie Linux) zawiera wpis podobny do
RAP critical Attributes 'name' or 'my hostname' of the nsrla resource do not resolve to the machine's hostname 'clientname.domain.com'. To correct the error, it may be necessary to delete the NSRLA database.

Cause

Nazwa systemu klienckiego została zmieniona, ale baza danych NSRLA nadal zawiera poprzednią nazwę hosta. Niedopasowanie to zapobiega nsrexecd przed poprawnym zainicjowaniem usługi. 

Resolution

  1. Zatrzymaj wszystkie usługi NetWorker na kliencie.
  2. Zmień nazwę katalogu bazy danych NSRLA:
    • Windows:
      Zmiana nazwy C:\Program Files\EMC NetWorker\nsr\res\nsrladb na nsrladb_old
    • Linux:
      Zmiana nazwy /nsr/res/nsrladb na nsrladb_old
  3. Uruchom ponownie usługi NetWorker.
    Zostanie wygenerowana nowa baza danych NSRLA z prawidłową nazwą hosta.

Affected Products

NetWorker
Article Properties
Article Number: 000376266
Article Type: Solution
Last Modified: 05 Dec 2025
Version:  2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.