NetWorker. nsrexecd не запускается после изменения имени хоста клиента

Summary: После переименования клиентской системы NetWorker не удается запустить службу nsrexecd. Это происходит из-за того, что имя хоста, хранящееся в базе данных NSRLA, больше не соответствует текущему имени хоста системы. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

  • При попытке запустить NetWorker Remote Exec (nsrexecd) приводит к следующей ошибке:

    "The NetWorker Remote Exec Service service on Local Computer started and then stopped. Some services stop automatically if they are not in use by other services or programs."

Отображается сообщение об ошибке в пользовательском интерфейсе

  • Переменная daemon.raw log (расположенный по адресу C:\Program Files\EMC NetWorker\nsr\logs\ в Windows или /nsr/logs/ в Linux) содержит запись, похожую на
RAP critical Attributes 'name' or 'my hostname' of the nsrla resource do not resolve to the machine's hostname 'clientname.domain.com'. To correct the error, it may be necessary to delete the NSRLA database.

Cause

Клиентская система была переименована, но база данных NSRLA по-прежнему содержит предыдущее имя хоста. Это несоответствие предотвращает nsrexecd сервис от корректной инициализации. 

Resolution

  1. Остановите все службы NetWorker на клиенте.
  2. Переименуйте каталог базы данных NSRLA:
    • Windows:
      «Rename» C:\Program Files\EMC NetWorker\nsr\res\nsrladb на nsrladb_old
    • Linux:
      «Rename» /nsr/res/nsrladb на nsrladb_old
  3. Перезапустите службы NetWorker.
    Будет создана новая база данных NSRLA с правильным именем хоста.

Affected Products

NetWorker
Article Properties
Article Number: 000376266
Article Type: Solution
Last Modified: 05 Dec 2025
Version:  2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.