PowerStore: Не вдається увійти в систему за допомогою групових дозволів openLDAP
Summary: Увійти в PowerStore Manager за допомогою облікових записів OpenLDAP з груповими дозволами не вдається на PowerStoreOS версії 4.1.0.0 і вище, якщо атрибутом члена групи є memberUid.
Symptoms
Не вдається увійти в PowerStore Manager для користувачів OpenLDAP, які успадкували права доступу від групи користувачів на PowerStoreOS версії 4.1. Вхід до системи дозволено, якщо доступ додано до конкретного користувача OpenLDAP.
Перевірте поточну конфігурацію автентифікації в налаштуваннях PowerStore Manager:
Налаштування, Безпека, Аутентифікація -> Редагувати конфігурацію LDAP
- Переконайтеся, що тип сервера – OpenLDAP
- Розширені налаштування, Налаштування групового пошуку - Атрибут члена встановлено на memberUid
Налаштування, безпека, користувачі - LDAP
- Призначений тип дозволу – це дозвіл групи
Після невдалої спроби входу до системи з користувачем openLDAP, перевірте журнали аудиту:
Налаштування, безпека, журнали аудиту
- Фільтрувати користувача до користувача openLDAP, який намагався увійти до системи (user@domain.com)
- Переконайтеся, що автентифікація за допомогою пароля пройшла успішно, але не вдалося авторизації:
- Користувач "user@domain.com" успішно увійшов у систему за допомогою автентифікації за допомогою пароля
- Не вдалося авторизуватися для облікового запису користувача: user@domain.com, під час запиту....
Cause
Користувач може пройти автентифікацію за допомогою сервера openLDAP, але PowerStore не зможе отримати членство в групі користувачів.
Resolution
Є два можливі обхідні шляхи:
- Призначення прав доступу на основі користувачів у PowerStore, у розділах Налаштування, Безпека, Користувачі - LDAP
- Змініть атрибут member у openLDAP та налаштування LDAP PowerStore на uniqueMember замість memberUid.
Цей параметр має бути змінений в обох- PowerStore, Налаштування, Безпека, Аутентифікація -> Редагувати Конфігурацію
LDAP Додаткові параметри, Налаштування групового пошуку, Атрибут члена - Сервер openLDAP у відповідних налаштуваннях групи користувачів
- PowerStore, Налаштування, Безпека, Аутентифікація -> Редагувати Конфігурацію
Цю проблему буде вирішено в майбутньому випуску PowerStoreOS