PowerStore: Manual licensing on PowerStoreOS 4.3 fails with Error in uploading license file
Summary: Unable to install a manual license file on PowerStoreOS 4.3.
Symptoms
An error is received in the PowerStore Manager user interface (UI) when trying to apply the license file manually:
Error in uploading license file. Contact your service provider.
Failed to activate product registration for cluster, Reason: Command response error: Failed to obtain the product registration data. (0xE0D010010001)


Cause
For systems not connected directly to Dell connectivity services, you must manually install a license. Instructions are provided in the PowerStore Manager UI under Settings > Licensing.
PowerStoreOS 4.3 uses Dynamic Licensing (DL) files. Old .xml license files are no longer supported with version 4.3.
The licensing portal has options available to register your PowerStore, or to Migrate the old license information.
If you received a license file from the Dell licensing team for PowerStoreOS 4.3, this should be a .dl file type, not the older .xml file type (which used by PowerStoreOS 4.2 and earlier).
Resolution
License xml files cannot be used with PowerStoreOS 4.3 for manual licensing.
The license must be migrated using the Dell licensing portal > Dynamic Licensing.