NetWorker: Azure VM restore fails with "Unable to find the index entry for the VM backup"
Summary: NetWorker is performing Azure Virtual Machine (VM) snapshot backups. During an Azure VM restore from the NetWorker Web User Interface (NWUI), the save set is selected from NWUI. The restore immediately fails "Unable to find the index entry for the VM backup" ...
Symptoms
NetWorker is performing Azure Virtual Machine (VM) snapshot backups. During an Azure VM restore from the NetWorker Web User Interface (NWUI): NetWorker: How to perform Azure VM snapshot restore from NWUI
The restore session immediately fails with the following errors observed in the recover logs:
208026:nsrazure_recover: Unable to find the index entry for the VM backup. 208628:nsrazure_recover: Unable to find a usable backup of saveset RESOURCE_GROUP:VM_NAME:DISK_NAME: Unable to find the index entry for the VM backup.
The recover session logs are on the NetWorker server, in the following folder:
- Linux:
/nsr/logs/adhoc/nsrazure_recover - Windows (default):
C:\Program Files\EMC NetWorker\nsr\logs\adhoc\nsrazure_recover
There are valid backups (cb) of the VM and the date selected on the NetWorker server's media database. Both the Azure VM disk and 'Azure' save sets are seen:
root@nsr:~# mminfo -avot volume type client date time size ssid fl lvl name .... BACKUP_VOLUME_NAME Data Domain CLIENT_NAME 12/10/25 04:08:02 31 GB 3862509710 cb full RESOURCE_GROUP:VM_NAME:DISK_NAME BACKUP_VOLUME_NAME Data Domain CLIENT_NAME 12/10/25 04:21:05 5 KB 3845733276 cb full Azure
Cause
The host access the NWUI and the NetWorker server are in different regions/time zones. The 'Azure' save set "Save Time" shown in the NWUI does not match the "Save Time" of the "Azure" save set on the NetWorker server.
Performing the restore with debug level seven shows that it fails to find the save set based on the time specified by the NWUI recover wizard. For example, the following is seen in the recover resource for the recovery job:
jobquery can be used to review the command-line syntax used by the NWUI to start the recovery.
root@nsr:~# jobquery
jobquery> show type; job id; command; job log file
jobquery> print type: recover job
type: recover job;
command: "nsrazure_recover -N 'SUBSCRIPTION_NAME' -R 'RESOURCE_GROUP' -A 'STORAGE_ACCOUNT' -n 'RESOURCE_GROUP:VM_NAME:DISK_NAME' -t \"12/10/2025 01:21:05 AM\" -D7";
job id: 547917;
job log file: /nsr/logs/adhoc/nsrazure_recover/547917.log;
The recovery log shows that it attempted to validate save sets for the VM but failed to find one with the time set from the nsrazure_recover command.
MM/DD/YY HH:mm:SS nsrazure_recover-D5 Searching for saveset name 'RESOURCE_GROUP:VM_NAME:DISK_NAME' MM/DD/YY HH:mm:SS nsrazure_recover-D2 lgto_auth for `nsrmmdbd' succeeded MM/DD/YY HH:mm:SS nsrazure_recover-D3 Validating saveset '3862509710' MM/DD/YY HH:mm:SS nsrazure_recover-D3 Ignoring saveset id which might be greater than savetime or not less than found ssid savetime '3862509710' ... MM/DD/YY HH:mm:SS nsrazure_recover-D5 469: Found 0 records for index entry RESOURCE_GROUP:VM_NAME, time 1765347665 208026:nsrazure_recover: Unable to find the index entry for the VM backup. 208628:nsrazure_recover: Unable to find a usable backup of saveset
The "time" shown in the log is in epoch time. In this example, it equates to: December 10, 2025 1:21:05 AM GMT-05:00
Epoch Converter - UNIX Timestamp Converter
The SSID in the log (in this example 3862509710) does not match the time of the backup in the NetWorker server's media database:
root@nsr:~# mminfo -avot volume type client date time size ssid fl lvl name .... BACKUP_VOLUME_NAME Data Domain CLIENT_NAME 12/10/25 04:08:02 31 GB 3862509710 cb full RESOURCE_GROUP:VM_NAME:DISK_NAME BACKUP_VOLUME_NAME Data Domain CLIENT_NAME 12/10/25 04:21:05 5 KB 3845733276 cb full Azure
Resolution
This issue is under investigation by NetWorker engineering.
Workaround:
There are two workarounds available. Use one of the following:
- Set the time zone of the host accessing the NWUI to match the time zone of the NetWorker server. When the restore job is started, it uses the timestamp from the NWUI matches the timestamp of the backup and the restore session starts.
- Start the restore from command line using the
-SSSIDoption instead of-n NAME -tTIMEoption used by the NWUI: NetWorker: How to Perform Azure VM Snapshot Restore from Command-Line.