Avamar: Los respaldos de Windows VSS fallan con el mensaje de error "code 0x80070005 access is denied"
Summary: Los respaldos del Servicio de instantáneas de volumen (VSS) de Windows fallan con el mensaje de error "código 0x80070005 acceso está denegado".
Symptoms
Falla de respaldos de Windows VSS
Los respaldos de estado del sistema Windows VSS fallan con mensajes de error similares a los siguientes:
2015-12-11 07:17:22 avvss Error <8336>: VSS exception code 0x80070005 thrown creating object - 'code 0x80070005: Access is denied'
2015-12-11 07:17:22 avvss Error <0000>: Failed to allocate VSS client, exiting
- El servicio Avagent se puede configurar para ejecutarse con una cuenta de dominio de NT debido a que los respaldos de Avamar SQL también se producen en ese mismo cliente.
- A la cuenta NT Authority/SYSTEM no se le otorgó la función sysadmin en SQL Server Management Studio, que se requiere para respaldar bases de datos SQL.
Cause
Causa raíz de la falla de los respaldos de Windows VSS
La causa raíz de la falla con el error "Access is denied" se debe a que el servicio Backup Agent (Avagent) se configuró con una cuenta de dominio de NT. Esta cuenta no tiene permisos suficientes para las operaciones de instantáneas de VSS.
De manera predeterminada, el servicio Avagent está configurado para ejecutarse con la cuenta SYSTEM local, que tiene los derechos necesarios. Sin embargo, cuando el servicio está configurado para ejecutarse con una cuenta de dominio de NT, carece de los permisos necesarios, lo que provoca el error "Acceso denegado".
El código de error específico asociado con este problema es 0x80070005, lo que indica un error de acceso denegado.
Error code: 0x80070005
Error message: Access is denied
Factores que contribuyen a ello
- La cuenta de dominio de NT que se utiliza para configurar el servicio Avagent no tiene la función sysadmin en SQL Server Management Studio, que es necesaria para respaldar bases de datos SQL.
- Los respaldos de Avamar SQL también se ejecutan en el mismo cliente, lo que puede estar relacionado con la configuración del servicio Avagent.
Resolution
Resolución de una falla de respaldos de Windows VSS
Para resolver la falla de respaldos de Windows VSS, siga estos pasos:
- Abra regedit en el cliente de Windows para editar el registro y siga las prácticas recomendadas para cambiar regedit.
- Busque la clave de registro HKLM/System/CurrentControlSet/Services/VSS.
- Haga clic con el botón secundario en la clave VssAccessControl y agregue un nuevo valor DWORD (32 bits).
- Asígnele un nombre con el dominio\nombre de usuario de la cuenta de servicio de Avagent y establezca el valor en 1.
- Salga del Editor del registro (no es necesario reiniciar).
Después de completar los pasos anteriores, verifique que el problema se haya resuelto correctamente. Para ello, revise los registros de respaldo en busca de mensajes de error relacionados con los respaldos de VSS.
No se requieren herramientas ni software específicos para esta resolución más allá del Editor del Registro de Windows (regedit).
Verifique sus permisos antes de editar el registro y siga las prácticas recomendadas para evitar problemas.
La edición del registro puede causar inestabilidad en el sistema si no se realiza correctamente. Proceda con precaución y considere realizar una copia de seguridad del registro antes de realizar cambios.