Avamar: Windows VSS-sikkerhetskopier mislykkes med feilmeldingen "kode 0x80070005 tilgang nektes"

Summary: Windows-sikkerhetskopier av Volume Shadow Copy Service (VSS) mislykkes med feilmeldingen "kode 0x80070005 tilgang nektes".

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Windows VSS-sikkerhetskopieringsfeil

Windows VSS-sikkerhetskopier av systemtilstand mislykkes med feilmeldinger som ligner på følgende:

2015-12-11 07:17:22 avvss Error <8336>: VSS exception code 0x80070005 thrown creating object - 'code 0x80070005: Access is denied'
2015-12-11 07:17:22 avvss Error <0000>: Failed to allocate VSS client, exiting
  • Avagent-tjenesten kan konfigureres til å kjøre med en NT-domenekonto på grunn av at Avamar SQL-sikkerhetskopier også forekommer på den samme klienten.
  • NT Authority/SYSTEM-kontoen har ikke fått sysadmin-rollen i SQL Server Management Studio, som kreves for å sikkerhetskopiere SQL-databaser.

Cause

Hovedårsaken til Windows VSS-sikkerhetskopieringsfeilen

Den grunnleggende årsaken til at feilen mislykkes med feilmeldingen "Ingen tilgang" skyldes at Backup Agent (Avagent)-tjenesten er konfigurert med en NT-domenekonto. Denne kontoen har ikke tilstrekkelige tillatelser for VSS-skyggekopieringsoperasjoner.

Som standard er Avagent-tjenesten konfigurert til å kjøre med den lokale SYSTEM-kontoen, som har de nødvendige rettighetene. Men når tjenesten er konfigurert til å kjøre med en NT-domenekonto, mangler den de nødvendige tillatelsene, noe som fører til feilen "Access is denied".

Den spesifikke feilkoden som er knyttet til dette problemet, er 0x80070005, noe som indikerer en feilmelding om nektet tilgang.

Error code: 0x80070005
Error message: Access is denied

Medvirkende faktorer

  • NT-domenekontoen som brukes til å konfigurere Avagent-tjenesten, har ikke sysadmin-rollen i SQL Server Management Studio, som kreves for å sikkerhetskopiere SQL-databaser.
  • Avamar SQL-sikkerhetskopiene forekommer også på samme klient, noe som kan være relatert til konfigurasjonen av Avagent-tjenesten.

Resolution

Løse Windows VSS-sikkerhetskopieringsfeil

Følg disse trinnene for å løse Windows VSS-sikkerhetskopieringsfeilen:

  • Åpne regedit på Windows-klienten for å redigere registret og følg beste praksis for å endre regedit.
  • Bla til registernøkkelen HKLM/System/CurrentControlSet/Services/VSS.
  • Høyreklikk VssAccessControl-nøkkelen, og legg til en ny DWORD-verdi (32-biters).
  • Gi den navnet med domene\brukernavnet til Avagent-tjenestekontoen, og sett verdien til 1.
  • Avslutt Registerredigering (omstart ikke nødvendig).

Når du har fullført trinnene ovenfor, kontrollerer du at problemet er løst ved å sjekke sikkerhetskopiloggene for eventuelle feilmeldinger relatert til VSS-sikkerhetskopier.

Ingen spesifikke verktøy eller programvare kreves for denne løsningen utover Windows Registerredigering (regedit).

Bekreft tillatelsene dine før du redigerer registret, og følg anbefalte fremgangsmåter for å forhindre problemer.
Redigering av registeret kan føre til ustabilitet i systemet hvis det ikke gjøres riktig. Fortsett med forsiktighet og vurder å sikkerhetskopiere registret før du gjør endringer.

Affected Products

Avamar, Avamar Client for Windows
Article Properties
Article Number: 000025623
Article Type: Solution
Last Modified: 13 May 2025
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.