Notification: Adding Array Manager to SRM Fails After Upgrade to Dell Storage Manager 2016R2

Summary: Storage Center (SC) Customer Notification: Adding Array Managers to Storage Resource Manager (SRM) Fails After Upgrade to Dell Storage Manager 2016R2.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

This alert pertains to SRM 6.1, SRA 16.2.1.213, and Dell Storage Manager (DSM) 2016R2. It contains specific information related to system features and or functionality.

 

Alert:
During an upgrade to DSM 2016R2, the SRA is upgraded from 6.2.2.7 to 16.2.1.213.
With a combined configuration of SRM 6.1, SRA 16.2.1.213, DSM 2016R2, and the Storage Centers not being licensed for Live Volume, the addition of the array managers to SRM fails with the following error:

std::exception 'class Dr::Xml::XmlValidateException' "empty content is not
valid for content model '(PeerArray+)'"

If the Storage Centers are licensed for Live Volume, then the array managers can be added to SRM and everything functions properly. 
 

Affected versions:
Requires a combined configuration of SRM 6.1, SRA 16.2.1.213, DSM 2016R2, and the Storage Centers not being licensed for Live Volume for this issue to occur.

Cause

Interoperability issue

Resolution

Workaround:
Modify a text file that is labeled dellsrmversion.txt that is located in the following install directory:
C:\Program Files\VMware\VMware vCenter Site Recovery Manager\storage\sra\DellCompellent

Open the file in a text editor and change the version from 6.1 to 0.0 and Save

This must be modified on both sides of a dual protected site before adding array managers to SRM. 

The array managers must be added to SRM before a Rescan SRAs occurs because the rescan changes the version back to 6.1 in the dellsrmversion.txt file. 

If the array managers are removed from SRM, the text file must be modified again before adding the array managers back to SRM.

Resolution:
The fix for this issue is in DSM 2016R3.

Affected Products

Compellent (SC, SCv & FS Series), Dell Compellent SC4020, Dell Storage SC8000, Dell Storage SCv2000, Dell Storage SCv2020, Dell Storage SCv2080, Dell Storage SC5020, Dell Storage SC5020F, Dell Storage SC7020, Dell Storage SC7020F, Dell Storage SC9000 , Dell Storage SCv3000, Dell Storage SCv3020 ...
Article Properties
Article Number: 000139070
Article Type: Solution
Last Modified: 16 Apr 2025
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.