PowerStore Alerts: Cluster installed with more than one operating system version
Summary: PowerStore NDU_CLUSTER_VERSION_MIXED alert occurred due to Cluster installed with more than one operating system version.
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
When Dell PowerStore encounters a problem, an error alert is generated to help identify the issue. This article explains the different possible causes and the relevant solutions for these error alerts. If your problem is not resolved despite the solution provided, check the technical support contact options.
Note: Cannot find the information you need? Let us know via the feedback form at the bottom of this article.
Note: Cannot find the information you need? Let us know via the feedback form at the bottom of this article.
Cause
This condition can cause discrepancies in feature behavior across the cluster due to these versioning differences, and can even lead to a loss of feature functionality after high-availability failover and recoveries.
Resolution
| Alert ID | NDU_CLUSTER_VERSION_MIXED |
| Alert Text | More than one operating system version is installed in this cluster |
| Error Code | (0x01500401) |
| Description | More than one operating system version is installed in this cluster. |
| Resolution | Cause This condition can cause discrepancies in feature behavior across the cluster due to these versioning differences, and can even lead to a loss of feature functionality after high-availability failover and recoveries. Solution Upgrade the cluster to a higher version than the version that is already installed or download a newer version. Please refer PowerStore Software Upgrade guide for details on how to upgrade the software in PowerStore cluster. |
Affected Products
PowerStoreArticle Properties
Article Number: 000179621
Article Type: Solution
Last Modified: 05 Sept 2025
Version: 6
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.