PowerProtect Cloud Snapshot Manager: Applikasjonskonsekvente øyeblikksbilder Jobber fullføres delvis

Summary: Jobber for programkonsekvente øyeblikksbilder fullføres «delvis» på grunn av konflikt med Azure CustomScript Extensions.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Følgende type "Årsak" rapporteres i jobbresultatene for delvis fullførte øyeblikksbilder:

2 soft failure(s) occurred:
Failed to execute script csmprescript.sh: Cannot update handlerVersion or autoUpgradeMinorVersion for VM extension 'csmPreScript'.
Change is in conflict with other extensions under handler 'Microsoft.Azure.Extensions.CustomScript', with typeHandler version '2.0' and autoUpgradeMinorVersion 'True'.,
Failed to execute script <script name>:
Cannot update handlerVersion or autoUpgradeMinorVersion for VM extension 'csmPostScript'. Change is in conflict with other extensions under handler 'Microsoft.Azure.Extensions.CustomScript', with typeHandler version '2.0' and autoUpgradeMinorVersion 'True'.

 

Cause

Et VM-konfigurasjonsproblem forårsaker dette problemet. Den vanligste årsaken er at et CustomScript-skript ble koblet til den virtuelle maskinen når det ble distribuert for å automatisere tilpasning av den virtuelle maskinen ved implementering. Bruken av CustomScript-utvidelser hindrer Cloud Snapshot Manager (CSM) i å feste forhånds- og etterskriptene til maskinen for kjøring, derav de nevnte "myke feilene".

 

Resolution

Avinstaller eksisterende CustomScript-utvidelser for å tillate kjøring av skript for CSM-applikasjonskonsistens.
Se skjermbildene nedenfor for veiledning:
Velg 'Extensions + Applications' fra VM-konfigurasjon
Avinstallere CustomScript

 

Affected Products

Cloud Snapshot Manager, PowerProtect Cloud Snapshot
Article Properties
Article Number: 000196913
Article Type: Solution
Last Modified: 23 Oct 2025
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.