PowerProtect Cloud Snapshot Manager: Zadania migawek spójnych na poziomie aplikacji są wykonywane częściowo
Summary: Zadania migawek spójnych z aplikacjami są "częściowo" wykonywane z powodu konfliktu z rozszerzeniami języka niestandardowego platformy Azure.
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
W wynikach częściowo ukończonych migawek w wynikach zadania zgłaszany jest następujący typ awarii "Przyczyna":
2 soft failure(s) occurred: Failed to execute script csmprescript.sh: Cannot update handlerVersion or autoUpgradeMinorVersion for VM extension 'csmPreScript'. Change is in conflict with other extensions under handler 'Microsoft.Azure.Extensions.CustomScript', with typeHandler version '2.0' and autoUpgradeMinorVersion 'True'., Failed to execute script <script name>: Cannot update handlerVersion or autoUpgradeMinorVersion for VM extension 'csmPostScript'. Change is in conflict with other extensions under handler 'Microsoft.Azure.Extensions.CustomScript', with typeHandler version '2.0' and autoUpgradeMinorVersion 'True'.
Cause
Przyczyną tego problemu jest problem z konfiguracją maszyny wirtualnej. Najczęstszą przyczyną jest sytuacja, w której skrypt CustomScript został dołączony do maszyny wirtualnej podczas jej wdrażania w celu zautomatyzowania dostosowywania maszyny wirtualnej podczas wdrażania. Użycie rozszerzeń CustomScript uniemożliwia Cloud Snapshot Manager (CSM) dołączanie skryptów pre i post do maszyny w celu wykonania, stąd przytaczane "miękkie awarie".
Resolution
Odinstaluj istniejące rozszerzenia języka CustomScript, aby umożliwić wykonywanie skryptów spójności aplikacji CSM.
Zobacz poniższe zrzuty ekranu, aby uzyskać wskazówki:

Affected Products
Cloud Snapshot Manager, PowerProtect Cloud SnapshotArticle Properties
Article Number: 000196913
Article Type: Solution
Last Modified: 23 Oct 2025
Version: 4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.