Migration of VNX volumes to the PowerStore results in Data Path Panics

Summary: Agentless import of multiple VNX volumes to PowerStore fail and may result in DataPath Panics.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

PowerStore Nodes reboot with DataPath Panics,
Some imports of volumes From VNX to PowerStore fail to complete.
I/O operation failure: timeout/abort returning error in journal files.
A LUN reset is sent to the array likely due to long I/O wait times.
I/O Request took approxamately 30s. 
May 26 18:49:06 CRK00223103614-A xtremapp[29944]: May 26 18:49:06.533142 X10 [log_id:0][9122(9389 nb_truck_7       0x7fe2cdd7bac0)]adp_io_request_callback:479: Datapath returning aborted IoRequest (0x50002e229000) after 29407 milliseconds  <<<<<< ~30 Seconds

Cause

Host initiator aborting IO takes an extended amount of time to complete:
A LUN reset is sent to the array likely due to long IO wait times.

Resolution

Verify that the VNX configuration follows the best practices in the host connectivity Guide. Run a health check on VNX and PowerStore prior to starting the import.
Volumes were configured on SAS disks, more flash drives help with performance access.

Additional Information

Affected Products

Entry Level & Midrange, PowerStore, Dell EMC Unity, PowerStore 3200T, PowerStore 5000X, PowerStore 5000T, VNX2 Series

Products

Storage Software, PowerStore 1000X, PowerStore 1000T, PowerStore 1200T, PowerStore 3000X, PowerStore 3000T, PowerStore 500T, PowerStore 5200T, PowerStore 7000X, PowerStore 7000T, PowerStore 9000X, PowerStore 9000T, PowerStore 9200T, PowerStoreOS
Article Properties
Article Number: 000215457
Article Type: Solution
Last Modified: 08 Nov 2025
Version:  2
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