PowerStore: PUHC-virhe: Verkkopalvelin käyttöliittymälle ja REST-käyttö ei toimi, useita tarkistuksia ohitettiin

Summary: Pre-Upgrade Health Check (PUHC) epäonnistuu yritettäessä päivittää PowerStoreOS 3.6:een tai PowerStoreOS 4.0:aan. Vastaanotettu virhe on "Käyttöliittymän verkkopalvelin ja REST-käyttö eivät toimi ja useat tarkistukset ohitettiin. (0XE1001003FFFF) ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

PUHC epäonnistuu yritettäessä päivittää PowerStoreOS 3.6:een tai PowerStoreOS 4.0:aan.

Käyttöliittymän tiedot:

The web server for GUI and REST access is not working and multiple checks were skipped. Please contact your service provider. (rest_check_failed)

Lokiviesti:

Error: The web server for GUI and REST access is not working and multiple checks were skipped. (0XE1001003FFFF)

Näyttökuva PUHC-rest_check_failed

Cause

Tähän PUHC-virheeseen on kolme mahdollista syytä päivitettäessä PowerStoreOS 3.6:een tai PowerStoreOS 4.0:aan.

Ongelma 1:
Käyttäjällä on kolmannen osapuolen varmenne, jossa ei ole PowerStore ICM Clusteringin IP-osoitetta, minkä vuoksi käyttöliittymä- ja REST-tarkistus epäonnistuu.

Ongelma 2:
PowerStoreOS 3.6:een ja uudempiin versioon on lisätty uusi PUHC-tarkistus, joka tarkistaa molempien solmujen yhteydet ICM-klusterin IP-osoitteeseen. PowerStoreOS 2.1 -koodissa on reititysongelma, joka vaikuttaa ICM-klusterin IP-osoitteeseen ja estää tämän uuden PUHC-tarkistuksen suorittamisen.

Ongelma 3:
  user.db on useita tietueita ulkoisen Management_HTTP palvelimen varmenteelle x509_certificate_table. Yksi merkintä on virheellinen ja toinen on kelvollinen. Koska user.db vanhentunut virheellinen varmennetietue luetaan ensin, PUHC ei luo asianmukaista varmennetiedostoa, minkä seurauksena REST-käyttö PUHC-komentosarjoista Control Pathiin (CP) epäonnistuu.

Resolution

Tilapäisratkaisu:

Ongelma 1:
Jos PUHC-virheet johtuvat siitä, että käyttäjällä on kolmannen osapuolen varmenne, joka ei sisällä PowerStore ICM Clustering IP -osoitetta, kolmannen osapuolen varmenne on luotava uudelleen sisältämään klusterin ICM-IP-osoite.

Ongelman ratkaisemiseksi käyttäjän on luotava kolmannen osapuolen varmenne uudelleen klusterin ICM-IP-osoitteella. Kolmannen osapuolen varmenteen luontiohjeet ovat Dell PowerStoren suojauksen määritysoppaassa (asiakirjan tarkasteleminen edellyttää rekisteröitynyttä Dell-tuen kirjautumista)

Toinen tapa ratkaista tämä ongelma on palata itse allekirjoitettuun varmenteeseen. Lisätietoja tästä prosessista on seuraavassa artikkelissa: Kolmannen osapuolen hallintavarmenteen palauttaminen itse allekirjoitetuksi.

Ongelma 2:
Jos PUHC-virhe ilmenee päivitettäessä PowerStoreOS 2.x -versiosta versioon 3.6 tai uudempaan ja on varmistettu, että ongelma ei johdu siitä, että käyttäjällä olisi kolmannen osapuolen varmenne, jossa ei ole PowerStore ICM Clustering -IP-osoitetta, ota yhteys Dellin tekniseen tukeen tai valtuutettuun palveluntarjoajaan ja katso lisätietoja tästä artikkelista.

Ongelma 3:
Ota yhteys Dellin tekniseen tukeen tai valtuutettuun palveluntarjoajaan ja katso lisätietoja tästä artikkelista.

Affected Products

PowerStore
Article Properties
Article Number: 000219640
Article Type: Solution
Last Modified: 29 Jul 2025
Version:  13
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.