PowerStore:PUHCエラー: UIおよびRESTアクセス用のWebサーバーが機能せず、複数のチェックがスキップされました

Summary: PowerStoreOS 3.6またはPowerStoreOS 4.0にアップグレードしようとすると、アップグレード前ヘルス チェック(PUHC)が失敗します。受信したエラーは、「UI用のWebサーバーとRESTアクセスが機能しておらず、複数のチェックがスキップされました。(0XE1001003FFFF)

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

PowerStoreOS 3.6またはPowerStoreOS 4.0.

にアップグレードしようとするとPUHCが失敗するUIの詳細:

The web server for GUI and REST access is not working and multiple checks were skipped. Please contact your service provider. (rest_check_failed)

ログ メッセージ:

Error: The web server for GUI and REST access is not working and multiple checks were skipped. (0XE1001003FFFF)

PUHC rest_check_failedのスクリーンショット

Cause

PowerStoreOS 3.6またはPowerStoreOS 4.0.にアップグレードした場合に、このPUHCエラーが発生する原因として、次の3つが考えられます

問題 1:
ユーザーは、PowerStore ICMクラスタリングIPアドレスを含まないサード パーティー証明書を持っているため、UIとRESTのチェックに失敗します。

問題2:
PowerStoreOS 3.6以降には、両方のノードからICMクラスターIPへの接続を確認する新しいPUHCチェックが追加されました。PowerStoreOS 2.1コードにルーティングの問題があり、ICMクラスターIPに影響するため、この新しいPUHCチェックが正常に完了しません。

問題3:
  user.dbには、x509_certificate_table内の外部Management_HTTP サーバー証明書の複数のレコードがあります。一方のエントリーは無効で、もう一方のエントリーは有効です。user.dbの古い無効な証明書レコードが最初に読み取られるため、PUHCは適切な証明書ファイルを生成できず、PUHCスクリプトからコントロール パス(CP)へのRESTアクセスが失敗します。

Resolution

回避策:

問題1:
ユーザーがPowerStore ICMクラスタリングIPアドレスを含まないサード パーティー証明書を持っていることがPUHCエラーの原因である場合は、サード パーティー証明書を再生成してクラスターICM IPを含める必要があります。

この問題に対処するには、ユーザーがクラスターICM IPを使用してサード パーティー証明書を再生成する必要があります。サード パーティー証明書を生成する詳細な手順については、『Dell PowerStoreセキュリティ構成ガイド 』を参照してください(ドキュメントを表示するには、登録済みのDellサポートへのログインが必要です)

この問題に対処するもう1つのオプションは、自己署名証明書に戻すことです。このプロセスの詳細については、次の記事を参照してください。サード パーティー管理証明書を自己署名に戻しています

問題2:
PowerStoreOS 2.xから3.6以降にアップグレードするときにPUHCエラーが発生し、PowerStore ICMクラスタリングIPアドレスを含まないサード パーティー証明書を持つユーザーがその証明書を使用していることが問題ではないことが確認された場合は、Dellテクニカル サポートまたは認定サービス プロバイダーにエスカレーションし、この記事を参照してサポートを受けてください。

問題3:
Dellテクニカル サポートまたは認定サービス プロバイダーにエスカレーションし、この記事を参照してサポートを受けてください。

Affected Products

PowerStore
Article Properties
Article Number: 000219640
Article Type: Solution
Last Modified: 29 Jul 2025
Version:  13
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.