PowerStore. Ошибка PUHC: Веб-сервер для доступа к пользовательскому интерфейсу и REST не работает, пропущено несколько проверок
Summary: Диагностика системы перед модернизацией (PUHC) завершается сбоем при попытке выполнить обновление до PowerStoreOS 3.6 или PowerStoreOS 4.0. Получена ошибка: «Веб-сервер для пользовательского интерфейса и доступа через REST не работает, и было пропущено несколько проверок. (0XE1001003FFFF) ...
Symptoms
Сбой PUHC при попытке выполнить обновление до PowerStoreOS 3.6 или PowerStoreOS 4.0.
Сведения о пользовательском интерфейсе:
The web server for GUI and REST access is not working and multiple checks were skipped. Please contact your service provider. (rest_check_failed)
Сообщение журнала:
Error: The web server for GUI and REST access is not working and multiple checks were skipped. (0XE1001003FFFF)

Cause
При модернизации до PowerStoreOS 3.6 или PowerStoreOS 4.0 возможны три причины этой ошибки PUHC.
Вопрос 1:
У пользователя есть сторонний сертификат, который не содержит IP-адрес кластеризации ICM PowerStore, что приводит к сбою проверки пользовательского интерфейса и REST.
Вопрос 2:
В PowerStoreOS 3.6 и более поздних версиях была добавлена новая проверка PUHC, которая проверяет возможность подключения обоих узлов к IP-адресу кластера ICM. В коде PowerStoreOS 2.1 имеется проблема маршрутизации, которая влияет на IP-адрес кластера ICM и не позволяет успешно выполнить эту новую проверку PUHC.
Вопрос 3:
В user.db имеется несколько записей для сертификата внешнего сервера Management_HTTP в x509_certificate_table. Одна запись недействительна, а другая — действительна. Из-за того, что сначала считывается устаревшая недействительная запись сертификата в user.db, PUHC не может создать соответствующий файл сертификата, что приводит к сбою доступа REST из сценариев PUHC к пути управления (CP).
Resolution
Временное решение.
Вопрос 1:
Если ошибки PUHC возникают из-за того, что у пользователя есть сторонний сертификат, который не содержит IP-адрес кластеризации ICM PowerStore, потребуется повторно создать этот сторонний сертификат, чтобы включить в него IP-адрес ICM кластера.
Для решения этой проблемы пользователь должен повторно создать сторонний сертификат с IP-адресом ICM кластера. Подробные инструкции по созданию стороннего сертификата см. в документе Dell PowerStore: руководство по настройке обеспечения безопасности (для просмотра документа требуется зарегистрированная учетная запись в службе поддержки Dell Support)
Другим способом решения этой проблемы является возврат к самозаверяющему сертификату. Дополнительные сведения об этом процессе см. в следующей статье: Возврат стороннего сертификата управления к самозаверяющему.
Вопрос 2:
Если при обновлении PowerStoreOS 2.x до 3.6 или более поздней версии возникает ошибка PUHC и было подтверждено, что проблема возникла не из-за наличия у пользователя стороннего сертификата, который не содержит IP-адрес кластеризации ICM PowerStore, обратитесь в службу технической поддержки Dell или к авторизованному поставщику услуг и обратитесь за помощью в эту статью.
Вопрос 3:
Обратитесь в службу технической поддержки Dell или авторизованному поставщику услуг и обратитесь за помощью в этой статье.