NetWorker Module for Meditech restore of a LUN or disk or segment is failing with error: Access is Denied

Summary: User deleted files from a production LUN in a Meditech Environment, and now they are using VPLEX Metro to try to restore.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

The user accidentally deleted one of the production LUNs from a Meditech Environment and now is trying to restore using VPLEX Metro.
 
Starting recovery from the Windows command line on Meditech Proxy machine or Meditech Web UI, gets the same error:
nsrmedirc: \\.\PHYSICALDRIVExx: file exists, overwriting
nsrmedirc: Cannot write to file '\\.\PHYSICALDRIVExx' : Access is denied. (win32 error 0x5)
nsrmedirc: Encountered an error recovering \\.\PHYSICALDRIVExx

Cause

The target LUN or disk from the Storage Array mapped to the Meditech Proxy machine for recovery had some data on it causing the restore failure and Access Denied error.

Resolution

The new LUN or Disk must be a RAW disk and should have no file system on it. See the NetWorker Module for Meditech Installation and Administration Guide for recovery requirements.

Prerequisites: 

Ensure that the following requirements are met:
  • The LUN is a raw disk; that is the LUN does not have a file system, but is online (accessible and is in ready state).
  • The target LUN size must be larger than or the same size as the source LUN.
In this case, the user erased the LUN or disk and attempted the recovery again which completed successfully.
Article Properties
Article Number: 000220702
Article Type: Solution
Last Modified: 05 Jan 2024
Version:  2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.