NetWorker 19.9: vProxy-Backup- und -Recovery-Jobs werden nicht gestartet, kein vProxy wird vom Prozess aufgenommen

Summary: Ein NVP-Backup (NetWorker VMware Protection) wird gestartet. Die virtuellen Maschinen (VMs) im Workflow befinden sich jedoch im Status "Warten auf Ausführung". VM-Wiederherstellungssitzungen werden gestartet, aber nicht fortgesetzt, es wird keine Schreibsitzung eingerichtet. Backup- und Recovery-Jobs von vProxy müssen manuell abgebrochen werden. ...

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Symptoms

Der VM-Backupworkflow zeigt die VMs in einem Zustand an, in dem auf die Ausführung gewartet wird. Die Details der Backupaktion in der NetWorker Management Console zeigen Folgendes an:
Details zur Backupaktion in der NMC

HINWEIS: Die Spalte "vProxy" bleibt leer, was darauf hinweist, dass ein vProxy nicht vom Workflow aufgenommen wurde.

VM-Recovery-Sitzungen zeigen das gleiche Symptom. Die Recovery-Sitzung wird gestartet, aber es wird kein vProxy von der Sitzung aufgenommen. Der Job wird nicht fortgesetzt und muss manuell abgebrochen werden. Es gibt keine Probleme mit der vProxy-Verfügbarkeit:

  • vProxys werden als aktiviert angezeigt: Ja unter Geräte –> VMware-Proxys
  • Es werden keine Meldungen wie "vProxy is unavailable" im NMC-Fenster "Alerts " angezeigt.
  • Der NetWorker-Server kann den vollständig qualifizierten Domainnamen (FQDN), den Kurznamen und die IP-Adresse von vProxy korrekt auflösen.
  • Der vProxy kann den FQDN, den Kurznamen und die IP-Adresse des NetWorker-Servers korrekt auflösen.
  • Port 9090 ist zwischen dem NetWorker-Server und der vProxy-Appliance offen. Jedes System kann über diesen Port miteinander kommunizieren.

Der NetWorker-Server ist 19.9.0.0-19.9.0.3> oder 19.10.0.0.

Cause

Bevor die VM-Backup- oder -Wiederherstellungssitzung eingerichtet werden kann, muss der NetWorker-Server eine verfügbare vProxy-Appliance identifizieren und eine Verbindung zu ihr herstellen.

Codeoptimierungen wurden in NetWorker 19.9.0.4 und 19.10.0.1 über NETWORKER-85156 vorgenommen.

    Resolution

    Wenn der NetWorker-Server 19.9.0.3 oder älter ist, führen Sie ein Upgrade auf 19.9.0.4/19.10.0.1 oder höher durch. Die vProxy-Appliances sollten ebenfalls auf die neueste von NetWorker unterstützte Version aktualisiert werden. Durch das Upgrade der vProxy-Appliance wird sichergestellt, dass die neuesten Sicherheitskorrekturen angewendet werden. Neue vProxy-Versionen bündeln außerdem aktualisierte ddboost-Bibliotheken, die VMware VDDK-Version (Virtual Disk Development Kit) und VMware Tools.

    NetWorker- und vProxy-Paketdownloads sind verfügbar über: https://www.dell.com/support/home/product-support/product/networker/overview

    Additional Information

    Es gibt mehrere mögliche Ursachen dafür, dass ein vProxy für einen Backup- oder Wiederherstellungsvorgang nicht ausgewählt wird. Wenn der NetWorker-Server 19.9.0.4, 19.10.0.1 oder höher ist, führen Sie die folgenden Schritte aus, um sicherzustellen, dass keine anderen Probleme die vProxy-Auswahl verhindern:

    Status "vProxy aktiviert":

    1. Navigieren Sie im NMC zu Devices-VMware> Proxies oder navigieren Sie über die NetWorker Web User Interface (NWUI) zu Protection –> VMware Proxies.

    2. Überprüfen Sie, ob die vProxies aktiviert sind. In der Spalte enabled sollte Enabled angezeigt werden: Ja:
      Registerkarte NWUI vProxies

       

      HINWEIS: Wenn der vProxy "Enabled" anzeigt: Nein, bearbeiten Sie den vProxy und wählen Sie Aktiviert aus: Ja

    Namensauflösung:

    Stellen Sie sicher, dass die Umgebung DNS (Domain Name System) verwendet. NetWorker-Server, vProxies, Data Domain-Systeme, VMware vCenter und VMware ESXi-Hosts müssen alle FQDNs verwenden, die im DNS aufgelöst werden können. In NetWorker konfigurierte Ressourcen sollten mit FQDN hinzugefügt werden. Der FQDN, der Kurzname und die IP-Adressen sollten alle korrekt aufgelöst werden. Alle Systeme, die Hostdateieinträge verwenden, müssen über korrekte IP-Adressen, FQDNs und Aliase verfügen.

    NVP-vProxy: Troubleshooting der Netzwerkverbindung für Backup- und Wiederherstellungsvorgänge

    Dual Stack (IPv4 und IPv6) wird von der vProxy-Appliance nicht unterstützt. Es muss das eine oder das andere verwendet werden. In einer IPv6-fähigen VMware-Umgebung sollten die folgenden Komponenten keine nicht erreichbaren IPv4-Einträge im DNS-Server haben:

      • FQDN des NetWorker-Servers
      • FQDN der vProxy-Appliance
      • Data Domain-FQDN
      • FQDN von vCenter
      • ESXi-FQDN

    Die oben aufgeführten FQDNs sollten nur AAAA-Datensätze aus dem DNS zurückgeben und sollten keine nicht erreichbaren IPv4-Datensätze im DNS enthalten.

    Siehe: NVP-vProxy: VM-Backups im Status "Warten auf Ausführung" in einer Umgebung mit Hostdateieinträgen oder Dual-Stack-Konfiguration (IPv4 und IPv6)

    1. Bestätigen Sie auf der vProxy-Appliance und dem NetWorker-Server, dass der FQDN, der Kurzname und die IP-Adresse für jedes entsprechende System aufgelöst werden können:

      nslookup FQDN
      nslookup Short_Name
      nslookup IP_ADDRESS
      NetWorker: Best Practices für das Troubleshooting von Namensauflösungen
    2. Überprüfen Sie die Spalte /etc/hosts -Datei auf jedem System und stellen Sie sicher, dass, falls Hostdateieinträge vorhanden sind, diese die richtige IP-Adresse und die entsprechenden Hostnamen haben.

      HINWEIS: Wenn Sie über SSH auf den vProxy zugreifen, müssen Sie sich mit dem Konto "admin" anmelden. Der Root-Zugriff über SSH ist standardmäßig deaktiviert.

    Port 9090-Kommunikation:

    1. Bestätigen Sie auf dem NetWorker-Server, dass Sie mit Port 9090 auf dem vProxy kommunizieren können:

      nsrports -t vProxy_Address -p 9090
    2. Vergewissern Sie sich von der vProxy-Appliance, dass Sie mit Port 9090 auf dem NetWorker-Server kommunizieren können:

      curl -v NetWorker_Address:9090
      HINWEIS: Wenn Sie über SSH auf den vProxy zugreifen, müssen Sie sich mit dem Konto "admin" anmelden. Der Root-Zugriff über SSH ist standardmäßig deaktiviert.

    Verfügbarkeit von vProxy:

    1. Überprüfen Sie die Daten des NetWorker-Servers daemon.raw für vProxy-Verfügbarkeit oder SSL-Fehler.

      Linux: /nsr/logs/daemon.raw
      Windows: C:\Program Files\EMC NetWorker\nsr\logs\daemon.raw

      NetWorker: Verwenden von nsr_render_log

    Zertifikat- und SSL-Fehler

    Wenn SSL-Fehler beobachtet werden, kann das Problem durch erneute Registrierung der vProxy-Appliance behoben werden: NVP-vProxy: Aufheben/erneutes Registrieren einer vProxy-Appliance

    Verfügbarkeit von Hot Add

    Standardmäßig sind für eine vProxy-Appliance 13 Hot-Add-Sitzungen aktiviert und Network Block Device (NBD) deaktiviert.
    Hot-Add-Sitzung aktiviert und NBD deaktiviert

    Das bedeutet, dass sich die vProxy-Appliance auf einem ESXi-Host befinden muss, der Datenspeicherzugriff auf die VMs hat, die sie sichert. Wenn nur Hot-Add aktiviert ist, können Sie NBD vorübergehend aktivieren, um zu sehen, ob die Backupsitzung gestartet wird. Wenn das Backup gestartet wird, deutet dies auf ein Hot-Add-Zugriffsproblem in VMware hin. Dies kann durch die Bereitstellung von vProxy-Appliances auf ESXi-Hosts behoben werden, sodass mindestens eine vProxy-Appliance auf jeden VMware-Datenspeicher zugreifen kann. Es wird nicht empfohlen, NBD (wenn möglich) zu verwenden. Eine große Anzahl von NBD-Sitzungen kann zu einer Überlastung des ESXi-Managementnetzwerks führen. Weitere Informationen zur Skalierbarkeit sowie zu Hot-Add-/NBD-Empfehlungen und -Einschränkungen finden Sie im NetWorker VMware Integration Guide, verfügbar unter: https://www.dell.com/support/home/product-support/product/networker/docs

    HotAdd kann auch mit dem ProxyHC-Dienstprogramm validiert werden: NVP-vProxy: So verwenden Sie das Integritätsprüfungstool ProxyHC auf der vProxy-Appliance.

    Für die Backupaktion ist manueller vProxy ausgewählt:

    Für die Backupaktion wurde ein vProxy manuell ausgewählt:
    Für die Backupaktion wurde ein vProxy manuell ausgewählt

    Stellen Sie sicher, dass keine Probleme vorliegen (wie oben beschrieben) beim Zugriff auf diesen vProxy oder mit seiner Verfügbarkeit, testen Sie einen anderen verfügbaren vProxy oder wählen Sie "Automatic".

    Affected Products

    NetWorker

    Products

    NetWorker Family, NetWorker Series
    Article Properties
    Article Number: 000225358
    Article Type: Solution
    Last Modified: 22 Oct 2025
    Version:  10
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