NetWorker 19.9: vProxy back-up en herstel Taken worden niet gestart, er wordt geen vProxy opgepikt door het proces
Summary: Een Back-up of herstel met NetWorker VMware Protection (NVP) wordt gestart; De virtuele machines (VM) in de werkstroom bevinden zich echter in de status "wachten om uit te voeren". VM-herstelsessies worden gestart, maar worden niet voortgezet, er wordt geen schrijfsessie tot stand gebracht. vProxy back-up- en hersteltaken moeten handmatig worden geannuleerd. ...
Symptoms
De VM-back-upworkflow toont de VM's in een wachtende status om uit te voeren. De details van de back-upactie in de NetWorker Management Console tonen:
VM-herstelsessies vertonen hetzelfde symptoom. De herstelsessie wordt gestart, maar er wordt geen vProxy opgepikt door de sessie. De taak wordt niet uitgevoerd en moet handmatig worden geannuleerd. Er zijn geen problemen met de beschikbaarheid van vProxy:
- vProxy's zijn ingeschakeld: Ja onder Apparaten-VMware-proxy's>
- Er worden geen "vProxy is niet beschikbaar"-berichten weergegeven in het venster NMC Alerts .
- De NetWorker-server kan de vProxy Fully Qualified Domain Name (FQDN), shortname en het IP-adres correct omzetten.
- De vProxy kan de FQDN, korte naam en het IP-adres van de NetWorker-server correct omzetten.
- Poort 9090 is geopend tussen de NetWorker-server en de vProxy-appliance. Elk systeem kan via deze poort met het andere communiceren.
De NetWorker-server is 19.9.0.0-19.9.0.3> of 19.10.0.0.
Cause
Voordat de VM-back-up- of herstelsessie tot stand kan worden gebracht, moet de NetWorker-server een beschikbare vProxy-appliance identificeren en daarmee verbinding maken.
Codeoptimalisaties zijn ingevoerd in NetWorker 19.9.0.4 en 19.10.0.1 via NETWORKER-85156.
Resolution
Als de NetWorker-server 19.9.0.3 of ouder is, voert u een upgrade uit naar 19.9.0.4/19.10.0.1 of hoger. De vProxy-appliances moeten ook worden geüpgraded naar de nieuwste versie die wordt ondersteund door NetWorker. Het upgraden van de vProxy-appliance zorgt ervoor dat de nieuwste beveiligingsoplossingen worden toegepast. Nieuwe vProxy-releases bundelen ook bijgewerkte ddboost-bibliotheken, VMware Virtual Disk Development Kit-versie (VDDK) en VMware Tools.
Downloads van NetWorker- en vProxy-pakketten zijn beschikbaar via: https://www.dell.com/support/home/product-support/product/networker/overview
Additional Information
Er zijn verschillende mogelijke oorzaken waarom een vProxy niet wordt geselecteerd voor een back-up- of herstelbewerking. Als de NetWorker-server 19.9.0.4, 19.10.0.1 of hoger is, voert u het volgende uit om ervoor te zorgen dat er geen andere problemen zijn die vProxy-selectie verhinderen:
Status vProxy ingeschakeld:
-
Ga vanuit NMC naar Devices-VMware> Proxy's of ga vanuit de NetWorker Web User Interface (NWUI) naar Protection-VMware> Proxy's.
-
Controleer of de vProxy's zijn ingeschakeld. In de kolom Ingeschakeld moet Ingeschakeld worden weergegeven: Ja:
OPMERKING: Als de vProxy Ingeschakeld weergeeft: Nee, bewerk de vProxy en selecteer Ingeschakeld: Ja
Naam Resolutie:
Zorg ervoor dat de omgeving gebruikmaakt van Domain Name System (DNS). NetWorker server, vProxy's, Data Domain systemen, VMware vCenters en VMware ESXi hosts moeten allemaal FQDN's gebruiken die in DNS kunnen worden opgelost. Resources die zijn geconfigureerd in NetWorker, moeten worden toegevoegd met behulp van FQDN. De FQDN, shortname en IP-adressen moeten allemaal correct worden opgelost. Alle systemen die gebruikmaken van bestandsvermeldingen van hosts moeten correct ingevulde IP-adressen, FQDN's en aliassen hebben.
NVP vProxy: Problemen met netwerkconnectiviteit oplossen voor back-up- en herstelbewerkingen
Dubbele stack (IPv4 en IPv6) wordt niet ondersteund door het vProxy-apparaat. De een of de ander moet worden gebruikt. In een VMware-omgeving met IPv6 mogen de volgende componenten geen onbereikbare IPv4-vermeldingen op de DNS-server hebben:
-
- NetWorker server FQDN
- vProxy Appliance FQDN
- Data Domain FQDN
- vCenter FQDN
- ESXi FQDN
De hierboven vermelde FQDN's mogen alleen AAAA-records van het DNS retourneren en mogen geen onbereikbare IPv4-records in het DNS hebben.
Zien: NVP vProxy: VM-back-ups bevinden zich in de status Wachten om te worden uitgevoerd in een omgeving met behulp van bestandsvermeldingen van hosts of configuratie van dual-stack (IPv4 en IPv6)
-
Bevestig vanuit de vProxy-appliance en de NetWorker-server dat de FQDN, korte naam en het IP-adres oplosbaar zijn voor elk corresponderend systeem:
nslookup FQDN nslookup Short_Name nslookup IP_ADDRESS
NetWorker: Best practices voor het oplossen van problemen met naamresolutie -
Controleer de
/etc/hostsbestand op elk systeem en zorg ervoor dat als er hostbestandsvermeldingen bestaan, deze het juiste IP-adres en de bijbehorende hostnamen hebben.OPMERKING: Bij toegang tot de vProxy via SSH, moet u inloggen met het "admin"-account. Basistoegang via SSH is standaard uitgeschakeld.
Poort 9090-communicatie:
-
Controleer vanaf de NetWorker-server of u kunt communiceren met poort 9090 op de vProxy:
nsrports -t vProxy_Address -p 9090
-
Controleer vanuit de vProxy-appliance of u kunt communiceren met poort 9090 op de NetWorker-server:
curl -v NetWorker_Address:9090
OPMERKING: Bij toegang tot de vProxy via SSH, moet u inloggen met het "admin"-account. Basistoegang via SSH is standaard uitgeschakeld.
vProxy-beschikbaarheid:
-
Controleer de NetWorker-serverbestanden
daemon.rawvoor vProxy-beschikbaarheid of SSL-fouten.Linux:
/nsr/logs/daemon.raw
Windows:C:\Program Files\EMC NetWorker\nsr\logs\daemon.raw
Certificaat- en SSL-fouten
Als SSL-fouten worden waargenomen, kan het probleem mogelijk worden opgelost door het vProxy-apparaat opnieuw te registreren: NVP vProxy: Hoe kan ik de registratie van een vProxy-apparaat ongedaan maken/opnieuw registreren?
Hot Add Beschikbaarheid.
Standaard heeft een vProxy-apparaat 13 Hot Add-sessies ingeschakeld en is Network Block Device (NBD) uitgeschakeld.
Dit betekent dat het vProxy-apparaat zich op een ESXi-host moet bevinden die datastore-toegang heeft tot de VM's waarvan het een back-up maakt. Als alleen HotAdd is ingeschakeld, kun je NBD tijdelijk inschakelen om te zien of de back-upsessie begint. Als de back-up wordt gestart, duidt dit op een Hot Add-toegangsprobleem in VMware. Dit kan worden opgelost door vProxy-appliances te implementeren op ESXi-hosts, zodat elke VMware-datastore toegankelijk is voor ten minste één vProxy-appliance. Het wordt niet aanbevolen om NBD te gebruiken (indien mogelijk). Grote hoeveelheden NBD-sessies kunnen congestie veroorzaken op het ESXi-beheernetwerk. Raadpleeg voor meer informatie over schaalbaarheid en aanbevelingen en beperkingen voor hotadd/NBD de NetWorker VMware Integration Guide die beschikbaar is via: https://www.dell.com/support/home/product-support/product/networker/docs
HotAdd kan ook worden gevalideerd met het hulpprogramma ProxyHC: NVP-vProxy: De healthcheck-tool ProxyHC gebruiken op een vProxy-apparaat.
Voor de back-upactie is handmatige vProxy geselecteerd:
Er is een vProxy handmatig geselecteerd voor de back-upactie:
Zorg ervoor dat er geen problemen zijn (zoals hierboven beschreven) om toegang te krijgen tot deze vProxy of met de beschikbaarheid ervan, een andere beschikbare vProxy te testen of in te stellen op "Automatische" selectie.