Open Server Manager: 运行状况汇总状态未自动清除

Summary: 修正错误或警告条件后,Dell Open Server Manager (OSM) 运行状况汇总保持严重状态。

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

只要事件日志中记录了警告或严重事件,Dell Open Server Manager (OSM) 运行状况汇总状态将变为严重。在终端用户从 BMC 日志中删除完整的事件日志之前,状态保持为严重。OSM 中不支持删除个别事件。有时,服务器标识符 LED 指示灯仍处于故障(琥珀色)状态,直到状态恢复正常。

运行状况汇总关键示例:

图 1:严重运行状况错误示例

上面的示例摘录演示了交流电源丢失并恢复到电源 1。虽然事件日志反映输入电源已恢复,但服务器运行状况继续反映顶部功能区中的严重错误。运行状况汇总将继续报告严重状态,直至删除整个事件日志。

Cause

此行为在 OpenBMC 开源固件堆栈中是预期的。为了使服务器运行状况恢复正常,终端用户必须确认错误条件并删除完整的事件日志。

Resolution

为了修复严重情况,OSM 终端用户必须删除完整的 BMC 事件日志。

注意:建议在删除事件日志之前导出 BMC 事件日志或导出技术支持报告 (TSR)。 
 
OSM UI >> 日志 >> 事件日志示例:

图 2:OSM 事件日志全部删除


REDFISH 示例: 
 
POST …/redfish/v1/Systems/system/LogServices/EventLog/Actions/LogService.ClearLog

{
    "@Message.ExtendedInfo": [
        {
            "@odata.type": "#Message.v1_1_1.Message",
            "Message": "The request completed successfully.",
            "MessageArgs": [
            ],
            "MessageId": "Base.1.13.0.Success",
            "MessageSeverity": "OK",
            "Resolution": "None"
        }
    ]
}

Affected Products

Open Server Manager

Products

PowerEdge R470, PowerEdge R670, PowerEdge R770, PowerEdge R7715, PowerEdge R7725
Article Properties
Article Number: 000226514
Article Type: Solution
Last Modified: 28 Jan 2025
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.