PowerStore: Appliance power on procedure may be delayed following Appliance Shutdown

Summary: Powering up an appliance may take longer than expected following shutting down or rebooting the appliance or cluster from PowerStore Manager.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

This issue affects powering down or rebooting an appliance or cluster from PowerStore Manager only.

This issue does not affect powering down or rebooting an appliance or a cluster from the CLI.

If the operation is performed from PowerStore Manager, powering on the appliance or appliance initialization following a reboot may take a long time.

Cause

Up until PowerStoreOS version 4.0.0, performing an appliance shutdown from PowerStore Manager is performed by shutting down the nodes one after the other. After shutting down the first node, the System Manager (SYM) node is not aware it should also shut down. A node failover is then initiated that may lead to a service disruption condition.

With PowerStoreOS version 4.0.0 or later, all internal shutdown scripts have an "appliance" flag set to indicate to SYM that both nodes are going down. Close gates and disable both nodes is then triggered instead of starting a failover.

Resolution

The issue is fixed in PowerStoreOS 4.0.0 and above.

 

Workaround

Contact Dell Technical Support to confirm this issue has occurred. Reference this KB Article in the Service Request for expedited handling. 

Affected Products

PowerStore
Article Properties
Article Number: 000247513
Article Type: Solution
Last Modified: 13 Nov 2024
Version:  2
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