Avamar: Gen4S – Hårdvara: Så här åtgärdar du olika diskhändelser och fel
Summary: Den här artikeln tar upp många av de vanliga diskrelaterade fel som rapporteras på en Gen4S-nod, tillsammans med de åtgärder som krävs.
Symptoms
Händelser som liknar följande händelser observeras i användargränssnittet eller loggfilerna:
Controller ID: 0 Unexpected sense: PD = Port 0 - 3:2:n Information unit CRC error detected, CDB = 0x28 0x00 0xb6 0x77 0xc3 0x07 0x00 0x01 0xd0 0x00, Sense = 0x70 0x00 0x0b 0x00 0x00 0x00 0x00 0x0a 0x00 0x00 0x00 0x00 0x47 0x03 0x00 0x00 0x00 0x00
Controller ID: 0 Unexpected sense: PD = Port 0 - 3:2:n Unrecovered read error, CDB = 0x28 0x00 0xd2 0x91 0xe0 0xf7 0x00 0x00 0x40 0x00, Sense = 0xf0 0x00 0x03 0xd2 0x91 0xe0 0xf7 0x0a 0x00 0x00 0x00 0x00 0x11 0x00 0x00 0x00 0x00 0x00
Controller ID: 0 Unexpected sense: PD = Port 0 - 3:2:n Hardware impending failure general hard drive failure, CDB = 0x03 0x00 0x00 0x00 0x40 0x00, Sense = 0x70 0x00 0x00 0x00 0x00 0x00 0x00 0x0a 0x00 0x00 0x00 0x00 0x5d 0x10 0x00 0x00 0x00 0x00
Controller ID: 0 PD Reset: PD = Port 0 - 3:2:n, Error = 3, Path = 0x5001234567890
Controller ID: 0 Unexpected sense: PD = -:-:n Recovered data - recommended rewrite, CDB = 0x2f 0x00 0x01 0x09 0x80 0x00 0x00 0x10 0x00 0x00, Sense = 0xf0 0x00 0x01 0x01 0x09 0x8f 0xed 0x18 0x00 0x00 0x00 0x00 0x18 0x06 0x00 0x80 0x09 0x19
Controller ID: 0 Command timeout on PD: PD = Port 0 - 3:2:n No additional sense information, CDB = 0xff 0xff 0xff 0xff 0xff 0xff 0xff 0xff 0xff 0xff 0xff 0xff 0xff 0xff 0xff 0xff, Sense = , Path = 0x5001234567890
Controller ID: 0 Unexpected sense: PD = Port 0 - 3:2:n Logical block address out of range, CDB = 0x2a 0x00 0xac 0x64 0xcd 0xe6 0x00 0x00 0x08 0x00, Sense = 0xf0 0x00 0x05 0xac 0x64 0xcd 0xe6 0x0a 0x00 0x00 0x00 0x00 0x21 0x00 0x00 0x00 0x00 0x00
Controller ID: 0 Unexpected sense: PD = Port 0 - 3:2:n Power on, reset, or bus device reset occurred, CDB = 0x2a 0x00 0x41 0xab 0x7a 0x00 0x00 0x00 0x80 0x00, Sense = 0x70 0x00 0x06 0x00 0x00 0x00 0x00 0x0a 0x00 0x00 0x00
Controller ID: 0 PD Predictive failure: Port 0 - 3:2:n
-
- 3:2:0 - 3:2:11 eller -:-:0 - -:-:11 är de interna standarddiskarna
- 3:2:12 eller -:-:12 är den interna SSD-disken.
Cause
Se lösningsavsnittet för orsaker och åtgärder.
Resolution
1. Logga in på Avamar-verktygsnoden som administratör.
2. Höj till rotprivilegium.
3. Läs in rotnycklarna per artikel Avamar: Logga in på en Avamar-server och läs in olika nycklar.
4. Med hjälp av informationen från användargränssnittshändelsen eller begäran om uppringningstjänst avgör du vilken nod som skapade felmeddelandet.
5. Anslut till noden som root med kommandot nedan:
ssn 0.# --user=root
(där 0,# är det fysiska nodnumret)
6. På den berörda noden:
a. Kontrollera diskarnas aktuella status:
avsysreport pdisk
b. Granska /var/log/messages Fil för händelser som är relaterade till disken som rapporterar händelsen.
Obligatoriska åtgärder baserat på händelser som loggas:
- För händelsen "Återställda data - rekommenderad omskrivning":
- Om disken inte rapporterade några andra händelser kan detta ignoreras på ett säkert sätt
- Om det inträffar andra händelser, t.ex. "ej återskapat läsfel", kontaktar du Dell Technologies för att avgöra om disken måste bytas ut proaktivt.
- För händelsen "Logical block address out of range":
- Om disken inte rapporterade några andra händelser kan detta ignoreras på ett säkert sätt
- Om det inträffar andra händelser, t.ex. "ej återskapat läsfel", kontaktar du Dell Technologies för att avgöra om disken måste bytas ut proaktivt.
- För händelsen "Ej återskapat läsfel":
- Om händelsen upprepas mer än tre gånger på en enskild disk kan disken i fråga ha ett integritetsproblem. Kontakta Dell Technologies för att ta reda på om disken måste bytas ut proaktivt.
- För händelsen "CRC-fel i informationsenheten detekterat":
- Om disken som rapporterar händelsen är 3:2:12 indikerar det att SSD-disken inte fungerar. Kontakta Dell Technologies för att byta ut knutan med hjälp av nodtransplantationsproceduren.
- Om disken som rapporterar händelsen är 3:2:0–3:2:11 betyder det att det är fel på hårddisken. Kontakta Dell Technologies för att proaktivt byta ut disken.
- För händelsen "Hardware near near failure general hard drive failure":
-
- Om disken som rapporterar händelsen är 3:2:12 fungerar SSD-disken inte (eller har misslyckats). Kontakta Dell Technologies för att byta ut knutan med hjälp av nodtransplantationsproceduren.
- Om disken som rapporterar händelsen är 3:2:0–3:2:11 är det fel på hårddisken (eller har slutat att fungera). Kontakta Dell Technologies för att proaktivt byta ut disken.
- För händelsen "Prediktivt fel:
- Om disken som rapporterar händelsen är 3:2:12 rapporterade SSD-disken en förutsägbar felvarning via SMART-funktionen och indikerar att SSD-disken inte fungerar. Kontakta Dell Technologies för att byta ut knutan med hjälp av nodtransplantationsproceduren.
- Om disken som rapporterar händelsen är 3:2:0–3:2:11 rapporterade hårddisken en förutsägbar felvarning via SMART-funktionen och indikerar att hårddisken är på väg att gå sönder. Kontakta Dell Technologies för att proaktivt byta ut disken.
- För händelsen "Ström på, återställning eller återställning av bussenhet inträffade":
- Granska
/var/log/messagesför att kontrollera om en eller flera diskar rapporterar felet.- Om en enskild disk rapporterar felet kan de vara relaterade till de veckovisa konsekvenskontrollerna. Kontakta Dell Technologies för att ta reda på om disken måste bytas ut proaktivt.
- Om flera diskar rapporterar felet är den fasta programvaran för expansion inaktuell eller så är chassit i ett felaktigt eller felaktigt tillstånd. Kontakta Dell Technologies för att granska nivåerna på den fasta programvaran eller byta ut noden med hjälp av nodtransplantationsproceduren.
- Granska
- För händelsen "PD Reset":
- Granska
/var/log/messagesför att kontrollera om en eller flera diskar rapporterar felet.- Om disken nyligen har bytts ut är det här meddelandet förväntat och kan ignoreras.
- Om enheten inte har bytts ut och byggts om på egen hand kan det vara fel på enheten eller så är den trasig. Kontakta Dell Technologies för att proaktivt byta ut disken.
- Granska
- För händelserna "Command timeout on PD" eller något annat fel som inte redan nämnts kontaktar du Dell Technologies för att bestämma nästa åtgärd.