Avamar: Gen4S Hardware: Çeşitli disk olaylarını ve hatalarını giderme
Summary: Bu makalede, bir Gen4S düğümünde bildirilen diskle ilgili yaygın hataların birçoğu ve gerekli eylemler ele alınmaktadır.
Symptoms
Kullanıcı arayüzünde veya günlük dosyalarında aşağıdaki olaylara benzer olaylar gözlemlenir:
Controller ID: 0 Unexpected sense: PD = Port 0 - 3:2:n Information unit CRC error detected, CDB = 0x28 0x00 0xb6 0x77 0xc3 0x07 0x00 0x01 0xd0 0x00, Sense = 0x70 0x00 0x0b 0x00 0x00 0x00 0x00 0x0a 0x00 0x00 0x00 0x00 0x47 0x03 0x00 0x00 0x00 0x00
Controller ID: 0 Unexpected sense: PD = Port 0 - 3:2:n Unrecovered read error, CDB = 0x28 0x00 0xd2 0x91 0xe0 0xf7 0x00 0x00 0x40 0x00, Sense = 0xf0 0x00 0x03 0xd2 0x91 0xe0 0xf7 0x0a 0x00 0x00 0x00 0x00 0x11 0x00 0x00 0x00 0x00 0x00
Controller ID: 0 Unexpected sense: PD = Port 0 - 3:2:n Hardware impending failure general hard drive failure, CDB = 0x03 0x00 0x00 0x00 0x40 0x00, Sense = 0x70 0x00 0x00 0x00 0x00 0x00 0x00 0x0a 0x00 0x00 0x00 0x00 0x5d 0x10 0x00 0x00 0x00 0x00
Controller ID: 0 PD Reset: PD = Port 0 - 3:2:n, Error = 3, Path = 0x5001234567890
Controller ID: 0 Unexpected sense: PD = -:-:n Recovered data - recommended rewrite, CDB = 0x2f 0x00 0x01 0x09 0x80 0x00 0x00 0x10 0x00 0x00, Sense = 0xf0 0x00 0x01 0x01 0x09 0x8f 0xed 0x18 0x00 0x00 0x00 0x00 0x18 0x06 0x00 0x80 0x09 0x19
Controller ID: 0 Command timeout on PD: PD = Port 0 - 3:2:n No additional sense information, CDB = 0xff 0xff 0xff 0xff 0xff 0xff 0xff 0xff 0xff 0xff 0xff 0xff 0xff 0xff 0xff 0xff, Sense = , Path = 0x5001234567890
Controller ID: 0 Unexpected sense: PD = Port 0 - 3:2:n Logical block address out of range, CDB = 0x2a 0x00 0xac 0x64 0xcd 0xe6 0x00 0x00 0x08 0x00, Sense = 0xf0 0x00 0x05 0xac 0x64 0xcd 0xe6 0x0a 0x00 0x00 0x00 0x00 0x21 0x00 0x00 0x00 0x00 0x00
Controller ID: 0 Unexpected sense: PD = Port 0 - 3:2:n Power on, reset, or bus device reset occurred, CDB = 0x2a 0x00 0x41 0xab 0x7a 0x00 0x00 0x00 0x80 0x00, Sense = 0x70 0x00 0x06 0x00 0x00 0x00 0x00 0x0a 0x00 0x00 0x00
Controller ID: 0 PD Predictive failure: Port 0 - 3:2:n
-
- 3:2:0 - 3:2:11 veya -:-:0 - -:-:11 dahili standart disklerdir
- 3:2:12 veya -:-:12 dahili SSD diskidir.
Cause
Nedenler ve eylemler için çözüm bölümüne bakın.
Resolution
1. Avamar Utility Node'da yönetici olarak oturum açın.
2. Kök ayrıcalığına yükseltin.
3. Makale başına kök anahtarları yükleme Avamar: Avamar Server'da Oturum Açma ve Çeşitli Anahtarları Yükleme (İngilizce).
4. Kullanıcı arayüzü olayından veya ev arama Servis İsteğinden alınan bilgileri kullanarak hata mesajına neden olan düğümü belirleyin.
5. Aşağıdaki komutu kullanarak kök olarak düğüme bağlanın:
ssn 0.# --user=root
(Burada 0.# fiziksel düğüm numarasıdır)
6. Etkilenen düğümde:
a. Disklerin geçerli durumunu kontrol edin:
avsysreport pdisk
b. Şunu inceleyin: /var/log/messages Olayı bildiren diskle ilgili olaylar için dosya.
Günlüğe kaydedilen olaylara göre gerekli eylemler:
- "Kurtarılan veriler - önerilen yeniden yazma" olayı için:
- Disk başka bir olay bildirmediyse bu sorun güvenle göz ardı edilebilir
- Unrecovered Read Error" gibi başka olaylar varsa diskin proaktif olarak değiştirilmesinin gerekip gerekmediğini belirlemek için Dell Technologies ile iletişime geçin .
- Mantıksal blok adresi aralık dışında" olayı için:
- Disk başka bir olay bildirmediyse bu sorun güvenle göz ardı edilebilir
- Unrecovered Read Error" gibi başka olaylar varsa diskin proaktif olarak değiştirilmesinin gerekip gerekmediğini belirlemek için Dell Technologies ile iletişime geçin .
- Unrecovered read error" olayı için:
- Olay tek bir diskte üç defadan fazla tekrarlanırsa söz konusu diskte bir bütünlük sorunu olabilir. Diskin proaktif olarak değiştirilmesinin gerekip gerekmediğini belirlemek için Dell Technologies ile iletişime geçin.
- Information unit CRC error detected" olayı için:
- Olayı bildiren disk 3:2:12 ise SSD'nin arızalı olduğunu gösterir. Düğüm nakli prosedürünü kullanarak düğümü değiştirmek için Dell Technologies ile iletişime geçin.
- Olayı bildiren disk 3:2:0-3:2:11 ise bu, sabit sürücünün arızalı olduğunu gösterir. Diski proaktif olarak değiştirmek için Dell Technologies ile iletişime geçin.
- Yaklaşan donanım arızası genel sabit sürücü arızası" olayı için:
-
- Olayı bildiren disk 3:2:12 ise, SSD arızalıdır (veya arızalanmıştır). Düğüm nakli prosedürünü kullanarak düğümü değiştirmek için Dell Technologies ile iletişime geçin.
- Olayı bildiren disk 3:2:0-3:2:11 ise, sabit sürücü arızalıdır (veya arızalanmıştır). Diski proaktif olarak değiştirmek için Dell Technologies ile iletişime geçin.
- Olay için "Tahmine dayalı arıza:
- Olayı bildiren disk 3:2:12 ise SSD, SMART işlevi aracılığıyla bir öngörücü arıza uyarısı bildirir ve SSD'nin arızalandığını gösterir. Düğüm nakli prosedürünü kullanarak düğümü değiştirmek için Dell Technologies ile iletişime geçin.
- Olayı bildiren disk 3:2:0-3:2:11 ise sabit sürücü, SMART işlevi aracılığıyla bir öngörülü arıza uyarısı bildirdi ve bu, sabit sürücünün arızalı olduğunu gösterir. Diski proaktif olarak değiştirmek için Dell Technologies ile iletişime geçin.
- Güç açıldı, sıfırlandı veya veri yolu aygıtı sıfırlandı" olayı için:
- Şunu inceleyin:
/var/log/messagesTek bir diskin mi yoksa birden fazla diskin mi hata bildirdiğini kontrol etmek için dosya.- Tek bir disk hata bildiriyorsa bunlar haftalık tutarlılık denetimleriyle ilgili olabilir. Diskin proaktif olarak değiştirilmesinin gerekip gerekmediğini belirlemek için Dell Technologies ile iletişime geçin.
- Birden fazla disk hata bildiriyorsa genişletici bellenimi güncel değildir veya kasa arızalı ya da arızalı durumdadır. Bellenim düzeylerini gözden geçirmek veya düğüm nakli prosedürünü kullanarak düğümü değiştirmek için Dell Technologies ile iletişime geçin.
- Şunu inceleyin:
- PD Reset" olayı için:
- Şunu inceleyin:
/var/log/messagesTek bir diskin mi yoksa birden fazla diskin mi hata bildirdiğini kontrol etmek için dosya.- Disk yakın zamanda değiştirilmişse bu mesaj beklenen bir durumdur ve göz ardı edilebilir.
- Sürücü değiştirilmediyse ve kendi başına yeniden oluşturulmadıysa, sürücü arızalı veya arızalı olabilir. Diski proaktif olarak değiştirmek için Dell Technologies ile iletişime geçin.
- Şunu inceleyin:
- PD'de komut zaman aşımı" olayları veya daha önce belirtilmeyen başka bir hata için Sonraki eylem planını belirlemek üzere Dell Technologies ile iletişime geçin .