NVP-vProxy: El disco de VM no se puede respaldar con el mensaje "VDDK Error: 13: No tiene derechos de acceso a este archivo.... El punto de montaje ya existe"
Summary: Está respaldando una máquina virtual (VM) con el dispositivo vProxy de NetWorker VMware Protection (NVP), pero uno o más discos de VM no se pueden respaldar. La falla informa "VDDK Error: 13: You do not have access rights to this file." Este es un error general que puede aparecer para varios síntomas. En este escenario, el vbackupd-vddk.log vProxy indica que el punto de montaje ya existe. Esto ocurre cuando un archivo .vmdk de VM quedaba conectado a un vProxy. ...
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Symptoms
La integración de NetWorker VMware Protection se configura con el vProxy Appliance. El respaldo de una máquina virtual (VM) no puede respaldar un disco específico (.vmdk). La falla en NetWorker Management Console (NMC) informa "No se puede respaldar el disco virtual "Disco duro #"" sin información adicional.
Los registros de la sesión de respaldo en NetWorker Server o vProxy muestran lo siguiente para el archivo .vmdk afectado:
Linux: /nsr/logs/policy/policy_name
Windows (valor predeterminado): C:\Program Files\EMC NetWorker\nsr\logs\policy\policy_name
vProxy: /opt/emc/vproxy/runtime/logs/recycle/vbackupd/DATE/
YYYY/MM/DD HH:MM:SS ERROR: [194] Failed to open source VMDK "[DATASTORE] VM_NAME/VM_NAME_1.vmdk": VDDK Error: 13: You do not have access rights to this file.
YYYY/MM/DD HH:MM:SS ERROR: [194] "Hard disk 2": BackupVmdk: "Hard disk 2": Unable to open Virtual Disk "[DATASTORE] VM_NAME/VM_NAME_1.vmdk" in "hotadd" mode.
YYYY/MM/DD HH:MM:SS ERROR: [194] "Hard disk 2": BackupVmdk: "Hard disk 2": Unable to open Virtual Disk "[DATASTORE] VM_NAME/VM_NAME_1.vmdk" in "hotadd" mode.
YYYY/MM/DD HH:MM:SS ERROR: [194] "Hard disk 2": BackupVmdk: Failed backup.
En el vProxy, /opt/emc/vproxy/runtime/logs/vbackupd-vddk.log muestra lo siguiente:
YYYY/MM/DD HH:MM:SS NOTICE: VDDK INFO VixDiskLib: VixDiskLib_OpenEx: Cannot open disk [DATASTORE] VM_NAME/VM_NAME_1.vmdk. Error 13 (You do not have access rights to this file) (Mounting VM vm-### using transport hotadd failed : Mount point "/tmp/vmware-root/50268f14....177-vm-###/hotadd" already exists..) at 5026.
YYYY/MM/DD HH:MM:SS NOTICE: VDDK INFO VixDiskLib: VixDiskLib_Open: Cannot open disk [DATASTORE] VM_NAME/VM_NAME_1.vmdk. Error 13 (You do not have access rights to this file) at 5064.
YYYY/MM/DD HH:MM:SS NOTICE: VDDK INFO VixDiskLib: VixDiskLib_Disconnect: Disconnect.
Cause
El archivo .vmdk de la VM se dejó conectado al dispositivo vProxy después de un respaldo anterior, lo que generó el error "Mount point xxxxx already exists".
Resolution
Hay dos opciones disponibles.
Opción 1:
Utilice la utilidad ProxyHC para limpiar los discos que quedan.
NVP-vProxy: Cómo usar la herramienta de evaluación del estado ProxyHC en el dispositivo
vProxyEn la base de conocimientos anterior, se detalla cómo obtener y utilizar la herramienta ProxyHC. La sintaxis necesaria para este problema específico es:
NVP-vProxy: Cómo usar la herramienta de evaluación del estado ProxyHC en el dispositivo
vProxyEn la base de conocimientos anterior, se detalla cómo obtener y utilizar la herramienta ProxyHC. La sintaxis necesaria para este problema específico es:
./ProxyHC tasks disk cleanup
Opción 2:
Limpieza manual de los discos configurados del vProxy. Los .vmdk adicionales se deben desconectar del dispositivo vProxy. Si el vProxy no realiza respaldos ni restauraciones, el dispositivo vProxy solo debe tener sus dos .vmdk conectados a la VM del dispositivo vProxy.
1. Detenga los respaldos de VM que pasan por el vProxy e informa el error "Mount point xxxxxx already exists".
2. Inicie sesión en vSphere Web Client de vCenter.
3. Haga clic con el botón secundario en el dispositivo vProxy y seleccione "Edit Settings..."
4. Compruebe si hay discos que pertenezcan a otras máquinas virtuales:
2. Inicie sesión en vSphere Web Client de vCenter.
3. Haga clic con el botón secundario en el dispositivo vProxy y seleccione "Edit Settings..."
4. Compruebe si hay discos que pertenezcan a otras máquinas virtuales:
5. Si hay discos .vmdk adicionales conectados al dispositivo vProxy, tome nota del nombre de la VM y desconecte los discos. Los .vmdk contienen el nombre para mostrar de la VM de vSphere (u otro nombre de VM que no sea el nombre del vProxy).
ADVERTENCIA: No utilice la opción "eliminar del almacén de datos". El disco se debe desconectar del vProxy, no se debe eliminar del almacenamiento. No quite ninguno de los discos que pertenecen al vProxy.
6. En vSphere, busque la VM cuyos discos se desconectaron del vProxy.
7. En la pestaña Summary de la VM, haga clic en Edit en Custom Attributes.
8. Seleccione cada uno de los atributos que contienen "Dell EMC vProxy" y elimínelos. Se volverán a crear durante la siguiente acción de vProxy. La eliminación de los atributos garantiza que se elimine toda la información obsoleta de la sesión.
9. Reinicie el dispositivo vProxy.
Additional Information
NOTA: El "Error 13 de VDDK" es un error general devuelto por VMware. El vProxy /opt/emc/vproxy/runtime/logs/vbackupd-vddk.log proporciona más información sobre la causa específica. Los siguientes artículos también se deben revisar si este artículo no es aplicable.
- NVP-vProxy de NetWorker: Los respaldos fallan con el siguiente error: VDDK Error: 13: "No tiene derechos de acceso a este archivo". "No se pudo asignar el ID de destino de SCSI"
- NVP vProxy: Los respaldos de VM fallan con el mensaje "VDDK Error: 13: No tiene derechos de acceso a este archivo... No se puede abrir el disco virtual en el modo de adición en caliente"
- NVP vProxy: Los respaldos de VM fallan con el mensaje "VDDK Error 13: No tiene derechos de acceso a este archivo": Guía de solución de problemas/triage.
Affected Products
NetWorkerProducts
NetWorkerArticle Properties
Article Number: 000031379
Article Type: Solution
Last Modified: 24 Oct 2025
Version: 6
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