NVP-vProxy. Сбой резервного копирования диска виртуальной машины с ошибкой «VDDK Error: 13: У вас нет прав доступа к этому файлу.... Точка монтирования уже существует"
Summary: Выполняется резервное копирование виртуальной машины (ВМ) с помощью устройства NetWorker VMware Protection (NVP) vProxy, но не удается выполнить резервное копирование одного или нескольких дисков виртуальной машины. В отчете о сбое отображается сообщение «Ошибка VDDK: 13: У вас нет прав доступа к этому файлу." Это общая ошибка, которая может проявляться при нескольких признаках. В этом случае vbackupd-vddk.log vProxy указывает на то, что точка монтирования уже существует. Это происходит, когда файл .vmdk виртуальной машины остается прикрепленным к vProxy. ...
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
Интеграция NetWorker VMware Protection настраивается с помощью устройства vProxy. При резервном копировании виртуальной машины (ВМ) не удается создать резервную копию определенного диска (.vmdk). При сбое в консоли управления NetWorker Management Console (NMC) появляется сообщение «Невозможно создать резервную копию виртуального диска "Hard Disk #"» без дополнительной информации.
Журналы сеансов резервного копирования на сервере NetWorker или vProxy показывают следующие сведения для затронутого .vmdk:
Linux: /nsr/logs/policy/policy_name
Windows (по умолчанию): C:\Program Files\EMC NetWorker\nsr\logs\policy\policy_name
Виртуальный прокси: /opt/emc/vproxy/runtime/logs/recycle/vbackupd/DATE/
YYYY/MM/DD HH:MM:SS ERROR: [194] Failed to open source VMDK "[DATASTORE] VM_NAME/VM_NAME_1.vmdk": VDDK Error: 13: You do not have access rights to this file.
YYYY/MM/DD HH:MM:SS ERROR: [194] "Hard disk 2": BackupVmdk: "Hard disk 2": Unable to open Virtual Disk "[DATASTORE] VM_NAME/VM_NAME_1.vmdk" in "hotadd" mode.
YYYY/MM/DD HH:MM:SS ERROR: [194] "Hard disk 2": BackupVmdk: "Hard disk 2": Unable to open Virtual Disk "[DATASTORE] VM_NAME/VM_NAME_1.vmdk" in "hotadd" mode.
YYYY/MM/DD HH:MM:SS ERROR: [194] "Hard disk 2": BackupVmdk: Failed backup.
На vProxy, /opt/emc/vproxy/runtime/logs/vbackupd-vddk.log отображается:
YYYY/MM/DD HH:MM:SS NOTICE: VDDK INFO VixDiskLib: VixDiskLib_OpenEx: Cannot open disk [DATASTORE] VM_NAME/VM_NAME_1.vmdk. Error 13 (You do not have access rights to this file) (Mounting VM vm-### using transport hotadd failed : Mount point "/tmp/vmware-root/50268f14....177-vm-###/hotadd" already exists..) at 5026.
YYYY/MM/DD HH:MM:SS NOTICE: VDDK INFO VixDiskLib: VixDiskLib_Open: Cannot open disk [DATASTORE] VM_NAME/VM_NAME_1.vmdk. Error 13 (You do not have access rights to this file) at 5064.
YYYY/MM/DD HH:MM:SS NOTICE: VDDK INFO VixDiskLib: VixDiskLib_Disconnect: Disconnect.
Cause
После предыдущего резервного копирования файл .vmdk виртуальной машины оставался подключенным к устройству vProxy, что приводило к ошибке «Mount point xxxxx already exists».
Resolution
Доступны два варианта.
Вариант 1.
Используйте утилиту ProxyHC для очистки оставшихся дисков.
NVP-vProxy: Использование инструмента диагностики системы ProxyHC на устройстве
vProxyВ приведенной выше статье базы знаний подробно описано, как получить и использовать инструмент ProxyHC. В данном конкретном случае используется следующий синтаксис:
NVP-vProxy: Использование инструмента диагностики системы ProxyHC на устройстве
vProxyВ приведенной выше статье базы знаний подробно описано, как получить и использовать инструмент ProxyHC. В данном конкретном случае используется следующий синтаксис:
./ProxyHC tasks disk cleanup
Вариант 2.
Ручная очистка настроенных дисков vProxy. Дополнительные файлы .vmdk должны быть отключены от устройства vProxy. Если vProxy не выполняет резервное копирование или восстановление, к виртуальной машине устройства vProxy должны быть подключены только два файла .vmdk.
1. Остановите резервное копирование виртуальной машины, проходящее через vProxy, и сообщение об ошибке «Mount point xxxxxx already exists».
2. Войдите в веб-клиент vCenter vSphere.
3. Нажмите правой кнопкой мыши на устройстве vProxy и выберите «Edit Settings...»
4. Проверьте наличие дисков, принадлежащих другим виртуальным машинам:
2. Войдите в веб-клиент vCenter vSphere.
3. Нажмите правой кнопкой мыши на устройстве vProxy и выберите «Edit Settings...»
4. Проверьте наличие дисков, принадлежащих другим виртуальным машинам:
5. Если к устройству vProxy подключены дополнительные диски .vmdk, запишите имя виртуальной машины и отсоедините диски. Файлы .vmdk содержат отображаемое имя виртуальной машины vSphere (или другое имя виртуальной машины, отличное от имени vProxy).
ВНИМАНИЕ! Не используйте параметр «удалить из хранилища данных». Диск должен быть отсоединен от vProxy, а не удален из хранилища. Не удаляйте диски, принадлежащие vProxy.
6. В vSphere найдите виртуальную машину, диски которой были отключены от vProxy.
7. На вкладке «Summary » виртуальной машины нажмите Edit в разделе Custom Attributes.
8. Выберите каждый из атрибутов, содержащих «Dell EMC vProxy», и удалите их. Они будут повторно созданы при следующем действии с использованием vProxy. Удаление атрибутов гарантирует, что вся устаревшая информация о сеансе будет удалена.
9. Перезагрузите устройство vProxy.
Additional Information
ПРИМЕЧАНИЕ. «VDDK Error 13» — это общая ошибка, возвращенная VMware. Команда vProxy /opt/emc/vproxy/runtime/logs/vbackupd-vddk.log предоставляет дополнительные сведения о конкретной причине. Следующие статьи также следует просмотреть, если эта статья не применима.
- NetWorker NVP-vProxy. Сбой резервного копирования с ошибкой: VDDK Error: 13: «У вас нет прав доступа к этому файлу». «Не удалось выделить идентификатор цели SCSI»
- NVP-vProxy. Сбой резервного копирования виртуальной машины с ошибкой «VDDK error: 13: У вас нет прав доступа к этому файлу... Не удается открыть виртуальный диск в режиме горячего добавления»
- NVP-vProxy. Сбой резервного копирования виртуальной машины с ошибкой «VDDK Error 13: У вас нет прав доступа к этому файлу" - Руководство по поиску и устранению неисправностей/рассмотрению вопросов.
Affected Products
NetWorkerProducts
NetWorkerArticle Properties
Article Number: 000031379
Article Type: Solution
Last Modified: 24 Oct 2025
Version: 6
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.