PowerPath for Windows : Windows shows harddisk?? in PowerPath
Summary: Windows shows harddisk?? in PowerPath
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
Typically this has been seen when a migration activity from one set of disks to another set of disks has occurred. However there are other causes.
PowerPath for Windows displays harddisk?? in the PowerPath GUI or in powermt display dev=all.
The device is visible at the HBA level and also at the MPIO level.
PowerPath for Windows displays harddisk?? in the PowerPath GUI or in powermt display dev=all.
The device is visible at the HBA level and also at the MPIO level.
Cause
It would appear that the Windows LDM is somehow compromised.
Resolution
Make sure that the file powermt.custom or powermt.custom.xml is removed (deleted) from the c:\program files\EMC\powercommon or c:\program files\EMC\PowerPath folders (depending on version of PowerPath) before carrying out any of the below options.
Option 1 - any of these steps may provide a resolution however if these do not then Option 2 or Option 3 will need to be carried out.
Option 2
Option 3
Option 1 - any of these steps may provide a resolution however if these do not then Option 2 or Option 3 will need to be carried out.
1) Remove powermt.custom.xml file and Reboot.
2) Scan for hardware changes in device manager.
3) powermt check reconfig
2) Scan for hardware changes in device manager.
3) powermt check reconfig
Option 2
1) Remove the suspect device(s) from visibility from the host.
2) Open a command prompt (right click and Run as Administrator).:
Then run the following 2 commands in the command prompt:
Set devmgr_show_nonpresent_devices=1
Start devmgmt.msc
This will open the device manager.
3) Select Menu item "View" "Show Hidden devices".
4) Expand the disk section of the tree.
5) Right click and uninstall all of the greyed out disk devices (including all PowerPath devices).
6) When complete reboot.
7) Make the device(s) visible to the host again.
8) Scan for hardware changes in device manager.
2) Open a command prompt (right click and Run as Administrator).:
Then run the following 2 commands in the command prompt:
Set devmgr_show_nonpresent_devices=1
Start devmgmt.msc
This will open the device manager.
3) Select Menu item "View" "Show Hidden devices".
4) Expand the disk section of the tree.
5) Right click and uninstall all of the greyed out disk devices (including all PowerPath devices).
6) When complete reboot.
7) Make the device(s) visible to the host again.
8) Scan for hardware changes in device manager.
Option 3
1) Remove all external devices from visibility from the host. Note: If the host is Boot from SAN then the boot device will by necessity need to be kept visible to the host down the primary boot path.
2) Uninstall PowerPath and reboot.
3) Open a command prompt (right click and Run as Administrator):
Then run the following 2 commands in the command prompt:
Set devmgr_show_nonpresent_devices=1
Start devmgmt.msc
This will open the device manager
4) Select Menu item "View" "Show Hidden devices"
5) Expand the disk section of the tree.
6) Right click and uninstall all of the greyed out disk devices (including all PowerPath devices).
7) When complete reboot.
8) Make the devices visible to the host again.
9) Install PowerPath and reboot.
2) Uninstall PowerPath and reboot.
3) Open a command prompt (right click and Run as Administrator):
Then run the following 2 commands in the command prompt:
Set devmgr_show_nonpresent_devices=1
Start devmgmt.msc
This will open the device manager
4) Select Menu item "View" "Show Hidden devices"
5) Expand the disk section of the tree.
6) Right click and uninstall all of the greyed out disk devices (including all PowerPath devices).
7) When complete reboot.
8) Make the devices visible to the host again.
9) Install PowerPath and reboot.
Additional Information
If MPIO is not claiming devices properly (with no PowerPath installed) then an equivalent routine for MPIO is
1) Remove all external devices from visibility from the host.
2) disable/uninstall Microsoft feature MPIO and reboot
3) Open a command prompt (right click and Run as Administrator):
Then run the following 2 commands in the command prompt:
Set devmgr_show_nonpresent_devices=1
Start devmgmt.msc
This will open the device manager
4) Select Menu item "View" "Show Hidden devices"
5) Expand the disk section of the tree.
6) Right click and uninstall all of the greyed out disk devices
7) When complete reboot.
8) Make the devices visible to the host again.
9) scan for hardware changes in device manager
10) enable/install MPIO and reboot
1) Remove all external devices from visibility from the host.
2) disable/uninstall Microsoft feature MPIO and reboot
3) Open a command prompt (right click and Run as Administrator):
Then run the following 2 commands in the command prompt:
Set devmgr_show_nonpresent_devices=1
Start devmgmt.msc
This will open the device manager
4) Select Menu item "View" "Show Hidden devices"
5) Expand the disk section of the tree.
6) Right click and uninstall all of the greyed out disk devices
7) When complete reboot.
8) Make the devices visible to the host again.
9) scan for hardware changes in device manager
10) enable/install MPIO and reboot
Affected Products
PowerPath for WindowsProducts
PowerPath for WindowsArticle Properties
Article Number: 000050184
Article Type: Solution
Last Modified: 20 Nov 2024
Version: 4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.