Avamar: Prestaties van Windows-server: Trage back-up van het bestandssysteem op servers met PGP-schijven

Summary: Dit Knowledge Base-artikel bespreekt problemen met trage back-upprestaties die worden veroorzaakt door Windows Security Identifiers (SID's) in Avamar, wat resulteert in vertraagde back-ups als gevolg van het verzamelen van gebruikersprofielen. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

De back-upprestaties van Avamar zijn traag.

Voorbeeld: 

Backed-up 6.659 MB in 105.79 minutes: 3.8 MB/hour (1 files/hour)

Cause

In de back-uplogboeken waarin foutopsporing is ingeschakeld, wordt de back-up snel gestart en voltooid, zoals hieronder wordt weergegeven.

Het begin van de back-uptaak begint als volgt:

2017-05-25 04:33:52 avtar Info : Logging to C:\Program Files\avs\var\Test05232017.log xxxxxxxxxxxxxxxxx

De back-uptaak wordt snel uitgevoerd, zoals hier wordt weergegeven:

2017/05/25-02:34:17.84500 [avtar] creating .system_info directory
2017-05-25 04:34:17 avtar Info : Backup complete, wrapping-up session with Server

De vertraging zat in het aanmaken van de gebruikersprofielen ".system_info/userinfo.xml" Als het begint met het lezen van de profielen:

2017-05-25 04:34:18 avtar Info : Reading 37 user profiles

Meer dan twee uur later was de opsomming van de gebruikersprofielen voltooid:

2017-05-25 06:50:34 avtar Info : Done reading user profiles

De back-up was een halve seconde later voltooid.

2017-05-25 06:50:35 avtar Info : Backup #10 timestamp 2017-05-25 06:50:34, 3 files, 3 folders, 4.578 KB (3 files, 1.576 KB, 34.43% new)
2017/05/25-04:50:35.04299 [avtar] backup expire prectime=131431854349654640
2017-05-25 06:50:35 avtar Info : Label "test w/new flags", scheduled to expire after 06/29/17 (2017-06-29 04:50:34 UTC)
2017-05-25 06:50:35 avtar Info : Backed-up 4.578 KB in 136.72 minutes: 2.0 KB/hour (1 files/hour)


Het probleem was geïsoleerd voor sommige SID's zoals SID "S-1-5-21-1761170581-294597109-3035037286-64925452" waarbij de corresponderende gebruikersnaam ontbrak. Het Avtar-proces liep vast bij het verwerken van deze SID's, waardoor deze vertraging ontstond.

Resolution

Als tijdelijke oplossing kunt u een avtar.cmd bestand maken in de map C:\Program Files\var of een andere map waarin de Avamar Windows-clientsoftware is geïnstalleerd. Voeg vervolgens de volgende vlag toe en sla het bestand op:

--x05=65536

 

Deze markering schakelt het verzamelen van gebruikersprofielen tijdens het back-upproces uit. Deze vlag heeft een aanzienlijke impact op de prestaties. Controleer op de lange termijn de vertrouwensrelaties van het Active Directory-domein in de omgeving en schoon domeinaccounts met inconsistente SID-vermeldingen. Om dat te doen, krijgt u meer details over deze SID's met behulp van de onderstaande procedure.

1. Open de Register-editor door de volgende opdracht te typen in de zoekbalk van Windows:

regedit

2. Ga naar het onderstaande pad:

HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\ProfileList

Alle SID's worden hier vermeld, en de "ProfileImagePath" sleutel gaat over de naam van elke SID.
3. Gebruik de applicatie van derden "PsGetSid.exe" om de naam in de opdrachtregel weer te geven.

Voorbeeld:

PsGetsid S-1-5-21-854245398-1973579041-362214817-1745107


PsGetSid.exe is beschikbaar via: https://learn.microsoft.com/en-us/sysinternals/downloads/psgetsid (Externe link)

Zodra de problematische gebruikersaccounts zijn verwijderd, verwijdert u ze uit het register met behulp van regedit.exe. De avtar-vlag is niet langer nodig als het opruimen klaar is.

--x05=65536

Affected Products

Avamar, Avamar Client for Windows
Article Properties
Article Number: 000053881
Article Type: Solution
Last Modified: 24 Sept 2025
Version:  5
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.