Avamar: Backup Fails with "Not Enough Space" and "Out of Memory for cache file"
Summary: Avamar backup fails with "Not Enough Space" and "Out of Memory for cache file."
Symptoms
An Avamar backup fails with the following messages recorded in the backup log.
AVTAR FATAL <5351>: Main: Unhandled internal exception Unix exception Not Enough Space AVTAR Debug-Error <0001> Out of Memory for cache file C:\Program Files\avs\var\p_cache.dat size 1610613280
Cause
The root cause is unknown, but the messages indicate that the client machine is short of space.
This could be either because there is not enough disk space for the cache file to be written. Or, it could be because the client is unable to hold the hash cache file in memory.
Resolution
- Ensure that the caches are appropriately sized for the amount of data being backed up (see the Operational Best Practices Guide)
- Ensure that the client has enough memory to hold the cache files along with any other applications which are in use on the machine
- Ensure that the client has sufficient disk space for the cache file to be stored
If the backup never previously worked, contact your Dell partner or Professional Services.
Additional Information
During a backup, both the file cache (f_cache.dat) and the hash cache (p_cache.dat) are loaded into memory.
The client must have enough memory to store the caches, the avtar process, and other processes running on the machine. If not, the backup fails with the messages reported above.
Backups sent to Data Domain use a paging file cache. This reduces the memory required for holding entries in the file cache.