Dell Unity: Når der opstår fejl på en disk i en dynamisk pulje, kan systemets ydeevne blive påvirket

Summary: Når der opstår fejl på en disk i en dynamisk pulje, kan systemets ydeevne blive påvirket.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Dynamic Pools kan bruge tildelt plads i puljen til at genopbygge.
Da genopbygningen startede, var der fuldstændig utilgængelighed af data, indtil den defekte disk blev udskiftet, og genopbygningen var fuldført.
Da genopbygningen var fuldført, vendte ydeevnen tilbage til normal.

En dynamisk pulje havde en drevfejl.
Puljen begyndte at genopbygge til ledig plads i poolen.
Det påvirkede systemets ydeevne i en sådan grad, at data ikke var tilgængelige.

 

Cause

Den grundlæggende årsag til problemet er, at værts-I/O'er bliver langsommere, fordi SP bruger ressourcerne.
Handlingen dynamisk genopbygning/omrokering af pulje bruger så mange ressourcer, at der ikke er nok tilovers til værtens I/O.

 

Resolution

Kontakt Dells tekniske support eller din autoriserede servicerepræsentant, og oplys dette artikel-id i Dell Knowledge Base.
Dette vil blive behandlet i en fremtidig version af Unity Code.

Vi kan bekræfte problemet ved hjælp af følgende trin:

  1. Opret en SSH-session til systemet.

  2. Bekræft ved hjælp af nedenstående kommando for at afgøre, om den pågældende pulje er dynamisk:
    Kommando: uemcli /stor/config/pool -name "<name of pool>" show -detail

    Eksempel:

    15:25:23 service@APMx spb:~/user> uemcli /stor/config/pool -name "My Dynamic Pool" show -detail
    Storage system address: 127.0.0.1
    Storage system port: 443
    HTTPS connection
    
    1:    ID              = pool_4
          Type            = Dynamic
          Name            = My Dynamic Pool
          Description     =
          Total space     = 6176968278016 (5.6T)
    <...>
  3. Kontroller, at en genopbygning er i gang med nedenstående kommando:
    Kommando: cat /EMC/C4Core/log/EMCSystemLogBackup.log | grep -i "<pool name>"

    Eksempel:

    15:26:23 service@APMx spb:~/user> cat /EMC/C4Core/log/EMCSystemLogBackup.log | grep -i "My Dynamic Pool"
    
    "2019-04-13T18:40:02.213Z" "spb@APMx" "Neo_CEM" "23864" "N/A" "WARN" "14:6032d" :: "Storage pool My Dynamic Pool is degraded." :: Category=User Component=Health TimeZone=UTC
    
    "2019-04-13T18:45:12.766Z" "spb@APMx" "Neo_CEM" "23864" "N/A" "WARN" "14:60343" :: "Storage pool My Dynamic Pool is rebuilding due to the loss of a drive." :: Category=User Component=Health TimeZone=UTC

Som fremhævet ovenfor giver kommandoen output, der angiver, at puljen er forringet, samt den rapporterer "Puljen genopbygges."

 

Affected Products

Dell EMC Unity 650F

Products

Dell EMC Unity 300F, Dell EMC Unity 350F, Dell EMC Unity XT 380F, Dell EMC Unity 400F, Dell EMC Unity 450F, Dell EMC Unity XT 480F, Dell EMC Unity 600F, Dell EMC Unity 650F, Dell EMC Unity XT 680F, Dell EMC Unity XT 880F , Dell EMC Unity Family |Dell EMC Unity All Flash ...
Article Properties
Article Number: 000055614
Article Type: Solution
Last Modified: 20 Oct 2025
Version:  5
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.