Dell Unity : Lorsqu’un disque tombe en panne dans un pool dynamique, les performances de la baie peuvent être affectées

Summary: Lorsqu’un disque tombe en panne dans un pool dynamique, les performances de la baie peuvent être affectées.

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Symptoms

Les pools dynamiques peuvent utiliser l’espace alloué dans le pool pour la reconstruction.
Lorsque la reconstruction a démarré, il y avait une indisponibilité totale des données jusqu’à ce que le disque défaillant soit remplacé et que la reconstruction soit terminée.
Une fois la reconstruction terminée, les performances reviennent à la normale.

Un pool dynamique a subi une défaillance de disque.
Le pool a commencé à se reconstruire dans l’espace de secours qu’il contient.
Cela a affecté les performances de la baie au point que l’indisponibilité des données s’est produite.

 

Cause

La cause première du problème réside dans le ralentissement des E/S de l’hôte, car le processeur de stockage utilise les ressources.
L’opération de reconstruction/remaniement du pool dynamique consomme tellement de ressources qu’il n’en reste pas assez pour les I/O de l’hôte.

 

Resolution

Contactez le support technique Dell ou votre représentant de service agréé en leur communiquant l’identifiant de cet article de la base de connaissances Dell.
Ce problème sera résolu dans une prochaine version du code Unity.

Nous pouvons confirmer le problème en procédant comme suit :

  1. Établissez une session SSH sur la baie.

  2. Vérifiez à l’aide de la commande ci-dessous pour déterminer si le pool en question est dynamique :
    Commande : uemcli /stor/config/pool -name "<name of pool>" show -detail

    Exemple :

    15:25:23 service@APMx spb:~/user> uemcli /stor/config/pool -name "My Dynamic Pool" show -detail
    Storage system address: 127.0.0.1
    Storage system port: 443
    HTTPS connection
    
    1:    ID              = pool_4
          Type            = Dynamic
          Name            = My Dynamic Pool
          Description     =
          Total space     = 6176968278016 (5.6T)
    <...>
  3. Vérifiez qu’une reconstruction est en cours à l’aide de la commande ci-dessous :
    Commande : cat /EMC/C4Core/log/EMCSystemLogBackup.log | grep -i "<pool name>"

    Exemple :

    15:26:23 service@APMx spb:~/user> cat /EMC/C4Core/log/EMCSystemLogBackup.log | grep -i "My Dynamic Pool"
    
    "2019-04-13T18:40:02.213Z" "spb@APMx" "Neo_CEM" "23864" "N/A" "WARN" "14:6032d" :: "Storage pool My Dynamic Pool is degraded." :: Category=User Component=Health TimeZone=UTC
    
    "2019-04-13T18:45:12.766Z" "spb@APMx" "Neo_CEM" "23864" "N/A" "WARN" "14:60343" :: "Storage pool My Dynamic Pool is rebuilding due to the loss of a drive." :: Category=User Component=Health TimeZone=UTC

Comme indiqué ci-dessus, la commande fournit un résultat indiquant que le pool est dégradé et signale que le pool est en cours de reconstruction.

 

Affected Products

Dell EMC Unity 650F

Products

Dell EMC Unity 300F, Dell EMC Unity 350F, Dell EMC Unity XT 380F, Dell EMC Unity 400F, Dell EMC Unity 450F, Dell EMC Unity XT 480F, Dell EMC Unity 600F, Dell EMC Unity 650F, Dell EMC Unity XT 680F, Dell EMC Unity XT 880F , Dell EMC Unity Family |Dell EMC Unity All Flash ...
Article Properties
Article Number: 000055614
Article Type: Solution
Last Modified: 20 Oct 2025
Version:  5
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