NMM 备份未能成功完成。内部错误

Summary: NetWorker Media Manager (NMM) 备份中止并显示内部错误;调试日志显示从 nsr res rmps.res检索 RM 服务端口信息失败,指示缺少 rmps.res 文件。

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

已从客户端主机中删除 \nsr\res\ 和 \nsr\tmp 文件夹。

Exchange DAG 备份失败,并显示以下错误:
NMM 备份未能成功完成。内部错误

备份日志中没有其他指示。

启用调试并运行备份(设置应用程序参数:NSR_PS_DEBUG_LEVEL=9。备份命令:nsrsnap_vss_save -D9)。nmm.raw显示以下错误:
Exch-Client123.FQDN nsrsnapagent NSR info 2 %s 1 0 111 [msg #274 vss_snapshotpriv.cpp 235 PSDBG 9] Error retrieving RM Service Port Information from /nsr/res/rmps.res

Cause

NMM 客户端主机上缺少 \nsr\res\rmps.res 文件。

注意:
错误消息“NMM 备份未能成功完成。“内部错误”非常常见,可能是由各种因素引起的。查找更具体的消息以确定故障原因。此知识库文章适用于调试日志显示以下错误的情况:

从 /nsr/res/rmps.res 检索 RM 服务端口信息时出错

Resolution

1.创建 \nsr\res\rmps.res 文件和端口详细信息,然后重新启动 “Replication Manager Client for RMAgentPS” 服务。

以下是选择默认端口的示例配置。

______________

type:RM 服务端口;
控制端口:6728;
数据端口:6729;


______________

Affected Products

NetWorker Module for Microsoft

Products

NetWorker Module for Microsoft
Article Properties
Article Number: 000056686
Article Type: Solution
Last Modified: 10 Dec 2025
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.