PowerFlex ScaleIO: después de volver a agregar un disco a un servidor, el sistema operativo no lo reconoce

Summary: El sistema operativo no reconoce un disco después de volver a agregarlo a un servidor.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms



Se probó la existencia de un disco fallido mediante la extracción manual del disco del servidor en línea
En el nivel del sistema operativo, el disco no se puede ver aunque se haya vuelto a agregar al servidor.
Esto no es realmente un problema de SIO.

Cause

Esto sucede porque el estado del disco se almacena en caché en un estado incorrecto.

Resolution

Realice los siguientes pasos:

Esta no es una manera recomendada para probar un disco fallido en un clúster de SIO.

Pídale al cliente que instale la utilidad de PERCCLI en el servidor Dell si aún no la tiene. (ver enlace a continuación para obtenerlo)

Obtenga el resultado del siguiente comando:

# /opt/MegaRAID/perccli/perccli64 /c0 show

Asegúrese de que el disco duro que se extrajo y devolvió esté visible en la lista de PD.

Compruebe si falta el VD (disco virtual).

Intente crear el VD si falta:

# opt/MegaRAID/perccli/perccli64 /c0 add vd type=raid0 drives=EID:Slt direct wt nora  ( this is for No ReadAhead (NR) WriteThrough (WT)

Es posible que aparezca un error:               

# /opt/MegaRAID/perccli/perccli64 /c0 add vd type=raid0 drives=EID:Slt                direct wt nora 
              Controller = 0
              Status = Failure
              Description = controller has data in cache for offline or missing virtual                disks

Si recibe el mensaje de error anterior, consulte el 500119 de la base de conocimientos: Los comandos de storcli no son efectivos https://www.dell.com/support/kbdoc/en-us/000065897/storcli-commands-not-effective A medida que utiliza la utilidad perccli, utilice el comando perrcli para comprobar si la caché está preservada:            

#/opt/MegaRAID/perccli/perccli64 /c0  show preservedcache

Si hay una caché preservada, el resultado muestra lo siguiente:            

#/opt/MegaRAID/perccli/perccli64 /c0  show preservedcache
           Controller = 0
           Status = Success
           Description = None
           -----------
           VD State  
            -----------
             16 Missing

Elimine la caché preservada con:

#opt/MegaRAID/perccli/perccli64 /c0/v16 delete preservedcache

A continuación, cree el VD con:

#opt/MegaRAID/perccli/perccli64 /c0 add vd type=raid0 drives=EID:Slt direct wt nora   

No debería ser necesario reiniciar y el disco ya debería verse en el nivel del sistema operativo. Compruébelo mediante la ejecución de lo siguiente:            

# ls -l /dev/disk/by-path | grep pci
           #ls -l /dev/disk/by-path | grep pci  | wc -l
           #fdisk -l | grep Disk
           #lsblk

  A continuación, debería poder volver a agregar el disco al inicio de sesión del clúster de SIO en la interfaz de usuario de ScaleIO. En la pantalla Backend SDS, haga clic con el botón secundario en el SDS y seleccione Add Device. Escriba el nombre del sistema operativo en el campo Path.    

Additional Information

Para descargar la utilidad de Perccli para Linux, vaya a:
https://downloads.dell.com/FOLDER03559396M/1/perccli-1.17.10-1.noarch.rpm
Copie el archivo de instalación, perccli-1.17.10-1.noarch.rpm, en la carpeta /tmp del nodo.
Desde la consola de Linux o mediante SSH, instale el paquete de PERCCLI:
#rpm -uvh /tmp/perccli-1.17.10-1.noarch.rpm


La Guía de referencia de la interfaz de línea de comandos (CLI) de las controladoras RAID PowerEdge (PERC) de Dell se puede encontrar en https://www.dell.com/support/kbdoc/en-us/000177280/how-to-use-the-poweredge-raid-controller-perc-command-line-interface-cli-utility-to-manage-your-raid-controller
   

 

Affected Products

PowerFlex Software

Products

PowerFlex Software, VxFlex Product Family
Article Properties
Article Number: 000058655
Article Type: Solution
Last Modified: 28 Oct 2024
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.