PowerFlex ScaleIO Dopo aver aggiunto nuovamente un disco a un server, il sistema operativo non lo riconosce

Summary: Il sistema operativo non riconosce un disco dopo averlo aggiunto nuovamente a un server.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms



Verifica della presenza di un disco guasto mediante estrazione manuale del disco dal server online
A livello di sistema operativo, il disco non può essere visualizzato anche se è stato aggiunto nuovamente al server.
In realtà non si tratta di un problema di SIO.

Cause

Ciò si verifica perché lo stato del disco è memorizzato nella cache in uno stato errato.

Resolution

Attenersi alla seguente procedura:

Non si tratta di un modo consigliato per verificare la presenza di un disco guasto in un cluster SIO.

Far installare al cliente l'utilità perccli sul server Dell, se non la ha già. (vedi link sotto per questo)

Ottenere l'output dal seguente comando:

# /opt/MegaRAID/perccli/perccli64 /c0 show

Assicurarsi che il disco rigido estratto e restituito sia visibile nell'elenco PD.

Verificare se il VD (disco virtuale) è mancante.

Provare a creare il disco virtuale se manca:

# opt/MegaRAID/perccli/perccli64 /c0 add vd type=raid0 drives=EID:Slt direct wt nora  ( this is for No ReadAhead (NR) WriteThrough (WT)

È possibile che venga visualizzato un errore:               

# /opt/MegaRAID/perccli/perccli64 /c0 add vd type=raid0 drives=EID:Slt                direct wt nora 
              Controller = 0
              Status = Failure
              Description = controller has data in cache for offline or missing virtual                disks

Se viene visualizzato il messaggio di errore riportato sopra, controllare l'500119 della KB: storcli commands not effective https://www.dell.com/support/kbdoc/en-us/000065897/storcli-commands-not-effective Poiché si utilizza l'utilità perccli, utilizzare il comando perrcli per verificare la presenza di cache preservata:            

#/opt/MegaRAID/perccli/perccli64 /c0  show preservedcache

Se è presente una cache conservata, l'output mostra:            

#/opt/MegaRAID/perccli/perccli64 /c0  show preservedcache
           Controller = 0
           Status = Success
           Description = None
           -----------
           VD State  
            -----------
             16 Missing

Eliminare la cache conservata con:

#opt/MegaRAID/perccli/perccli64 /c0/v16 delete preservedcache

Creare quindi il disco virtuale con:

#opt/MegaRAID/perccli/perccli64 /c0 add vd type=raid0 drives=EID:Slt direct wt nora   

Non dovrebbe essere necessario riavviare il sistema e il disco dovrebbe essere ora visibile a livello di sistema operativo. Controllare eseguendo quanto segue:            

# ls -l /dev/disk/by-path | grep pci
           #ls -l /dev/disk/by-path | grep pci  | wc -l
           #fdisk -l | grep Disk
           #lsblk

  A questo punto dovrebbe essere possibile aggiungere nuovamente il disco nel cluster SIO Accedere all'interfaccia utente di ScaleIO. Dalla schermata Backend SDS, cliccare con il pulsante destro del mouse sull SDS e selezionare Add Device. Digitare il nome del sistema operativo nel campo Path.    

Additional Information

Per scaricare l'utilità Perccli per Linux, accedere a:
https://downloads.dell.com/FOLDER03559396M/1/perccli-1.17.10-1.noarch.rpm
Copiare il file di installazione, perccli-1.17.10-1.noarch.rpm, nella cartella /tmp sul nodo.
Dalla console Linux o utilizzando SSH, installare il pacchetto
PERCCLI:#rpm -Uvh /tmp/perccli-1.17.10-1.noarch.rpm


La Guida di riferimento all'interfaccia della riga di comando (CLI) dei controller RAID Dell PowerEdge (PERC) è disponibile all'indirizzo:
https://www.dell.com/support/kbdoc/en-us/000177280/how-to-use-the-poweredge-raid-controller-perc-command-line-interface-cli-utility-to-manage-your-raid-controller   

 

Affected Products

PowerFlex Software

Products

PowerFlex Software, VxFlex Product Family
Article Properties
Article Number: 000058655
Article Type: Solution
Last Modified: 28 Oct 2024
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.