PowerFlex, ScaleIO: po ponownym dodaniu dysku do serwera system operacyjny go nie rozpoznaje

Summary: System operacyjny nie rozpoznaje dysku po dodaniu go z powrotem do serwera.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms



Przetestowano dysk uszkodzony przez ręczne wyciągnięcie dysku z serwera w trybie online
Na poziomie systemu operacyjnego dysk nie jest widoczny, nawet jeśli został ponownie dodany do serwera.
Tak naprawdę nie jest to problem SIO.

Cause

Dzieje się tak, ponieważ stan dysku jest w nieprawidłowym stanie.

Resolution

Wykonaj następujące czynności:

Nie jest to zalecany sposób testowania uszkodzonego dysku w klastrze SIO.

Poproś klienta, aby zainstalował narzędzie perccli na serwerze Dell, jeśli jeszcze go nie posiada. (zobacz link poniżej)

Pobierz dane wyjściowe z następującego polecenia:

# /opt/MegaRAID/perccli/perccli64 /c0 show

Upewnij się, że pobrany i zwrócony dysk twardy jest widoczny na liście PD.

Sprawdź, czy nie brakuje VD (dysku wirtualnego).

Spróbuj utworzyć VD, jeśli go brakuje:

# opt/MegaRAID/perccli/perccli64 /c0 add vd type=raid0 drives=EID:Slt direct wt nora  ( this is for No ReadAhead (NR) WriteThrough (WT)

Może wystąpić błąd:               

# /opt/MegaRAID/perccli/perccli64 /c0 add vd type=raid0 drives=EID:Slt                direct wt nora 
              Controller = 0
              Status = Failure
              Description = controller has data in cache for offline or missing virtual                disks

Jeśli zostanie wyświetlony powyższy komunikat o błędzie, sprawdź 500119 bazy wiedzy: Polecenia storcli nie działają https://www.dell.com/support/kbdoc/en-us/000065897/storcli-commands-not-effective Podczas korzystania z narzędzia perccli użyj polecenia perrcli, aby sprawdzić, czy pamięć podręczna jest zachowana:            

#/opt/MegaRAID/perccli/perccli64 /c0  show preservedcache

Jeśli istnieje zachowana pamięć podręczna, dane wyjściowe pokazują:            

#/opt/MegaRAID/perccli/perccli64 /c0  show preservedcache
           Controller = 0
           Status = Success
           Description = None
           -----------
           VD State  
            -----------
             16 Missing

Usuń zachowaną pamięć podręczną za pomocą polecenia:

#opt/MegaRAID/perccli/perccli64 /c0/v16 delete preservedcache

Następnie utwórz dysk wirtualny za pomocą:

#opt/MegaRAID/perccli/perccli64 /c0 add vd type=raid0 drives=EID:Slt direct wt nora   

Ponowne uruchomienie nie powinno być wymagane, a dysk powinien być teraz widoczny na poziomie systemu operacyjnego. Sprawdź, uruchamiając następujące polecenie:            

# ls -l /dev/disk/by-path | grep pci
           #ls -l /dev/disk/by-path | grep pci  | wc -l
           #fdisk -l | grep Disk
           #lsblk

  Następnie powinno być możliwe dodanie dysku z powrotem do klastra SIO Zaloguj się do interfejsu użytkownika ScaleIO. Na ekranie Backend SDS kliknij prawym przyciskiem myszy SDS i wybierz polecenie Dodaj urządzenie. Wpisz nazwę systemu operacyjnego w polu Ścieżka.    

Additional Information

Aby pobrać narzędzie Perccli dla systemu Linux, przejdź do:
https://downloads.dell.com/FOLDER03559396M/1/perccli-1.17.10-1.noarch.rpm
Skopiuj plik instalacyjny perccli-1.17.10-1.noarch.rpm do folderu /tmp w węźle.
Z konsoli systemu Linux lub za pomocą SSH zainstaluj pakiet PERCCLI:
#rpm -uvh /tmp/perccli-1.17.10-1.noarch.rpm


Podręcznik referencyjny interfejsu wiersza poleceń (CLI) kontrolerów RAID Dell PowerEdge (PERC) można znaleźć pod adresem https://www.dell.com/support/kbdoc/en-us/000177280/how-to-use-the-poweredge-raid-controller-perc-command-line-interface-cli-utility-to-manage-your-raid-controller
   

 

Affected Products

PowerFlex Software

Products

PowerFlex Software, VxFlex Product Family
Article Properties
Article Number: 000058655
Article Type: Solution
Last Modified: 28 Oct 2024
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.