Avamar: Dosyalar, VM yedeğinden FLR kullanarak geri yüklenemiyor

Summary: Proxy, yedekleme hedefi DNS adını çözemediği için dosyalar, FLR kullanılarak VM yedeğinden geri yüklenemiyor.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

N/A 

  • FLR kullanarak VM yedeklerine göz atma başarısız olursa aşağıdaki hata mesajı görüntülenir:
 
kA23a000000GJ2pCAG_3_0
  • Göz attığımız VM'ler bile herhangi bir FLR sınırına ulaşmıyor.
  • Proxy'deki FLR günlüklerini kontrol ederek, /usr/local/avamarclient/bin/logs dizininde yer alan MountMgr.log dosyasında aşağıdaki hata mesajını görebiliriz. Bu mesaj, proxy'nin yedekleme hedefi sunucusundan (DD) yedekleme listesini sağlayamadığını ve listenin orada olmadığını belirtir:
[MM - DEBUG] TID=140213502355139 MID=30870: sAssetPath = /mnt/dunion/<vCenter_name>/VirtualMachines/<VM_name_UUID>/by-number/0000149 [MM - DEBUG] TID=140213502355139 MID=30871: sClientId = [MM - DEBUG] TID=140213502355139 MID=30872: sMountedAvFS = /mnt/dunion/<vCenter_name>/VirtualMachines/<VM_name_UUID>/by-number/0000149/VMFiles [MM - ERROR] TID=140213502355139 MID=30873: HLPR_ListOfDirectories failed for /mnt/dunion/<vCenter_name>/VirtualMachines/<VM_name_UUID>/by-number/0000149/VMFiles [MM - FUNC] TID=140213502355139 MID=30874: IVmdkManager::GetAllAvailableDiskIndexes LEAVE [MM - ERROR] TID=9923 MID=30875: Unable to find backed up VMDK images for: /mnt/dunion/<vCenter_name>/VirtualMachines/<VM_name_UUID>/by-number/0000149
 
  • Avamar yardımcı programı düğümünden aşağıdaki gibi kontrol ederken yedekleme bulunsa bile:
mccli backup show --name=/<vCenter_name>/VirtualMachines/<VM_name_UUID>
0,23000,CLI command completed successfully.
Created LabelNum Size Retention Hostname Location Consistent Level Tier
------------------- -------- -------- --------- ---------------------------------- -------- ---------------- ------
yyyy-mm-dd hh:mm PM 149 ##.# GB D <AVAMAR_FQDN> Local file Active

 
  • Ayrıca doğru Avamar IP'sinin, aşağıdaki gibi zaten /usr/local/avamar/var dizinindeki axionfs.cmd dosyasında yer aldığını görebildik:
--server=xxx.xxx.xxx.xxx
--id=restoreonly
--password=#################################
--fuseoptions='-s -r -f -o allow_other,use_ino'
--primarybackupdir=by-number
--inactivity_timeout=172800
--encrypt=tls
--encrypt-strength=high
(END)

Cause

  • /usr/local/avamar/var dizinindeki en yeni axionfs_xxxxxxx_xxxx_xxxx_xxxxxxxxxxxx.log dosyasında aşağıdaki hatayı gördüğümüz için kullanılan proxy, Datadomain FQDN'yi çözemedi ya da hedef sunucuyu yedekleyemedi:
     

axionfs Info <10539>: Connecting to Data Domain Server "DD_FQDN"(1) (LSU: avamar-xxxxxxxxxx, User: "ddboost")
[axionfs] netsys::getaddrinfo failed for DD_FQDN: Name or service not known
axionfs Error <10541>: Failed to resolve Data Domain Server name "DD_FQDN" to an IP address. Data Domain login FAILED
axionfs Error <10512>: Problem logging into the DDR server index:1
axionfs Error <11014>: Could not open DDR for /, #146
[axionfs] context::loop: Nothing pending on server, only internal work (pending all=4, ext=0, int=0)
axionfs Warning <19046>: Unable to get ddr_files.xml for clientid <VM_CID> and backupid <backupid>
axionfs Warning <19047>: Unable to retrieve DDR info for 'VMConfiguration'
axionfs Error <41308>: Cannot iterate contents of '': Unable to set location information in direlem_iter for 'VMConfiguration'

Resolution

Bu sorunu çözmek için:
  • AVamar proxy'nin, proxy'de aşağıdaki komutu çalıştırarak FQDN'yi çözebildiğinden emin olun:
  1. nslookup <datadomain_FQDN>
  2. nslookup <datadomain_IP>
  • Datadomain için geçerli bir çıkış yoksa proxy'de /etc/resolve.conf dosyasını düzenleyin ve doğru DNS adını ekleyin. 
VEYA 
  • Proxy'deki /etc/hosts dosyasına Datadomain FQDN ve IP'si ekleyin.

Affected Products

Avamar

Products

Avamar, Avamar Client for VMware
Article Properties
Article Number: 000067854
Article Type: Solution
Last Modified: 06 Nov 2025
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.