NetWorker NVP-vProxy: Kopie zapasowe przestają odpowiadać, oczekując na woluminy zapisywalne, jeśli docelowa pula kopii zapasowych zawiera urządzenie tylko do odczytu

Summary: Rozwiązanie NetWorker VMware Protection (NVP) jest skonfigurowane z urządzeniem vProxy. W docelowej puli kopii zapasowych skonfigurowano wiele urządzeń z różnych MTree i jedno z urządzeń ma wybraną opcję Tylko do odczytu. Akcja tworzenia kopii zapasowej nie może zostać uruchomiona na pozostałych urządzeniach, a alerty konsoli NetWorker Management Console (NMC) wskazują, że oczekuje na woluminy zapisywalne. Tradycyjne akcje tworzenia kopii zapasowych NetWorker mogą pomyślnie zapisywać dane na dostępnych urządzeniach, jeśli w puli znajduje się urządzenie tylko do odczytu. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

  • Rozwiązanie NetWorker VMware Protection (NVP) jest skonfigurowane z urządzeniem vProxy.
  • Co najmniej jedna maszyna wirtualna (VM) w przepływie pracy ochrony nie zapisuje żadnych kopii zapasowych.
    • Nie można uruchomić operacji tworzenia kopii zapasowej na pozostałych urządzeniach i alerty programu NetWorker Management Console (NMC) wyświetlają komunikat z informacją, że oczekuje na woluminy z możliwością zapisu.
      oczekiwanie na alert woluminu zapisywalnego w NMC
    • Dziennik akcji tworzenia kopii zapasowej może zgłaszać następujące błędy:
      YYYY-MM-DD HH:mm:SS 2 5 0 14244 11312 0 NSR_NAME nsrvproxy_save NSR warning Unable to set up the direct save with server 'NSR_NAME'. Be sure network connectivity exists between client 'VCENTER_NAME' and storage node 'STORAGENODE_NAME' in both directions. Error: Unable to connect to the storage node on host STORAGENODE_NAME: nsrvproxy_save failed to authenticate with nsrmmd on host STORAGENODE_NAME: Timed out.
      ...
      YYYY-MM-DD HH:mm:SS 2 5 0 11248 11312 0 NSR_NAME nsrvproxy_save NSR warning Unable to set up the direct save with server 'NSR_NAME'. Be sure network connectivity exists between client 'VCENTER_NAME' and storage node 'STORAGENODE_NAME' in both directions. Error: The VM backup request is not valid.
  • W docelowej puli kopii zapasowych skonfigurowano wiele urządzeń z różnych MTree i jedno z urządzeń ma wybraną opcję Tylko do odczytu.
    • Media-Media> Pools-Pool> properties
      Kryteria wyboru puli nośników
    • Woluminy dyskowe nośników>:
      Woluminy dysków
  • Tradycyjne akcje tworzenia kopii zapasowych NetWorker mogą pomyślnie zapisywać dane na dostępnych urządzeniach, jeśli w puli znajduje się urządzenie tylko do odczytu.

 

Cause

Jest to znane ograniczenie w NetWorker, ponieważ przyrostowa kopia zapasowa rozwiązania vProxy używa wirtualnych syntetycznych pełnych kopii zapasowych (VSF) w Data Domain. To ograniczenie ma wpływ na wszystkie funkcje zależne od VSF (na przykład: kopie zapasowe vProxy, kopie zapasowe oparte na blokach i moduł NetWorker dla kopii zapasowych Microsoft), gdy wolumin Data Domain staje się tylko do odczytu w docelowej puli kopii zapasowych.

Kopie zapasowe klientów NetWorker Traditional nie korzystają z VSF, więc mogą korzystać z docelowej puli kopii zapasowych z urządzeniem tylko do odczytu.

 

Resolution

Opcja 1:

Zmień tryb głośności z "tylko do odczytu" na "dołączany".

UWAGA: Należy to zrobić tylko wtedy, gdy masz pewność, że dysk powinien zostać zapisany. Jeśli urządzenie musi pozostać "tylko do odczytu", zobacz opcję 2.
  1. Zaloguj się do konsoli NetWorker Management Console (NMC) przy użyciu konta administratora.

  2. Jeśli urządzenie jest zamontowane, odmontuj je w sekcji Urządzenia-Urządzenia>.

    1. Otwórz właściwości urządzenia i upewnij się, że funkcja Auto Media Management jest wyłączona. Jeśli ta opcja jest włączona, urządzenie automatycznie montuje się ponownie po wymontowaniu:
      Ustawienie automatycznego zarządzania multimediami
    2. Kliknij prawym przyciskiem myszy urządzenie i wybierz polecenie Odmontuj:
      Odmontowywanie urządzenia
  3. Przejdź do sekcji Media-Disk>Volumes. Kliknij prawym przyciskiem myszy wolumin tylko do odczytu i wybierz polecenie Zmień tryby> — możliwość dołączenia. "Konwertowanie urządzenia na tylko do odczytu" w Podręczniku administracyjnym NetWorker wskazuje, że uniemożliwia to użycie urządzenia w operacjach tworzenia kopii zapasowych, ale nadal może być używane do operacji odczytu (przywracania i klonowania), ale dotyczy to tylko tradycyjnych kopii zapasowych NetWorker.
    Zmień tryb na dołączany

  4. Wróć do Devices-Devices>. Kliknij urządzenie prawym przyciskiem myszy i wybierz polecenie Zamontuj.

    OSTRZEŻENIE: Nie klikaj przycisku "etykieta". Etykietowanie woluminu powoduje usunięcie wszystkich znajdujących się na nim danych.

Po dołączeniu woluminu i zamontowaniu urządzenia. Alert "oczekiwanie na wolumin zapisywalny" powinien zostać usunięty, a dane powinny zacząć być zapisywane w puli. Jeśli alert nie zostanie usunięty, zapoznaj się z poniższą bazą wiedzy, ponieważ istnieją inne potencjalne przyczyny, które również mogą mieć zastosowanie: NetWorker: Rozwiązywanie problemów ze zdarzeniami oczekiwania na nośnik — oczekiwanie na jeden zapisywalny wolumin lub brak pasujących urządzeń

Opcja 2:

Jeśli urządzenie tylko do odczytu musi pozostać w docelowej puli kopii zapasowych, należy je wyłączyć, aby nowe kopie zapasowe mogły zostać ukończone. Aby wyłączyć urządzenie, należy je odmontować. Zapoznaj się z powyższymi krokami 1–2, aby odmontować urządzenie. Po wymontowaniu urządzenia kliknij je prawym przyciskiem myszy i wybierz opcję Włącz/Wyłącz. W kolumnie "enabled" urządzenia widnieje wartość "no". Kolejne kopie zapasowe maszyny wirtualnej są zapisywane na innych woluminach w puli.

UWAGA: Nowe kopie zapasowe nie mogą utworzyć kopii zapasowej VSF, więc wykonywana jest nowa pełna kopia zapasowa maszyny wirtualnej.

 

Additional Information

Affected Products

NetWorker

Products

NetWorker
Article Properties
Article Number: 000069413
Article Type: Solution
Last Modified: 18 Mar 2025
Version:  6
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.