Avamar: Timed Out - End due to File count per backup

Summary: Knowledge base (KB) article that provides instructions for creating multiple cache prefixes.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

The Avamar client backup is failing with "Timed Out - End" status message in the Avamar Administrator console or Avamar User Interface (AUI).



 

Cause

The server has too many files included for backup. The avtar process takes too long to scan all the files and is not able to complete within the allocated backup window.

A typical backup should take about one hour for every million files in a file server. The backup window is 12 hours, but the client has 20 million files to backup. Therefore, the avtar process does not have enough time to scan through all files to check for changed data for backup and update the file cache.

Resolution

Break the client file system into multiple smaller datasets.

Refer to the most recent version of the Avamar Operational Best Practices Guide, under the "Using CachePrefix" section.

From the Guide:

Assume that a client has 5.5 million files but only 1.5 GB of RAM. One volume has 2.5 million files, and three other volumes have 1 million files each. Break this client file system into four datasets. A volume with 2.5 million files requires a file cache of at least 110 MB (2.5 x 44 MB). The next increment that accommodates this is 176 MB.
 
Define other datasets as shown in the following table.
 
Drive                            Attribute settings
C:\ drive (2.5 M files) filecachemax=220
                                     hashcachemax=30
                                     cacheprefix=driveC
E:\ drive (1.0 M files) filecachemax=88
                                     hashcachemax=30
                                     cacheprefix=driveE
F:\ drive (1.0 M files) filecachemax=88
                                     hashcachemax=30
                                     cacheprefix=driveF
G:\ drive (1.0 M files) filecachemax=88
                                      hashcachemax=30
                                      cacheprefix=driveG

Configure cacheprefix in the dataset by setting Enter Attribute = cacheprefix and Enter Attribute Value = driveC.

The following cache files are located in the Avamar /var directory on the client:
 
driveC_f_cache.dat
driveC_p_cache.dat
driveE_f_cache.dat
driveE_p_cache.dat
driveF_f_cache.dat
driveF_p_cache.dat
driveG_f_cache.dat
driveG_p_cache.dat

 
Ensure that adequate disk space is available to accommodate the additional file and hash caches.
 
When specifying various cacheprefix values, ensure that new cache files are excluded from the backups. The cache files are large and have high change rates.

Temporarily enable overtime on the backup until the backups for each of the split datasets completes successfully.
 
Custom cache settings for Windows client: 
 
  1. From the Edit Dataset or New Dataset dialog box, select the Options tab.
  2. Click More.
    1. Type the attribute/value pair:
    2. In the Enter Attribute field, type [avtar]filecachemax.
    3. In the Enter Attribute Value field, type 200.
    4. Click the + button.
    5. In the Enter Attribute field, type [avtar]hashcachemax.
    6. In the Enter Attribute Value field, type 30.
    7. In the Enter Attribute field, type [avtar]cacheprefix
    8. In the Enter Attribute Value field, type driveC.
  3. Click OK button to save changes to the dataset.

Additional Information

 

 

 

Affected Products

Avamar, Avamar Client for Linux, UNIX, MacOSX, Avamar Client for Windows
Article Properties
Article Number: 000163298
Article Type: Solution
Last Modified: 08 Sept 2025
Version:  4
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