AppSync. Сбой восстановления из-за несоответствия SQL Server версии s
Summary: Восстановление завершается сбоем с сообщением об ошибке: «Версия производственного экземпляра SQL Server выше, чем версия экземпляра монтирования. Восстановление невозможно инициировать, если версии на обоих серверах не совпадают». ...
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
Обновлен AppSync с версии 3.x до версии 3.7 или более поздней, а также обновлен агент хоста продукта, но не агент хоста монтирования.
После модернизации AppSync 3.5 до AppSync 3.7 или более поздней версии возможны сбои планов обслуживания на этапе восстановления. Указанная ниже ошибка отображается в графическом интерфейсе пользователя AppSync.
Ошибка, отображаемая в событиях плана обслуживания:
В журналах сервера отображается ошибка:
После модернизации AppSync 3.5 до AppSync 3.7 или более поздней версии возможны сбои планов обслуживания на этапе восстановления. Указанная ниже ошибка отображается в графическом интерфейсе пользователя AppSync.
Ошибка, отображаемая в событиях плана обслуживания:
Номер> версии <версии SQL Server производственного экземпляра выше, чем номер> версии <версии экземпляра монтирования. Восстановление невозможно инициировать, если версии на обоих серверах не совпадают.
В журналах сервера отображается ошибка:
22.02.2018 21:44:27.198 INFO [EJB по умолчанию - 5] [com.emc.archway.service.eventservice.EventServiceBean] [Host_Name] [] d1xxxxxxxxxxxxxxxxxx>>>- СОБЫТИЕ [SQL_000028]: Версия < SQL ServerНомер> версии производственного экземпляра ABC выше, чем номер> версии <экземпляра монтирования XYZ . Восстановление невозможно инициировать, если версии на обоих серверах не совпадают. (МЕТАДАННЫЕ: TYPE-ERROR, TIME-2018-02-22 21:44:27.198-0800NATIVETIME-2018-02-22 21:44:27.198-0800, HOST-Host_ Name, PHASE-Recover copy, THREAD=EJB, default - 5, USER-User_Name, CATEGORY-GENERIC, SESSIONID-f4-20V8nudbHq8155MOFFTZkHayb1PYEgeAaELoj)
22.02.2018 21:44:27.198 ОШИБКА [EJB по умолчанию - 5] [com.emc.archway.commands.application.RunApplicationRecoveryCommandBean] [Host_Name] [] d1xxxxxxxxxxxxxxxxxx>>>- Возникло исключение: IncompatibleSqlInstanceVersion, сообщение: Номер> версии версии производственного экземпляра SQL Server <ABC выше, чем номер> версии <экземпляра монтирования XYZ. Восстановление невозможно инициировать, если версии на обоих серверах не совпадают.
22.02.2018 21:44:27.198 ОШИБКА [EJB по умолчанию - 5] [com.emc.archway.commands.application.RunApplicationRecoveryCommandBean] [Host_Name] [] d1xxxxxxxxxxxxxxxxxx>>>- Возникло исключение: IncompatibleSqlInstanceVersion, сообщение: Номер> версии версии производственного экземпляра SQL Server <ABC выше, чем номер> версии <экземпляра монтирования XYZ. Восстановление невозможно инициировать, если версии на обоих серверах не совпадают.
Cause
Это может наблюдаться в следующих обстоятельствах:
- Версия SQL Server на производственном узле и хосте монтирования может быть одинаковой, но на SQL Server установлено накопительное обновление или пакет обновления, что приводит к увеличению меньшего количества версий экземпляра SQL.
- Производственный узел работает под управлением AppSync 3.7, а хост монтирования — под управлением версии 3.5 или более ранней. Восстановление завершится сбоем из-за того, что AppSync обнаружит несоответствие версии, если на хосте монтирования не запущен агент AppSync версии 3.7.
Resolution
Временное решение.
- Проверьте версию подключаемого модуля хоста AppSync, установленную на производственном хосте и хосте монтирования.
- Версия подключаемого модуля хоста AppSync на хосте монтирования должна быть такой же, как на производственном хосте.
- В случае несоответствия версии AppSync обновите подключаемый модуль хоста в разделе Хост монтирования и повторно выполните поиск хоста на сервере AppSync.
Products
AppSyncArticle Properties
Article Number: 000167338
Article Type: Solution
Last Modified: 18 Sept 2025
Version: 5
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.