AppSync : Échec de la récupération en raison d’une incompatibilité entre les versions de SQL Server

Summary: La restauration échoue avec le message d’erreur « La version SQL Server de l’instance de production est supérieure à la version de l’instance de montage. La récupération ne peut pas être initiée si les versions sur les deux serveurs ne correspondent pas. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Mise à jour d’AppSync de la version 3.x vers la version 3.7 ou ultérieure et mise à jour de l’agent hôte produit, mais pas de l’agent hôte de montage.

Après la mise à niveau d’AppSync 3.5 vers AppSync 3.7 ou une version ultérieure, les plans de service peuvent échouer pendant la phase de récupération. L’erreur ci-dessous est visible dans l’interface utilisateur d’AppSync.

Erreur détectée dans les événements du plan de service : 
Le numéro> de version de SQL Server <de l’instance de production est supérieur au numéro> de version de l’instance <de montage. La récupération ne peut pas être lancée si les versions sur les deux serveurs ne correspondent pas.

Erreur détectée dans les fichiers log du serveur : 
02-22-2018 21:44:27.198 INFO [EJB default - 5] [com.emc.archway.service.eventservice.EventServiceBean] [Host_Name] [] d1xxxxxxxxxxxxxxxxxx->>>EVENT [SQL_000028] :  Version de SQL Server <Le numéro> de version de l’instance de production ABC est supérieur au numéro> de version <de l’instance de montage XYZ . La récupération ne peut pas être lancée si les versions sur les deux serveurs ne correspondent pas. (MÉTADONNÉES : TYPE-ERROR, TIME-2018-02-22 21:44:27.198-0800NATIVETIME-2018-02-22 21:44:27.198-0800, HOST-Host_ Name, PHASE-Recover copy, THREAD=EJB default - 5, USER-User_Name, CATEGORY-GENERIC, SESSIONID-f4-20V8nudbHq8155MOFFTZkHayb1PYEgeAaELoj)
02-22-2018 21:44:27.198 ERROR [EJB default - 5] [com.emc.archway.commands.application.RunApplicationRecoveryCommandBean] [Host_Name] [] d1xxxxxxxxxxxxxxx->>>Une exception s’est produite : IncompatibleSqlInstanceVersion, Message :  Le numéro> de version de version de SQL Server <de l’instance de production ABC est supérieur au numéro> de version <de l’instance de montage XYZ. La récupération ne peut pas être lancée si les versions sur les deux serveurs ne correspondent pas.

Cause

Cela peut se produire dans les circonstances suivantes : 
  • La version de SQL Server sur le serveur de production et sur le serveur de montage peut être identique, mais SQL Server dispose d’une mise à jour cumulative ou d’un correctif installé, ce qui entraîne une augmentation mineure du nombre de versions de l’instance SQL.
  • Le serveur de production exécute AppSync 3.7 et l’hôte de montage exécute la version 3.5 ou une version antérieure. La récupération échoue en raison de la détection par AppSync d’une discordance de version si l’hôte de montage n’exécute pas la version 3.7 de l’agent AppSync.
Avant AppSync 3.7, AppSync n’affichait que la version de base de l’instance SQL. Après la mise à niveau d’AppSync vers la version 3.7, la version de l’instance SQL s’affiche et identifie la version de SQL, ainsi que tout Service Pack ou mise à jour cumulative qui y est installé.

Resolution

Solution de contournement : 
  1. Vérifiez la version du plug-in hôte AppSync installée sur le serveur de production et l’hôte de montage.
  2. La version du plug-in hôte AppSync sur l’hôte de montage doit être identique à celle de l’hôte de production.
  3. Si la version d’AppSync ne correspond pas, mettez à jour le plug-in Host dans Mount Host et effectuez une nouvelle détection de l’hôte dans AppSync Server.

Products

AppSync
Article Properties
Article Number: 000167338
Article Type: Solution
Last Modified: 18 Sept 2025
Version:  5
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.