NVP – vProxy: Virtuální počítač ztratí připojení během procesu odstraňování snapshotu.

Summary: Během kroku odebrání snapshotu úlohy vProxy zdrojový virtuální počítač (VM) dočasně ztratí připojení.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Protokol relace zálohování vProxy zobrazí, když jsou vytvořeny požadavky na snapshot:

YYYY/MM/DD HH:MM:SS TRACE: [NW_BUILD] Sending remove snapshot request to Snapshot Manager ...
YYYY/MM/DD HH:MM:SS TRACE: [NW_BUILD] Sending remove snapshot request to Snapshot Manager ...
YYYY/MM/DD HH:MM:SS INFO: [NW_BUILD] Remove snapshot request accepted by Snapshot Manager.
YYYY/MM/DD HH:MM:SS INFO: [NW_BUILD] Remove snapshot request accepted by Snapshot Manager.
POZNÁMKA: Protokoly relace naleznete v serveru vProxy ve složce /opt/emc/vproxy/runtime/logs/vbackupd/ nebo /opt/emc/vproxy/runtime/logs/recycle/vbackupd/


V vbackupd-snapmgr.log vProxy se může zobrazit chyba, například:

YYYY/MM/DD HH:MM:SS INFO: Found virtual machine "VM-NAME" with MORef "vm-###".
YYYY/MM/DD HH:MM:SS NOTICE: Virtual machine "VM-NAME" requires consolidation of its virtual disks.
YYYY/MM/DD HH:MM:SS ERROR: Failed to complete consolidation of virtual disks for "VM-NAME" (vm-###): Unable to access file since it is locked
YYYY/MM/DD HH:MM:SS WARN: Failed to consolidate virtual disks of virtual machine "VM-NAME" (vm-###): Failed to complete consolidation of virtual disks for "VM-NAME" (vm-###): Unable to access file since it is locked.
YYYY/MM/DD HH:MM:SS WARN: Failed to consolidate virtual disks of virtual machine "VM-NAME" (vm-###): Failed to complete consolidation of virtual disks for "VM-NAME" (vm-###): Unable to access file since it is locked.
YYYY/MM/DD HH:MM:SS NOTICE: Snapshot "snapshot-###" of virtual machine "VM-NAME" (vm-###) was removed.
POZNÁMKA: vbackupd-snapmgr.log naleznete v části:  /opt/emc/vproxy/runtime/logs/vbackupd/ nebo /opt/emc/vproxy/runtime/logs/recycle/daemon/


V protokolech událostí v operačním systému virtuálního počítače se může zobrazit chyba, například:

The mirroring connection to "TCP://VM-NAME:5022" has timed out for database "out" after 10 seconds without a response. Check the service and network connections"
Event ID: 1479.

vmware.log virtuálního počítače (nachází se ve složce datového úložiště VMware ve virtuálním počítači) může obsahovat další informace o procesu odstranění snapshotu.

Cause

NetWorker/vProxy neodstraní samotný snapshot. Nástroj VMware vCenter řídí vytváření, správu a odstraňování snímků virtuálních počítačů. NetWorker zahájí zálohování odesláním požadavku společnosti VMware na vytvoření snapshotu. Na konci odešle požadavek na odstranění snímku.

Odstranění snímku snižuje počet vstupů/výstupů za sekundu (IOPS) virtuálního počítače. K tomu dochází kvůli dodatečným zámkům úložiště VMFS (Virtual Machine File System) kvůli zvýšeným aktualizacím metadat a zvýšenému zatížení IOP během procesu odebrání. Pokud cílové úložiště běží nad 30–40 % zatížení IOP, odebrání snímku může hodnotu překročit 80 %. Tento špička často způsobuje latenci a poškozuje výkon aplikací.

NVP vProxy: Odstraňování problémů se snapshoty VMware během zálohování NetWorker.

Resolution

Testování izolace:

Chcete-li izolovat problém na konkrétní událost odebrání snapshotu VMware, postupujte následovně:
 
VÝSTRAHA: Níže uvedené kroky proveďte v době, kdy připojení k virtuálnímu počítači není citlivé, například mimo špičku.
  1. Přihlaste se k serveru vCenter nebo klientovi vSphere.
  2. Vytvořte snímek na daném virtuálním počítači.
  3. Ponechte snapshot na virtuálním počítači po dobu, po kterou úloha vProxy na virtuálním počítači spustí.
  4. Spusťte příkaz ping na IP adresu nebo název hostitele virtuálního počítače.
Linux:
ping -D VM_IP
Windows (Powershell): 
ping -t VM_IP | Foreach{"{0} - {1}" -f (Get-Date),$_}
Oba výše uvedené příkazy označí pingem časové razítko. 
  1. Odstraňte snapshot.
  2. Sledujte virtuální počítač během odebírání snapshotu.
Pokud se při provádění výše uvedeného testu vyskytnou stejné problémy s připojením jako při zálohování vProxy, pravděpodobně se jedná o problém v prostředí VMware. Chcete-li provést další šetření, otevřete případ podpory u podpory společnosti VMware.

Pro virtuální počítače uložené v datovém úložišti NFSv3:

Pokud zálohujete virtuální počítače, které jsou uložené v datovém úložišti NFSv3 a pozorujete problémy s připojením, přečtěte si článek znalostní databáze VMware: https://kb.vmware.com/s/article/2010953Tento hypertextový odkaz vás zavede na webové stránky mimo společnost Dell Technologies.

společnost VMware hlásí tento konkrétní problém jako vyřešený při použití hostitelů VMware ESXi ve verzi 8.0u2b (nebo novější)

Pro řešení používající NFSv3 pro verze ESXi starší než 8.0u2b jsou k dispozici následující možnosti. Je třeba zvážit jednu z následujících možností.
  • Nasaďte zařízení NVP vProxy na stejného hostitele ESXi jako virtuální počítače, které jsou omráčeny.
  • Zvažte použití protokolu NFSv4 pro připojení datových úložišť NFS. 
POZNÁMKA: Před implementací systému NFS 4.1 si přečtěte článek NFS Protocols a vSphere SolutionsNFS Datastore Concepts and Operations in vSphere Environment.Tento hypertextový odkaz vás zavede na webové stránky mimo společnost Dell Technologies.NFS 4.1 používá jiné uzamykací mechanismy než NFSv3 - viz Uzamykací mechanismy.
  • Nakonfigurujte zařízení vProxy, která zálohují tyto virtuální počítače, tak, aby místo HotAddu používala NBD. Kdykoli je to možné, upřednostňuje se použití horkého přidání, protože obecně funguje lépe než NBD. Vysoká zátěž NBD může negativně ovlivnit sítě pro správu VMware. Tato možnost by měla být provedena pouze v případě, že ostatní uvedené možnosti nejsou možné. 
Servery vProxies lze nakonfigurovat tak, aby zálohovaly pouze pomocí protokolu NBD. V konzoli NetWorker Management Console (NMC) –> zařízení –> VMware proxy:
Nastavení relace NBD
POZNÁMKA: Nastavením "hot add" na 0 se deaktivuje transportní režim hot add. 

Additional Information

Další postupy odstraňování problémů:

  • Zkontrolujte, zda virtuální počítač neobsahuje snímky, když není spuštěná žádná úloha, a odeberte všechny, které byly nalezeny.
  • Zkontrolujte osamocené snímky na virtuálním počítači. 
  • Snižte počet souběžných záloh virtuálních počítačů, ke kterým dochází v tomto datovém úložišti nebo hostiteli. Doporučení ohledně výkonu a škálovatelnosti naleznete v průvodci integrací NetWorker VMware. https://www.dell.com/support/home/product-support/product/networker/docs
  • Pokud se prostředky procesoru virtuálního počítače během konsolidace snímků výrazně zvýší, zvažte zvýšení rezervace procesoru pro tento virtuální počítač.
  • Přesuňte virtuální počítač na hostitele s více dostupnými prostředky.
  • Pokud se jedná o virtuální počítač serverové zařízení vCenter, přečtěte si článek Vzorové postupy pro zálohování a obnovení serveru vCenter v Příručce integrace NetWorker VMware: https://www.dell.com/support/home/product-support/product/networker/docs


VMware KB 1002836Tento hypertextový odkaz vás zavede na webové stránky mimo společnost Dell Technologies. | Odstranění snapshotu může zastavit virtuální počítač na dlouhou dobu.

Zkontrolujte balíček podpory VMware vCenter a nezapomeňte shromáždit systémové protokoly ESXi pro systémy ESXi, které jsou hostiteli virtuálních počítačů, u nichž se tento příznak projevil. V části \var\run\log\vmkernel.log hostitele ESXi se mohou během operací snapshotu vykazovat problémy s latencí úložiště:

YYYY-MM-DDTHH:mm:SS cpu10:2098132)WARNING: ScsiDeviceIO: 1498: Device naa.############# performance has deteriorated. I/O latency increased from average value of 1429 microseconds to 29874 microseconds.

K dalšímu šetření je nutné zapojit dodavatele úložiště.

Affected Products

NetWorker

Products

NetWorker
Article Properties
Article Number: 000167629
Article Type: Solution
Last Modified: 10 Nov 2025
Version:  8
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.