AppSync: Odzyskiwanie bazy danych Oracle kończy się niepowodzeniem podczas próby zmiany właściciela miejsca docelowego dziennika archiwum

Summary: Polecenie chown katalogu dziennika archiwum kończy się niepowodzeniem, ponieważ sam katalog nie istnieje na hoście montowania.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms



Podczas próby zamontowania i odzyskania kopii bazy danych Oracle plan serwisowy kończy się niepowodzeniem na etapie "pre-Recover Database" z następującymi błędami:

Zdarzenia planu serwisowego zostaną wyświetlone:
Odzyskaj kopię, MILE_000005,AppSync< Server,Odzyskaj> fazę kopiowania dla <DBNAME> zakończoną z błędami
Recover copy, GENL_000055,AppSync< Server,An> error occurred while running preRecoverDatabase on host <MOUNTHOST>. Aby uzyskać więcej informacji, zapoznaj się xxx.log na hoście agenta.

Dziennik serwera AppSync będzie zawierać następujące wpisy:
ERROR [EJB default - 6] [com.emc.archway.service.sshservice.SshServiceBean] [<AppSync Server>] [] ->>> ACP failed, zrzucanie stderr: Traceback (most recent call last):
  Plik "/usr/local/lib/python3.3/site-packages/cx_Freeze/initscripts/Console3.py", wiersz 27, w <module
> Plik "acp.py", wiersz 146, w <module>
Plik "acp.py", wiersz 118, w głównym
pliku "generic/oracle.py", wiersz 117, w przebiegu
Plik "generic/oracle.py", wiersz 618, w preRecoverDatabase
Plik "generic/oracle.py", wiersz 2928, w pliku preRecoverDatabase
"generic/oracle.py", wiersz 4458, w changeOwner
  Plik "/jenkins/lglbi061/workspace/Build-Linux-3.8.0.0/urm/appsync/3.8.0.0/integration/acp/src/appsync/acputil.py", wiersz 656, w execute
acputil. Wyjątek powłoki: Polecenie 'chown -R 1000:1000 /archiwum/
<Nazwa>_systemu plików/' nie powiodła się z kodem błędu 1: ['chown: nie można uzyskać dostępu do \u20xx/archiwum/<Nazwa> systemu plików/\u20yy: Nie ma takiego pliku ani katalogu']

Dziennik wtyczki AppSync na hoście montowania, do którego odwołuje się zdarzenie planu obsługi w celu wyświetlenia w celu uzyskania dodatkowych informacji, pokaże wykonywane polecenie, ale nic nie nastąpi, na przykład:
acputil.py[643]:execute() Info:Uruchomione polecenie: chown -R 1000:1000 /archives/<DBNAME>/

Cause

Katalog dziennika archiwum został utworzony jako /archive/<nazwa systemu> plików podczas tworzenia bazy danych oracle, ale nazwa systemu plików, na którym został zamontowany, to /archive. W bazie danych AppSync miejsce docelowe archiwum jest zapisywane jako /archive/<Filesystem name>, ta sama nazwa, która została podana podczas tworzenia bazy danych.

Gdy AppSync montuje kopię i próbuje odzyskać, pobiera miejsce docelowe z bazy danych AppSync i próbuje zmienić właściciela w miejscu docelowym. Ponieważ AppSync zainstalował go jako /archive, nazwa> /archive/<Filesystem nie istnieje na hoście montowania. Powodem jest to, że ścieżka nie jest określona w "ustawieniach mapowania ścieżek" dla /archive, co domyślnie zamontuje ją do /archive na hoście montowania.

Nazwa katalogu /archive/<Filesystem> nie istnieje na hoście montowania, ale podczas zmiany uprawnień AppSync znajdzie nazwę z bazy danych.

Resolution

Inżynierowie AppSync opublikowali poprawkę rozwiązującą ten problem. Otwórz zgłoszenie w dziale pomocy technicznej firmy Dell EMC i podaj ten identyfikator artykułu, aby otrzymać poprawkę. 

Ta poprawka zostanie włączona do przyszłych wersji AppSync. Sprawdź przyszłe informacje dotyczące wydania, aby potwierdzić, czy ten problem został rozwiązany w wersji, którą chcesz zainstalować.

Additional Information

Informacje te przetłumaczono na inne języki: 
https://downloads.dell.com/TranslatedPDF/AR-SA_537205.pdf
https://downloads.dell.com/TranslatedPDF/DE_537205.pdf
https://downloads.dell.com/TranslatedPDF/ES_537205.pdf
https://downloads.dell.com/TranslatedPDF/ES-XL_537205.pdf
https://downloads.dell.com/TranslatedPDF/FR_537205.pdf
https://downloads.dell.com/TranslatedPDF/IT_537205.pdf
https://downloads.dell.com/TranslatedPDF/JA_537205.pdf
https://downloads.dell.com/TranslatedPDF/KO_537205.pdf
https://downloads.dell.com/TranslatedPDF/NL_537205.pdf
https://downloads.dell.com/TranslatedPDF/PT_537205.pdf
https://downloads.dell.com/TranslatedPDF/PT-BR_537205.pdf
https://downloads.dell.com/TranslatedPDF/RU_537205.pdf
https://downloads.dell.com/TranslatedPDF/SV_537205.pdf
https://downloads.dell.com/TranslatedPDF/ZH-CN_537205.pdf
https://downloads.dell.com/TranslatedPDF/ZH-TW_537205.pdf

Affected Products

AppSync

Products

AppSync
Article Properties
Article Number: 000168360
Article Type: Solution
Last Modified: 18 Sept 2025
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.